Results 1 to 4 of 4

Thread: __gitps1() does not show changes (branch*)

  1. #1

    Default __gitps1() does not show changes (branch*)

    __gitps1() on openSUSE alsways shows (branch), even if there have been changes

    every other computer I am shows (branch*) if there have been changes,

    if this a bug on openSuse?
    this is extreme irritating

  2. #2

    Default Re: __gitps1() does not show changes (branch*)

    I have opened a bug report for this
    https://bugzilla.opensuse.org/show_bug.cgi?id=1088732

    lets see if this helps

  3. #3

    Default Re: __gitps1() does not show changes (branch*)

    Quote Originally Posted by a4z View Post
    __gitps1() on openSUSE alsways shows (branch), even if there have been changes

    every other computer I am shows (branch*) if there have been changes,

    if this a bug on openSuse?
    this is extreme irritating
    Not sure, but it can be only different default settings: http://blog.backslasher.net/git-prompt-variables.html

    Edit: Just tested this and it works:
    GIT_PS1_SHOWDIRTYSTATE=y __git_ps1

  4. #4

    Default Re: __gitps1() does not show changes (branch*)

    yes, thanks,
    got even more info in the bug report

    GIT_PS1_SHOWDIRTYSTATE
    GIT_PS1_SHOWSTASHSTATE
    GIT_PS1_SHOWUNTRACKEDFILES
    have copied my bashrc so long that I have forgotten how to write a new one :-)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •