Results 1 to 5 of 5

Thread: LEAP 15.0 BETA BUILD 191.1 - Can't enter password to log in

  1. #1

    Default LEAP 15.0 BETA BUILD 191.1 - Can't enter password to log in

    Hello,

    Previously I had installed Build 189.1 but because my video card has just died resulting in the screen showing "input not recognized", I decided to install Build 191.1 today (KDE - amd64)
    After initial reboot, I got a login screen and a mouse cursor arrow but I cannot log in. There's no blinking on the password box. My replacement video card is GeForce 7300GT.

    Any suggestions for solutions? Thank you very much.


  2. #2

    Default Re: LEAP 15.0 BETA BUILD 191.1 - Can't enter password to log in

    I have to thank "oldcpu" for one of his recent post which shows a workaround:

    1. During installation, hit "CANCEL" when the screen shows a warning about "mesa-dri-nouveau";

    2. If not, reboot and enter "nomodeset" (before "splash=silent quiet showopts" ) as a kernel boot option at the GRUB menu. Once signed in, go to YAST > Software Management to remove "mesa-dri-nouveau";

    3. Finally, reboot as normal and this time don't enter "nomodeset".


  3. #3

    Default Re: LEAP 15.0 BETA BUILD 191.1 - Can't enter password to log in

    I have same problem. It happened with kernel 4.12.14-lp150.7.2 and after zypper dup gave me kernel lp150.7.5, it still happens. Fortunately, I started with an older build and have kernel lp150.6 which works fine.
    I am using a small form factor PC to test Leap beta, but I do not have a spare graphics card to see if that solves the problem.
    Hardware is Intel Q67 chipset and Nvidia G98 GPU.

  4. #4

    Default Re: LEAP 15.0 BETA BUILD 191.1 - Can't enter password to log in

    Today after I booted into Leap 15.0 Beta via Grub menu, the screen shows a command line login page starting with user id instead of the usual Plasma login page with user id and password boxes. It appears that "nomodeset" is in front of "resume....splash=silent quiet showopts".

    Hardware: AMD64 CPU with 8 GB RAM and GeForce 6600GT video card.

    After removing "nomodeset" from in front of "resume..." and booting into Leap, I was able to get the usual login page.

    I then edited the /etc/default/grub file to put "nomodeset" in front of splash= silent...", saved the file.

    After running "grub2-mkconfig -o /boot/grub2/grub.cfg" and rebooting into Leap 15.0, I still got the same command line log in page.

    I guess when I installed Leap Beta, I put "nomodeset" on the boot option window and this must be why it keeps appearing in the Grub menu's kernel boot option.

    I would appreciate your suggestions to get the KDE plasma login page consistently.

    Thanks a lot for your help.


  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,664
    Blog Entries
    3

    Default Re: LEAP 15.0 BETA BUILD 191.1 - Can't enter password to log in

    Quote Originally Posted by taytong888 View Post
    I would appreciate your suggestions to get the KDE plasma login page consistently.
    Editing "/etc/default/grub" and then regenerating "grub.cfg" should do what you want.

    When I read what you posted there, the changes that you made to "/etc/default/grub" are the opposite to the changes that you made to the command line. They have to both be changed the same way.

    Maybe recheck what you did.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •