Results 1 to 4 of 4

Thread: Can't get into Plasma after upgrading graphics card

  1. #1

    Default Can't get into Plasma after upgrading graphics card

    I've used KDE/Plasma ever since installing Tumbleweed without issue. I recently upgraded my graphics card from an AMD RX 580 to an AMD RX Vega 56, and now when I enter my password into SDDM and log in, it takes me right back to the login screen. I can log into IceWM and even Plasma Wayland (although it's still all but unusable), just not regular Plasma. Is there a driver difference between the two cards that I need to correct? I also tried rolling back to an earlier snapshot but am unable to boot into any, as I get a GRUB error about a null source scalable image or something like that, have yet to investigate that issue.

    Also I'm not too familiar with how/where to get logs from, but upon further instruction ought to be able to get some of those.

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,277

    Default Re: Can't get into Plasma after upgrading graphics card

    I am not sure about this but it might be down to a hardware acceleration mismatch. According to Wikipedia the Vega chips mandate the use of the AMDGPU drm driver, whereas all the others use the Radeon drivers.
    https://en.wikipedia.org/wiki/List_o...ocessing_units

    You can show your graphics installation with:
    Code:
     # hwinfo --gfxcard
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  3. #3
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    280

    Default Re: Can't get into Plasma after upgrading graphics card

    Actually, the RX 580 uses the amdgpu driver as well. I've got an RX 480 and use it. I believe that RX 300 series and newer use the amdgpu driver.
    Over the last couple of months, there have been at least a couple of mesa updates that broke things on my Plasma system. I keep LXDE for such situations. Subsequent updates seemed to take care of the problem. There were a couple of posts concerning the problem, but I don't have them bookmarked. It might be prudent to check that your mesa and xorg packages are at least from the same repo.
    One difference between our systems that may be worth mentioning is that I use kdm as my display manager. It's just a personal preference on my part.

  4. #4

    Default Re: Can't get into Plasma after upgrading graphics card

    Quote Originally Posted by purevw View Post
    Actually, the RX 580 uses the amdgpu driver as well. I've got an RX 480 and use it. I believe that RX 300 series and newer use the amdgpu driver.
    Over the last couple of months, there have been at least a couple of mesa updates that broke things on my Plasma system. I keep LXDE for such situations. Subsequent updates seemed to take care of the problem. There were a couple of posts concerning the problem, but I don't have them bookmarked. It might be prudent to check that your mesa and xorg packages are at least from the same repo.
    One difference between our systems that may be worth mentioning is that I use kdm as my display manager. It's just a personal preference on my part.
    You must be a wizard or something, because just now I did a ref/dup and it came back with some Mesa packages to upgrade, and now I'm back in Plasma. What a coincidence! (or is it...)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •