Results 1 to 9 of 9

Thread: New xfce terminal window opens behind the Qt active window

  1. #1

    Default New xfce terminal window opens behind the Qt active window

    Hi,

    On my current Tumbleweed XFCE installation, I am facing the phenomenon or running i.e. qt creator and the xfce terminal output to open behind it...

    Is there any way to prevent it to do so?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,258
    Blog Entries
    2

    Default Re: New xfce terminal window opens behind the Qt active window

    You should first see if it happens with any other apps besides qt creator.

    If it's happening only with qt creator, where did your qt creator come from?
    You can post info about your qt-creator with the following
    Code:
    zypper info qt-creator
    At the moment I'm assuming you're launching by an application launch menu selection and that the menu selection's properties might not be correct...

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: New xfce terminal window opens behind the Qt active window

    I am using qt-creator 4.5.2 from qt.io....
    In any case, only libqt5-creator exists on repositories and it is older:

    ------------------------------------------------------------------------------------------------------------------------------------------------------
    zypper info libqt5-creator
    Loading repository data...
    Reading installed packages...




    Information for package libqt5-creator:
    ---------------------------------------
    Repository : Main Repository (OSS)
    Name : libqt5-creator
    Version : 4.5.0-3.1
    Arch : x86_64
    Vendor : openSUSE
    Installed Size : 93,2 MiB
    Installed : No
    Status : not installed
    Source package : libqt5-creator-4.5.0-3.1.src
    Summary : Integrated Development Environment targeting Qt apps
    Description :
    Qt Creator is an integrated development environment (IDE) designed to
    facilitate development with the Qt application framework.
    ------------------------------------------------------------------------------------------------------------------------------------------------------


    If I use the mate-terminal for output, instead of xfce4-terminal, then it opens in the front of qt-creator...

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,258
    Blog Entries
    2

    Default Re: New xfce terminal window opens behind the Qt active window

    IMO in all likelihood, this is an issue specific to the Desktop and not the underlying distro.
    Because you installed from a non-openSUSE source, you should probably submit a bug directly to the bugzilla for qt-creator (looks like they maintain their own private git repository).

    You can tinker with the shortcut properties on your own (recommend simply comparing the qt-creator menu item vs any other that behaves correctly), but more than likely this should simply be fixed upstream.

    Or,
    Identify what the difference is between the version from qt.io and the openSUSE version... It's only a minor increment 4.5.2 vs 4.5.0) so the difference might not be great. Also sometimes you can install an app from the openSUSE repos and the app will have its own updater to its own Vendor (qt.io) so by starting with the openSUSE version the app would be installed correctly and then still be updated to latest.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5

    Default Re: New xfce terminal window opens behind the Qt active window

    Quote Originally Posted by tsu2 View Post
    IMO in all likelihood, this is an issue specific to the Desktop and not the underlying distro.
    Because you installed from a non-openSUSE source, you should probably submit a bug directly to the bugzilla for qt-creator (looks like they maintain their own private git repository).

    You can tinker with the shortcut properties on your own (recommend simply comparing the qt-creator menu item vs any other that behaves correctly), but more than likely this should simply be fixed upstream.

    Or,
    Identify what the difference is between the version from qt.io and the openSUSE version... It's only a minor increment 4.5.2 vs 4.5.0) so the difference might not be great. Also sometimes you can install an app from the openSUSE repos and the app will have its own updater to its own Vendor (qt.io) so by starting with the openSUSE version the app would be installed correctly and then still be updated to latest.

    TSU
    Why so?
    With libqt5-creator 4.5.0 is even worse...
    No matter of which terminal is used as output, it always opens behind the qt-creator window....
    At least with qt.io 4.5.2, there is a way, to work with mate terminal.....
    So, it must be a distro's DE case....
    Awaiting your feedback....

  6. #6
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: New xfce terminal window opens behind the Qt active window

    A workaround is to put them in different "workspaces".
    Hotkeys can be set in Settings Manager > Window Manager > Keyboard

  7. #7
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: New xfce terminal window opens behind the Qt active window

    Also, check that it isn't set to "always on top" for some reason.
    Right-click Qt creator's titlebar,
    you will see "Same as Other Windows" if it is,
    and "Always on Top" if it isn't.

    Also check that the terminal isn't set to "Always Below Other Windows".

    Edit: Nevermind, I see these are temporary settings.

  8. #8

    Default Re: New xfce terminal window opens behind the Qt active window

    None of the windows is set to "Always on Top" and to "Always Below Other Windows", the second does not even exist as an option....
    My workaround to output to mate-terminal instead of xfce4-terminal is far better than opening the output in different workspaces.....
    Also on "Settings" the "Window Manager" doesn't run....

  9. #9

    Default Re: New xfce terminal window opens behind the Qt active window

    Replaced marco with xfwm4 and problem solved....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •