Results 1 to 4 of 4

Thread: Epson XP-55 wireless printer not detected by printer setup.

  1. #1

    Default Epson XP-55 wireless printer not detected by printer setup.

    I've just made a new install of TW (rel: 20180320) and been unable to
    install my printer. A new install yesterday of an older TW but then
    fully updated gave no trouble. Looking at my notes, I see that I should
    shut down the firewall whilst installing the printer, though I'm not
    sure why this was unnecessary yesterday.

    Shutting down the firewall used to be a piece of cake with YaST but I'm
    completely baffled by this new tool in YaST for tinkering with
    firewalld. Where can I find nice friendly "on" and "off" buttons?


    --
    Graham Davis, Bracknell, Berks., UK.
    openSUSE Tumbleweed; KDE Plasma 5.12.3; Qt 5.10.0; Kernel 4.15.11;
    AMD Athlon X4 860K Processor; Sound: FCH Azalia;
    Video: nVidia GeForce 210 (Driver: nouveau)

  2. #2

    Default Re: Epson XP-55 wireless printer not detected by printer setup.

    On 26/03/18 17:32, Graham P Davis wrote:
    > I've just made a new install of TW (rel: 20180320) and been unable to
    > install my printer. A new install yesterday of an older TW but then
    > fully updated gave no trouble. Looking at my notes, I see that I should
    > shut down the firewall whilst installing the printer, though I'm not
    > sure why this was unnecessary yesterday.
    >
    > Shutting down the firewall used to be a piece of cake with YaST but I'm
    > completely baffled by this new tool in YaST for tinkering with
    > firewalld. Where can I find nice friendly "on" and "off" buttons?
    >
    >


    Solved - I think.

    No sign of any user-friendly buttons so used commands -
    sudo systemctl stop firewalld
    and later -
    sudo systemctl start firewalld

    Unfortunately, as soon as I'd started up the firewall after getting the
    printer recognised and configured, starting up the firewall again
    blocked all printing. After a fair bit of floundering, I found the
    firewalld website and read a bit about zones. I then changed the default
    zone from "public" to "home". Almost immediately, the printer fired up
    and spat out a queued print. I hope that was the right procedure to
    follow but at least I can now print.

    Why do "improvements" usually mean more complications?

    --
    Graham Davis, Bracknell, Berks., UK.
    openSUSE Tumbleweed; KDE Plasma 5.12.3; Qt 5.10.0; Kernel 4.15.11;
    AMD Athlon X4 860K Processor; Sound: FCH Azalia;
    Video: nVidia GeForce 210 (Driver: nouveau)

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,894
    Blog Entries
    1

    Default Re: Epson XP-55 wireless printer not detected by printer setup.

    Quote Originally Posted by Cloddy View Post
    On 26/03/18 17:32, Graham P Davis wrote:
    > I've just made a new install of TW (rel: 20180320) and been unable to
    > install my printer. A new install yesterday of an older TW but then
    > fully updated gave no trouble. Looking at my notes, I see that I should
    > shut down the firewall whilst installing the printer, though I'm not
    > sure why this was unnecessary yesterday.
    >
    > Shutting down the firewall used to be a piece of cake with YaST but I'm
    > completely baffled by this new tool in YaST for tinkering with
    > firewalld. Where can I find nice friendly "on" and "off" buttons?
    >
    >


    Solved - I think.

    No sign of any user-friendly buttons so used commands -
    sudo systemctl stop firewalld
    and later -
    sudo systemctl start firewalld

    Unfortunately, as soon as I'd started up the firewall after getting the
    printer recognised and configured, starting up the firewall again
    blocked all printing. After a fair bit of floundering, I found the
    firewalld website and read a bit about zones. I then changed the default
    zone from "public" to "home". Almost immediately, the printer fired up
    and spat out a queued print. I hope that was the right procedure to
    follow but at least I can now print.

    Why do "improvements" usually mean more complications?

    --
    Graham Davis, Bracknell, Berks., UK.
    openSUSE Tumbleweed; KDE Plasma 5.12.3; Qt 5.10.0; Kernel 4.15.11;
    AMD Athlon X4 860K Processor; Sound: FCH Azalia;
    Video: nVidia GeForce 210 (Driver: nouveau)
    AFAIU, the default firewalld firewall rules only apply to the 'public' zone anyway, so unless you really need an active firewall, you're best to disable it anyway. That will depend on your exact situation of course.
    Last edited by deano_ferrari; 26-Mar-2018 at 14:24.

  4. #4

    Default Re: Epson XP-55 wireless printer not detected by printer setup.

    On 26/03/18 22:26, deano ferrari wrote:
    >
    > Cloddy;2860311 Wrote:
    >> On 26/03/18 17:32, Graham P Davis wrote:
    >>> I've just made a new install of TW (rel: 20180320) and been unable to
    >>> install my printer. A new install yesterday of an older TW but then
    >>> fully updated gave no trouble. Looking at my notes, I see that I

    >> should
    >>> shut down the firewall whilst installing the printer, though I'm not
    >>> sure why this was unnecessary yesterday.
    >>>
    >>> Shutting down the firewall used to be a piece of cake with YaST but

    >> I'm
    >>> completely baffled by this new tool in YaST for tinkering with
    >>> firewalld. Where can I find nice friendly "on" and "off" buttons?
    >>>
    >>>

    >>
    >> Solved - I think.
    >>
    >> No sign of any user-friendly buttons so used commands -
    >> sudo systemctl stop firewalld
    >> and later -
    >> sudo systemctl start firewalld
    >>
    >> Unfortunately, as soon as I'd started up the firewall after getting the
    >> printer recognised and configured, starting up the firewall again
    >> blocked all printing. After a fair bit of floundering, I found the
    >> firewalld website and read a bit about zones. I then changed the default
    >> zone from "public" to "home". Almost immediately, the printer fired up
    >> and spat out a queued print. I hope that was the right procedure to
    >> follow but at least I can now print.
    >>
    >> Why do "improvements" usually mean more complications?
    >>

    > AFAIU, the default firewalld firewall rules only apply to the 'public'
    > zone anyway, so unless you really need an active firewall, you're best
    > to disable it anyway. That will depend on your exact situation of
    > course.
    >


    Yes, I probably don't need it as at least one of my upstream routers has
    a firewall running but I have a nervous tendency to go for
    belt-and-braces approaches wherever I can.

    As for the firewalld rules, switching default zone from "public" to
    "home" allows mdns, Samba and SSH services in addition to the
    dhcpv6-client which is the only one allowed by "public".


    --
    Graham Davis, Bracknell, Berks., UK.
    openSUSE Tumbleweed; KDE Plasma 5.12.3; Qt 5.10.0; Kernel 4.15.11;
    AMD Athlon X4 860K Processor; Sound: FCH Azalia;
    Video: nVidia GeForce 210 (Driver: nouveau)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •