Results 1 to 9 of 9

Thread: Gigabyte Radeon RX 560 - black screen during installation

  1. #1
    Join Date
    Aug 2009
    Location
    Esslingen, Germany
    Posts
    7

    Default Gigabyte Radeon RX 560 - black screen during installation

    A new PC with Gigabyte Radeon RX 560 video shows a black screen soon after the initial setup/installation menu. Tested with uefi setup with or without grub2 nomodset parameter for both Leap 42.3 and Leap 15 Beta. Meanwhile, live DVD start with ubuntu 16.04 LTS works fine. Any ideas?

    Greetings, Thommie

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Gigabyte Radeon RX 560 - black screen during installation

    Not clear. What do you mean by "the initial setup/installation menu"?
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,574

    Default Re: Gigabyte Radeon RX 560 - black screen during installation

    Quote Originally Posted by thommierother View Post
    A new PC with Gigabyte Radeon RX 560 video shows a black screen soon after the initial setup/installation menu. Tested with uefi setup with or without grub2 nomodset parameter for both Leap 42.3 and Leap 15 Beta. Meanwhile, live DVD start with ubuntu 16.04 LTS works fine. Any ideas?
    Instead of with/without nomodeset, how about trying without quiet or splash=silent so you can see boot messages? Also you can try adding plymouth.enable=0. How long after the screen turned black did you wait before giving up? Were you insufficiently patient?

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,478

    Cool Re: Gigabyte Radeon RX 560 - black screen during installation

    @thommierother:
    According to "Tom's Hardware", it seems that, the AMD Radeon RX 560 GPU is a "Polaris 11 (Baffin)" item <http://www.tomshardware.com/reviews/...-4gb,5254.html> -- meaning, from the point of view of the "amdgpu" driver, it's part of the AMD "Volcanic Islands" family.

    Further, from May 2016, there are items on "Phoronix" <https://phoronix.com/scan.php?page=n...laris-More-IDs> and "Video Cardz" <https://videocardz.com/58634/amd-con...s-11-is-baffin> related to the "amdgpu" driver support for "Baffin" GPUs.

    So, given that, the AMD Radeon RX 560 was launched in April 2017 and, AMD state that "Linux x86_64" support is available (and, separate, Ubuntu … ) <https://www.amd.com/en/products/graphics/radeon-rx-560>, it may be that, the "amdgpu" driver version currently available with Leap is not "new enough" for cards with this AMD GPU.
    • You say that, Ubuntu was behaving OK.


    We'll have to take a look at the current list of AMD GPU boot options to see if there's anything specific for AMD Polaris 11 (Baffin) GPUs.
    • Will be back after searching …

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,478

    Default Re: Gigabyte Radeon RX 560 - black screen during installation

    Quote Originally Posted by thommierother View Post
    shows a black screen soon after the initial setup/installation menu.
    The Ubuntu folks sometimes suggest that, the reason is that, the GPU driver turns down the screen brightness all the way to "off": try increasing the screen brightness -- somehow -- no idea how if the system isn't a Laptop …

    Haven't found anything yet specific to "Volcanic Islands": there's this Phoronix article for version 4.13 kernels and "Sea Islands" and "Southern Islands" GPUs: <https://www.phoronix.com/scan.php?pa...3-gcn101&num=1>.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,478

    Default Re: Gigabyte Radeon RX 560 - black screen during installation

    @thommierother:
    If you want to take the risk that, the "amdgpu" driver version (Linux Kernel version dependent) will support an AMD "Polaris 11" (Baffin) GPU, you could try a "Text Mode" installation:
    [F3 ]Video Mode - Select various graphical display modes for the installation. Select Text Mode if the graphical installation causes problems.
    <https://en.opensuse.org/SDB:Installation_help>.

  7. #7
    Join Date
    Aug 2009
    Location
    Esslingen, Germany
    Posts
    7

    Default Re: Gigabyte Radeon RX 560 - black screen during installation

    Thanks for the first hints so far, unfortunately I have no lspci -vvv here to show the kernel details of the card.
    But I believe that @dcurtisfra is right with the suggestion that it is a "Polaris 11 (Baffin)" and the
    "amdgpu" FOSS driver does not have support for this GPU yet, even not in the Leap 15 beta installer.

    The black screen appears after starting the installation routine from the initial menu. You see the kernel booting
    and as soon as it tries to switch graphics (plymouth), there is no more signal on the monitor.

    I will play with F3 and with some kernel params. "without quiet or splash=silent and plymouth.enable=0" was
    new for me, thx.

    I am a NVidia guy, don't know details of AMD cards under linux yet ...
    Is it the same situation like in the "Nvidia world" that its better to use the properietary driver (AMDGPU-PRO)
    later on?

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Gigabyte Radeon RX 560 - black screen during installation

    You might try the following parameters on the Install command line:
    Code:
    self_update=1
    There will be a pause at the start, because this will download the latest installer (not the whole DVD Installation package, just necessary updates to the installer itself fixed after original release).

    Also, you could try the text installer (ncurses), a little less pretty looking, but the same functionality.

    Do that with:
    Code:
    Textmode=1
    You could try both parameters at the same time, has worked for a few in a similar situation to yours.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,654
    Blog Entries
    14

    Default Re: Gigabyte Radeon RX 560 - black screen during installation

    You could try one of the Tumbleweed live images to see if a newer kernel / system would work better with your hardware.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •