Results 1 to 5 of 5

Thread: Multiple update failures

  1. #1

    Default Multiple update failures

    I've been using openSuSE for about 2 decades. On 3/14/2018 I installed Tumbleweed in a clean partition and looked it over. It looked good, but I went on to other things for a while. I returned to Tumbleweed today. The first thing I did after resetting my network access, was go to YaST -> Online Update. There were no packages to install.

    Later, I rebooted. Now, the system tool wanted to update. I let it proceed. It started to install over 1,100 packages. At about 1/2 hour in, it was 95% complete and installing btrfsmaintenance. After about 2 hours, it was still 95% complete and installing btrfsmaintenance. I shut it down.

    I rebooted again. I got "Update error: Failed to activate 'org.FreeDesktop.PackageKit': timed out (service_start_timeout=25000ms)" I went into YaST -> Software Management and searched for PackageKit. It and many dependencies were installed. Several were different versions. In particular, libpackagekit-glib2-18 and libpackagekitqt5-0 were different versions. I uninstalled them and typelib, which also seemed to be required to resolve conflicts. I let YaST generate a new set of dependencies.

    That message has gone away, but now I get: "Network is offlline / Last check: 1 hour and 13 minutes ago." The update tool clearly does not try to access the internet. At present, Firefox accesses the internet as does 'ping' from the command line, so the problem is with the update tool.

    If I run 'zypper update' from the command line, I learn "498 packages to upgrade, 136 new." It ends by warning "Consider to cancel: / Product 'openSUSE Tumbleweed' requires to be updated by calling 'zypper dup'!" I do not understand the meaning of that message, so I chose not to continue. It seems improbable that so many more packages were needed after the system update tool had accomplished 95% of its work on 1,100 packages.

    Please give me specific command-line or other instructions for how to restore Tumbleweed to its intended state. I would prefer not to have to reinstall it.

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,115
    Blog Entries
    1

    Default Re: Multiple update failures

    Quote Originally Posted by docduke View Post
    I've been using openSuSE for about 2 decades. On 3/14/2018 I installed Tumbleweed in a clean partition and looked it over. It looked good, but I went on to other things for a while. I returned to Tumbleweed today. The first thing I did after resetting my network access, was go to YaST -> Online Update. There were no packages to install.
    No, don't use this method or 'zypper update' to update this rolling release.

    The correct procedure is to do
    Code:
    sudo zypper dup

    https://en.opensuse.org/Portal:Tumbleweed

  3. #3

    Default Re: Multiple update failures [Solved]

    That did it. Thanks!

  4. #4

    Default Re: Multiple update failures

    Quote Originally Posted by deano_ferrari View Post
    No, don't use this method or 'zypper update' to update this rolling release.

    The correct procedure is to do
    Code:
    sudo zypper dup

    https://en.opensuse.org/Portal:Tumbleweed
    My system has been in a sluggish state for a while and somewhat "dodgy". I usually just use the Software Update applet. I also have packman and KDE:Extras set at priority 98.

    After recent updates using the applet and via YAST gave me rapidly flashing console login (on all ALT consoles) which was impossible to get past. I did a rollback.

    What finally worked was exactly as you say, although I first set all repos at the same priority (99).

    System all up to date (20180403), responsive, and better than ever. Just fantastic.

    So why does the above link advise adding --no-allow-vendor-change?

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,115
    Blog Entries
    1

    Default Re: Multiple update failures

    Quote Originally Posted by cartland View Post
    So why does the above link advise adding --no-allow-vendor-change?
    Because that option was not the default previously. Now it is (since ~ July 2017)

    Refer...
    https://lists.opensuse.org/opensuse-.../msg00172.html

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •