Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Firewalld service inactive (dead)

  1. #1

    Exclamation Firewalld service inactive (dead)

    Why is firewalld service not active after reboot? How to fix it?

    Code:
    sudo service firewalld status
    [sudo] пароль для root:  
    ● firewalld.service - firewalld - dynamic firewall daemon
       Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: disab
       Active: inactive (dead)
         Docs: man:firewalld(1)
    
    
    Code:
    cat /etc/os-release
    NAME="openSUSE Tumbleweed"
    # VERSION="20180330"
    ID=opensuse
    ID_LIKE="suse"
    VERSION_ID="20180330"
    PRETTY_NAME="openSUSE Tumbleweed"
    
    

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Firewalld service inactive (dead)

    have you ran a recent update
    Code:
    zypper dup
    afaik on TW firewalld has replaced SUSEfirewall
    if SUSEfirewall is still alive and working on your machine it could be affecting firewalld
    you can use yast service manager to check if SUSEfirewall is still there and to activate firewalld
    see
    https://forums.opensuse.org/showthre...bleweed-update

  3. #3

    Default Re: Firewalld service inactive (dead)

    Quote Originally Posted by I_A View Post
    you can use yast service manager to check if SUSEfirewall is still there and to activate firewalld
    Quote Originally Posted by doscott View Post
    Use the yast services manager to make sure SuSEfirewall2 services are stopped and disabled, and that firewalld is enabled and started.
    When everything looks good you can use yast to find all SuSEfirewall2 installed packages and remove them.
    Done.

    It helped, thanks.

  4. #4

    Default Re: Firewalld service inactive (dead)

    Tell me please, why ifconfig does not work for Tumbleweed ? It's a surprise for me:

    Code:
    sudo ifconfig
    sudo: ifconfig: command not found
    

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Firewalld service inactive (dead)

    Quote Originally Posted by aleksejsmir View Post
    Tell me please, why ifconfig does not work for Tumbleweed ? It's a surprise for me:

    Code:
    sudo ifconfig
    sudo: ifconfig: command not found
    
    The 'net-tools' package has been deprecated for some time now and no longer included by default. Instead the 'ip' command and others can be used. For example, to get interfaces and assigned addresses...
    Code:
    ip a
    Routing...
    Code:
    ip r

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Firewalld service inactive (dead)

    For your interest...

    https://software.opensuse.org/packag...ols-deprecated

    net-tools-deprecated

    Deprecated Networking Utilities

    This package contains the deprecated network utilities arp, ifconfig, netstat and route, which have been replaced by tools from the iproute2 package: * arp -> ip [-r] neigh * ifconfig -> ip a * netstat -> ss [-r] * route -> ip r

  7. #7
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Firewalld service inactive (dead)

    Quote Originally Posted by deano_ferrari View Post
    The 'net-tools' package has been deprecated for some time now and no longer included by default. Instead the 'ip' command and others can be used.v
    Or if you are a fan of vintage computing (or just putting off updating a pile of scripts):
    Code:
    sudo zypper in net-tools-deprecated
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  8. #8

    Default Re: Firewalld service inactive (dead)

    OK, thank you!
    What do you think, I must enter eth0 and ppp0 in the firewall settings ("Interfaces" tab)? or eth0 only? If I do not do this ("Interfaces" tab is empty), will the firewall work?

    Code:
    ip a 
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 00:25:22:bb:5f:e9 brd ff:ff:ff:ff:ff:ff
    3: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN group default qlen 3
        link/ppp  
        inet 100.65.171.237 peer 100.65.168.1/32 scope global ppp0
           valid_lft forever preferred_lft forever
    
    

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Firewalld service inactive (dead)

    Quote Originally Posted by aleksejsmir View Post
    OK, thank you!
    What do you think, I must enter eth0 and ppp0 in the firewall settings ("Interfaces" tab)? or eth0 only? If I do not do this ("Interfaces" tab is empty), will the firewall work?
    There should be no need to add the interfaces explicitly. By default, both eth0 and ppp0 (when active) will be assigned to the public zone by default.

    For example, when I have firewalld active on a normal ethernet connection and a VPN active...
    Code:
    firewall-cmd --list-all-zones
    I get....
    Code:
    public (active)
      target: default
      icmp-block-inversion: no
      interfaces: eth0 ppp0

  10. #10
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    398

    Default Re: Firewalld service inactive (dead)

    There is a good link about firewalld:
    https://www.digitalocean.com/communi...ld-on-centos-7

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •