Results 1 to 9 of 9

Thread: Dramatic performance loss from 4.15.10 to 4.15.13

  1. #1

    Default Dramatic performance loss from 4.15.10 to 4.15.13

    Hello all,

    while working on the emulation system MAME, I noticed a heavy performance loss in the recent kernel. MAME is a particularly CPU-intense application.

    $ uname -a; ./mame64 ti99_4a -bench 20
    Linux capella.daheim.lan 4.15.13-1-default #1 SMP PREEMPT Sun Mar 25 08:34:58 UTC 2018 (950fc49) x86_64 x86_64 x86_64 GNU/Linux
    Average speed: 302.08% (19 seconds)

    After a reboot, I selected the older kernel 4.15.10 that is still available on my system:

    $ uname -a; ./mame64 ti99_4a -bench 20
    Linux capella.daheim.lan 4.15.10-1-default #1 SMP PREEMPT Thu Mar 15 20:31:17 UTC 2018 (5e4329c) x86_64 x86_64 x86_64 GNU/Linux
    Average speed: 896.21% (19 seconds)

    The MAME benchmark is designed to let the emulation run without screen output and without delays for realistic timing, thus running as fast as possible.

    The speed value says that the emulation runs at 300% (the 19 emulated seconds only took 6.33 sec). However, the second run with the older kernel says that it ran three (!) times as fast.

    I did not change anything, just booted the other kernel and immediately started the benchmark process.

    I also noticed this lower performance in applications in Dosbox with choppy sound, so it is not only MAME-related.

    Greetings,

    Michael

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Dramatic performance loss from 4.15.10 to 4.15.13

    Just to rule out other things than the kernel, please boot the previous kernel, then run the benchmark again.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Dramatic performance loss from 4.15.10 to 4.15.13

    It's been happening this way for the last three days at least; I also did a zypper dup today, but no change. I do not have the kernels 4.15.11 or 4.15.12 on my system - need to check with another computer at my second home, maybe that one has them. Anyway, this was a rapid increase in numbers in about 10 days.

  4. #4

    Default Re: Dramatic performance loss from 4.15.10 to 4.15.13

    You might have to get ugly and bisect to find the culprit for your exact case if other people aren't reporting.

  5. #5

    Default Re: Dramatic performance loss from 4.15.10 to 4.15.13

    This is pretty weird; with 4.15.13 my 6 year old laptop is now faster than my desktop PC with a last-year Core i7. How could this possibly happen?

    I suppose I can pull the kernel sources from Github. Do I need particular settings for creating a kernel for my Tumbleweed installation? Is there a Howto? (I did not build a kernel for the last 15 years, if I remember correctly.)

  6. #6

    Default Re: Dramatic performance loss from 4.15.10 to 4.15.13

    Things are getting even more complicated. On my second PC, I also found the performance loss, but it happened earlier. Rolling back, it seems as if it was between openSUSE-release-20180227-1.2.x86_64 (fast) and openSUSE-release-20180314-1.2.x86_64 (slow). The former release had kernel 4.15.6, the latter 4.15.8.

    Can it be related to a library? I found that in the second release, glibc 2.27 became available.

    Maybe I'll take a spare SSD and try a clean install and see what happens.

  7. #7

    Default Re: Dramatic performance loss from 4.15.10 to 4.15.13

    I believe I found the problem. It is indeed the Spectre_v2 mitigation. I verified this on all PCs where I discovered the issue.

    All three systems report
    $ cat /sys/devices/system/cpu/vulnerabilities/spectre_v2
    Mitigation: Indirect Branch Restricted Speculation, IBPB, IBRS_FW
    When I add the kernel boot parameter "spectre_v2=off", the previous high speed is available again.

    Sadly, I will have to turn off that mitigation and make my system vulnerable, until a better solution will be found. Or until I decide it is time for another hardware upgrade.

    I heard of performance losses with respect to this Meltdown/Spectre problem, but this is really extreme.

  8. #8

    Default Re: Dramatic performance loss from 4.15.10 to 4.15.13

    Unless you are hosting virtual containers to random internet users, I'd just turn it off. Good job on identifying the root cause!

  9. #9
    Join Date
    Nov 2009
    Location
    Hampshire, UK
    Posts
    42

    Default Re: Dramatic performance loss from 4.15.10 to 4.15.13

    This has fixed an issue I was seeing where watching video (Amazon Prime) would suddenly go so slowly and the whole PC become unresponsive. I've now been watching for a couple of hours without incident.
    - Custom built core i7 720, 18GB RAM, nVidia GT1030 Asus Xonar D2X, OpenSuse 15.2 and Tumbleweed 64bit

    He is no fool who gives up that which he cannot keep to gain that he cannot loose - Jim Elliot

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •