Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: Rails for Leap 42.3

  1. #11

    Default Re: Rails for Leap 42.3

    Quote Originally Posted by tsu2 View Post
    You'll need to add the devel:languages:ruby:extensions repo.
    There is a one-click install on the following page (click on experimental, then the repo I specified, not the others)

    https://software.opensuse.org/package/rubygem-rails-5_1
    Oh ... does not work.
    Perhaps I should try other packages on this page?


  2. #12
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,733
    Blog Entries
    2

    Default Re: Rails for Leap 42.3

    Quote Originally Posted by aleksejsmir View Post
    Oh ... does not work.
    Perhaps I should try other packages on this page?

    See prior post by rayh.
    Curious what the problem might be, but considering Rails is itself a framework the possibilities are great.
    If a specific reason exists, then you can use that to qualify other repos... but... if that's not available...

    I only recommended the extensions repo as likely more tested and stable.
    If you want to try other 42.3 repos, I'd try the OBS repos before private repos.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #13
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,733
    Blog Entries
    2

    Default Re: Rails for Leap 42.3

    Rayh may have to verify his rails 5.1 from TW was installed on a LEAP 42.3 system running Ruby 2.3 or 2.5.

    In other words, to install the package he found that works, you <may> also need to upgrade your Ruby to 2.5.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #14

    Default Re: Rails for Leap 42.3

    Quote Originally Posted by tsu2 View Post
    In other words, to install the package he found that works, you <may> also need to upgrade your Ruby to 2.5.
    I upgraded my workstation from Leap to Tumbleweed.
    But now I need this article, not 503 error.

  5. #15
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,208

    Default Re: Rails for Leap 42.3

    Quote Originally Posted by tsu2 View Post
    Rayh may have to verify his rails 5.1 from TW was installed on a LEAP 42.3 system running Ruby 2.3 or 2.5.

    In other words, to install the package he found that works, you <may> also need to upgrade your Ruby to 2.5.
    Note I am not a ruby programmer and the Leap-42.3 machine is remote. [EDIT] I did not try Ruby-2.3

    I only tried installing ruby2.5-rubygem-rails-5_1 from Tumbleweed -- I did not try to use it, and promptly removed all the rails stuff and reverting nscd and gcc etc. to the 42.3 versions.
    The ruby2.5-rubygem-rails-5_1. install did not worry about ruby-common-2.1-8.3 from 42.3, TW uses ruby-common-2.1-12.1. I have since tried changeinging ruby-common on 42.3 machine to the TW version with no obvious ill effects -- YaST and nscd still work.

    As reported earlier I had tried with several versions of Rails from
    http://download.opensuse.org/reposit...USE_Leap_42.3/
    but none of them would install. They all produced the same error as observed by Aleksej.

    BTW Tsu, your reference to Pyenv was of interest to me and I will be investigating it; thanks.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  6. #16
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,208

    Default Re: Rails for Leap 42.3

    Quote Originally Posted by eng-int View Post
    The ruby2.5-rubygem-rails-5_1. install did not worry about ruby-common-2.1-8.3 from 42.3, TW uses ruby-common-2.1-12.1. I have since tried changeinging ruby-common on 42.3 machine to the TW version with no obvious ill effects -- YaST and nscd still work.
    P.S. Leap-42.3-OSS includes libruby-2.3.3 and libruby-2.4.1. TW has libruby-2.5.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  7. #17

    Default Re: Rails for Leap 42.3

    Quote Originally Posted by aleksejsmir View Post
    I upgraded my workstation from Leap to Tumbleweed.
    Yes, it works for me now:
    Code:
    sudo zypper in ruby2.5-rubygem-rails-5_1
    Cool! Thank you! I'm really glad.


  8. #18

    Default Re: Rails for Tumbleweed

    Hmmmmm.... problem. I installed rails and thoroughly tested the project. It worked. But now (after zipper dup) puma has stopped working ....


    Code:
    /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require': libssl.so.44: cannot open shared object file: No such file or directory - /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/puma/puma_http11.so (LoadError)
    any ideas?


    Code:
    alex@linux-yz6z:~/rails/test2> rails s 
    WARNING: Nokogiri was built against LibXML version 2.9.7, but has dynamically loaded 2.9.8
    => Booting Puma
    => Rails 5.1.6 application starting in development  
    => Run `rails server -h` for more startup options
    Exiting
    Traceback (most recent call last):
            50: from bin/rails:3:in `<main>'
            49: from bin/rails:3:in `load'
            48: from /home/alex/rails/test2/bin/spring:15:in `<top (required)>'
            47: from /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:70:in `require'
            46: from /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:70:in `require'
            45: from /usr/lib64/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `<top (required)>'
            44: from /usr/lib64/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/binstub.rb:31:in `load'
            43: from /usr/lib64/ruby/gems/2.5.0/gems/spring-2.0.2/bin/spring:49:in `<top (required)>'
            42: from /usr/lib64/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/client.rb:30:in `run'
            41: from /usr/lib64/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/client/command.rb:7:in `call'
            40: from /usr/lib64/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `call'
            39: from /usr/lib64/ruby/gems/2.5.0/gems/spring-2.0.2/lib/spring/client/rails.rb:28:in `load'
            38: from /home/alex/rails/test2/bin/rails:9:in `<top (required)>'
            37: from /home/alex/rails/test2/bin/rails:9:in `require'
            36: from /usr/lib64/ruby/gems/2.5.0/gems/railties-5.1.6/lib/rails/commands.rb:16:in `<top (required)>'
            35: from /usr/lib64/ruby/gems/2.5.0/gems/railties-5.1.6/lib/rails/command.rb:44:in `invoke'
            34: from /usr/lib64/ruby/gems/2.5.0/gems/railties-5.1.6/lib/rails/command/base.rb:63:in `perform'
            33: from /usr/lib64/ruby/gems/2.5.0/gems/thor-0.20.0/lib/thor.rb:387:in `dispatch'
            32: from /usr/lib64/ruby/gems/2.5.0/gems/thor-0.20.0/lib/thor/invocation.rb:126:in `invoke_command'
            31: from /usr/lib64/ruby/gems/2.5.0/gems/thor-0.20.0/lib/thor/command.rb:27:in `run'
            30: from /usr/lib64/ruby/gems/2.5.0/gems/railties-5.1.6/lib/rails/commands/server/server_command.rb:130:in `perform'
            29: from /usr/lib64/ruby/gems/2.5.0/gems/railties-5.1.6/lib/rails/commands/server/server_command.rb:130:in `tap'
            28: from /usr/lib64/ruby/gems/2.5.0/gems/railties-5.1.6/lib/rails/commands/server/server_command.rb:135:in `block in perform'
            27: from /usr/lib64/ruby/gems/2.5.0/gems/railties-5.1.6/lib/rails/commands/server/server_command.rb:44:in `start'
            26: from /usr/lib64/ruby/gems/2.5.0/gems/rack-2.0.4/lib/rack/server.rb:297:in `start'
            25: from /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/rack/handler/puma.rb:61:in `run'
            24: from /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/rack/handler/puma.rb:14:in `config'
            23: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
            22: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in `load_dependency'
            21: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `block in require'
            20: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
            19: from /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/puma/launcher.rb:4:in `<top (required)>'
            18: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
            17: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in `load_dependency'
            16: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `block in require'
            15: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
            14: from /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/puma/cluster.rb:1:in `<top (required)>'
            13: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
            12: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in `load_dependency'
            11: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `block in require'
            10: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
             9: from /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/puma/runner.rb:1:in `<top (required)>'
             8: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
             7: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in `load_dependency'
             6: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `block in require'
             5: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
             4: from /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/puma/server.rb:15:in `<top (required)>'
             3: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require'
             2: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:258:in `load_dependency'
             1: from /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `block in require'
    /usr/lib64/ruby/gems/2.5.0/gems/activesupport-5.1.6/lib/active_support/dependencies.rb:292:in `require': libssl.so.44: cannot open shared o
    bject file: No such file or directory - /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/puma/puma_http11.so (LoadError)
    
    

  9. #19
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,733
    Blog Entries
    2

    Default Re: Rails for Leap 42.3

    If you're installed on BTRFS, you should be able to roll back to immediately after you upgraded.

    Before you do so however, you should first check to see of the file exists or not
    Code:
    /usr/lib64/ruby/gems/2.5.0/gems/puma-3.11.3/lib/puma/puma_http11.so 
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  10. #20

    Default Re: Rails for Leap 42.3

    How to report this problem to maintainer?

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •