Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: Error on software update in YAST

  1. #11

    Default Re: Error on software update in YAST

    Quote Originally Posted by hcvv View Post
    In any case, you should not have libdvdcss and Packman both active.
    Yes, but they are not connected with http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/

  2. #12
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Error on software update in YAST

    "pretty standard" ?? By no means. You have lots of home:/ repos active, which are user repos for packagers, where they can and will break things because these repos are meant for that. And, this breaks the concept of Tw being openqa tested, since home:/ and devel:/ repos are untested, unlike every Tw snapshot. To be honest: I call this a mess.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #13

    Default Re: Error on software update in YAST

    Quote Originally Posted by Knurpht View Post
    "pretty standard" ?? By no means. You have lots of home:/ repos active, which are user repos for packagers, where they can and will break things because these repos are meant for that. And, this breaks the concept of Tw being openqa tested, since home:/ and devel:/ repos are untested, unlike every Tw snapshot. To be honest: I call this a mess.
    Anyway above is not related to the topic. Problem is solved. Bad that standard openSUSE repo does not contain many software so need to use community repos. Also not all packages are up-to-date.

  4. #14
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    398

    Default Re: Error on software update in YAST

    Like @Knurpht want to say:
    Try to stick with a few repositories, preferably TW ones.
    Like ArchLinux philosophy: keep it simple. Only keep it simple not anything else.

  5. #15
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,401

    Default Re: Error on software update in YAST

    Quote Originally Posted by akontsevich View Post
    Anyway above is not related to the topic. .
    That might be what you are convinced of, but you ask for help, thus those who try to help you will try to understand your working environment as good as possible. And they will try to find the odd thing in places where you probably won't think of. Because you were already working on this for some time and did not found the solution, conclusion then might be that it is to be found in another place where you did not look at all. That is how helping in error searching often works.

    Or to say it short: when you say that something hasn't anything to do with the problem, a good helper will then go specially there to inverstigate.

    And last, as I and others already tried to tell you, you saying that you have a "pretty standard" set of repos gave many of us a good story for today.
    You might need them for what you want to do, but that is not the same as it being a standard setup.
    Henk van Velden

  6. #16
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Error on software update in YAST

    Quote Originally Posted by akontsevich View Post
    Anyway above is not related to the topic. Problem is solved. Bad that standard openSUSE repo does not contain many software so need to use community repos. Also not all packages are up-to-date.
    What? Tw mostly is only 24-48 hours behind upstream KDE and GNOME, has the latest stable kernel, and > 12413 package-builds which bring a total of > 18000 packages in the OSS and NON-OSS repo. The repos you're using are not 'community repos' they're packager's home repos. The procedure if you want packages in Tw: ask the maintainer to submit the package to Tw. That way the package would be integrated in the openqa testing.

    This problem may be solved, but expect more instabilities/errors/non-working software. The integrity of your install is already broken. But, hey , it's your system.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #17
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,153

    Default Re: Error on software update in YAST

    Quote Originally Posted by akontsevich View Post
    It is pretty standard - see below:

    Code:
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                                  | Name                                                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                        | Service
    ---+----------------------------------------+------------------------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------------------------+--------
    ...
    10 | download.opensuse.org-oss              | Основной репозиторий (OSS)                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                          |        
    ...
    22 | http-download.opensuse.org-c5a99b04    | openSUSE:Tumbleweed                                        | Yes     | (r ) Yes  | Yes     |   99     | NONE   | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/                   |        
    ...
    As far as I can ascertain http://download.opensuse.org/reposit...weed/standard/ was an obsolete link to http://download.opensuse.org/tumbleweed/repo/oss/ so you are not missing anything and
    Code:
      #  zypper rr 22
    will remove the warning message.

    Having 29 enebled repositories for a rolling distribution certainly cannot be considered “standard”, especially when they include those for other distributions.
    You appear to have hand selected your repositor list rather than using the OpenSUSE defaults/recommendations for Tumbleweed.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  8. #18

    Default Re: Error on software update in YAST

    Quote Originally Posted by Knurpht View Post
    What? Tw mostly is only 24-48 hours behind upstream KDE and GNOME, has the latest stable kernel, and > 12413 package-builds which bring a total of > 18000 packages in the OSS and NON-OSS repo. The repos you're using are not 'community repos' they're packager's home repos.
    I do not know what package installation added http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/ repo, however I thought it is standard or community.

    Quote Originally Posted by Knurpht View Post
    The procedure if you want packages in Tw: ask the maintainer to submit the package to Tw. That way the package would be integrated in the openqa testing.
    Do not tell tales to me please. They can't add some packages for about month or years: acestream, pgadmin4, matrix riot, tortoisehg, goldendict (old version), deepin, additional icons, themes, xmlcopyeditor, qtox, ring, and many many others.

  9. #19

    Default Re: Error on software update in YAST

    Quote Originally Posted by eng-int View Post
    As far as I can ascertain http://download.opensuse.org/reposit...weed/standard/ was an obsolete link to http://download.opensuse.org/tumbleweed/repo/oss/ so you are not missing anything and
    Code:
      #  zypper rr 22
    will remove the warning message.
    Thanks! The best answer for today! It also removed network repo for me.

    Quote Originally Posted by eng-int View Post
    Having 29 enebled repositories for a rolling distribution certainly cannot be considered “standard”, especially when they include those for other distributions. You appear to have hand selected your repositor list rather than using the OpenSUSE defaults/recommendations for Tumbleweed.
    As I said I have to use some of them, cleaned up some unnecessary for now however. Thought standard repo is standard

  10. #20
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Error on software update in YAST

    Quote Originally Posted by akontsevich View Post
    Do not tell tales to me please. They can't add some packages for about month or years: acestream, pgadmin4, matrix riot, tortoisehg, goldendict (old version), deepin, additional icons, themes, xmlcopyeditor, qtox, ring, and many many others.
    I'm not telling tales, rather sharing knowledge. But, if you prefer to stick to what you think, good luck, don't complain if your system gets in a beyond-repair state. I'm out. And 'they' is you and me and all the others in this community.

    EDIT: Forgot to mention that you can use the credentials from the forums to start building missing packages in your own repo. Then submit them to Tw, after review they will be added.
    Last edited by Knurpht; 29-Mar-2018 at 06:27.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •