Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Zypper dup keeps wanting to install new, unwanted packages.

  1. #1
    Join Date
    Mar 2018
    Location
    UK
    Posts
    25

    Default Zypper dup keeps wanting to install new, unwanted packages.

    Hi all,

    I am trying to run zypper dup but when I do extra packages/programmes that I don't need or want are added too. Digikam and Showfoto are two that it wants to install at the moment. Is this normal and if so, why ?

    I'm using KDE.

  2. #2

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    Digikam is recommended by patterns-kde-kde_imaging-20170319-13.1.noarch. Showfoto and Marble are recommended by Digikam.

  3. #3
    Join Date
    Mar 2018
    Location
    UK
    Posts
    25

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    Quote Originally Posted by xorbe View Post
    Digikam is recommended by patterns-kde-kde_imaging-20170319-13.1.noarch. Showfoto and Marble are recommended by Digikam.

    Thanks for your reply xorbe

    So it is best to just let them install and then ignore them.

    Adrian

  4. #4

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    I cannot profess to know how "zypper dup" decides to add and remove packages, I just let it do its thing ... if you aren't getting any conflict resolution questions then it sounds good to me! Is this the system's first dup?

  5. #5
    Join Date
    Mar 2018
    Location
    UK
    Posts
    25

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    Quote Originally Posted by xorbe View Post
    I cannot profess to know how "zypper dup" decides to add and remove packages, I just let it do its thing ... if you aren't getting any conflict resolution questions then it sounds good to me! Is this the system's first dup?
    Yes, this is the first time I have run dup, no conflicts or anything else reportind.

    Adrian

  6. #6
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    If you not want them you can lock these packages (patterns).
    zypper al package or zypper al -t pattern (pattern you want) - without "()"

  7. #7
    Join Date
    Mar 2018
    Location
    UK
    Posts
    25

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    Quote Originally Posted by another_roadrunner View Post
    If you not want them you can lock these packages (patterns).
    zypper al package or zypper al -t pattern (pattern you want) - without "()"
    Thank you for that another_roadrunner, I will remember that, much appreciated.

  8. #8
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    Quote Originally Posted by quercus View Post
    Thank you for that another_roadrunner, I will remember that, much appreciated.
    You are welcome.
    I did myself in this way.
    Here is a link who help me a lot
    https://en.opensuse.org/SDBypper_manual_(plain)
    Regards

  9. #9
    Join Date
    Mar 2018
    Location
    UK
    Posts
    25

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    Thanks again another _roadrunner, that really is helpful, have bookmarked the page for easy reference in the future. Thank you for your help, much appreciated.

    Adrian

  10. #10
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: Zypper dup keeps wanting to install new, unwanted packages.

    With pleasure.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •