Results 1 to 4 of 4

Thread: Can't do dist upgrade

  1. #1

    Default Can't do dist upgrade

    When I run "zypper dup" I get the following message:
    16 Problems:
    Problem: problem with installed package libMyGUIEngine3-3.2.2-2.2.x86_64
    Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
    Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
    Problem: problem with installed package libudt0-4.11-3.2.x86_64
    Problem: problem with installed package libvapoursynth-script0-R38-3.3.x86_64
    Problem: problem with installed package libzimg2-2.6.2-1.1.x86_64
    Problem: problem with installed package scummvm-tools-2.0.0-7.2.x86_64
    Problem: problem with installed package qt3-3.3.8c-141.1.x86_64
    Problem: problem with installed package arts-1.5.10-40.14.x86_64
    Problem: problem with installed package qt3-devel-3.3.8c-141.1.x86_64
    Problem: problem with installed package arts-devel-1.5.10-40.14.x86_64
    Problem: problem with installed package libvapoursynth-R38-3.3.x86_64
    Problem: vlc-noX-3.0.1-2.1.x86_64 requires libvlccore9 = 3.0.1-2.1, but this requirement cannot be provided
    Problem: python-kde4-4.14.3-8.4.x86_64 requires python2-sip(api) = 12.2, but this requirement cannot be provided
    Problem: libQt5DataVisualization5-5.10.0-1.1.x86_64 requires libQt5Core.so.5(Qt_5.10)(64bit), but this requirement cannot be provided
    Problem: libmysqld18-10.1.25-2.4.x86_64 requires mariadb-errormessages = 10.1.25, but this requirement cannot be provided
    The lines down to and including vlc-noX can be fixed by changing provider, which I believe is the correct action, but from python-kde4 I have no idea what to do.
    Here's the output of zypper lr -d if that helps:
    # | Alias | Namn | Aktiverad | GPG-kontroll | Uppdatera | Prioritet | Typ | uri
    | Tj�nst
    ---+----------------------------------+----------------------------+-----------+--------------+-----------+-----------+--------+------------------------------
    ----------------------------------------------+-------
    1 | download.nvidia.com-tumbleweed | nVidia Graphics Drivers | Ja | (r ) Ja | Ja | 99 | rpm-md | https://download.nvidia.com/o
    pensuse/tumbleweed |
    2 | download.opensuse.org-non-oss | Huvudförrådet (NON-OSS) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/tu
    mbleweed/repo/non-oss/ |
    3 | download.opensuse.org-oss | Huvudförrådet (OSS) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/tu
    mbleweed/repo/oss/ |
    4 | download.opensuse.org-tumbleweed | Huvuduppderingsförråd | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/up
    date/tumbleweed/ |
    5 | http-ftp.gwdg.de-788ed8f6 | Packman Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/
    packman/suse/openSUSE_Tumbleweed/ |
    6 | http-opensuse-guide.org-25b139c0 | libdvdcss repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/rep
    o/openSUSE_Tumbleweed/ |
    7 | openSUSE-20171026-0 | openSUSE-20171026-0 | Ja | (r ) Ja | Nej | 99 | yast2 | cd:///?devices=/dev/disk/by-i
    d/ata-TSSTcorp_CDDVDW_SH-224BB_R8WS6GAD200TSM |
    8 | packman | packman | Ja | (r ) Ja | Ja | 99 | rpm-md | http://ftp.gwdg.de/pub/linux/
    misc/packman/suse/openSUSE_Tumbleweed/ |
    9 | repo-debug | openSUSE-Tumbleweed-Debug | Nej | ---- | ---- | 99 | yast2 | http://download.opensuse.org/
    debug/tumbleweed/repo/oss/ |
    10 | repo-source | openSUSE-Tumbleweed-Source | Nej | ---- | ---- | 99 | yast2 | http://download.opensuse.org/
    source/tumbleweed/repo/oss/ |

  2. #2

    Default Re: Can't do dist upgrade [SOLVED]

    I reran zypper dup just recently and now it seems to be working.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,848
    Blog Entries
    14

    Default Re: Can't do dist upgrade

    Per, you might need to do a vendor switch on the Packman repo, i.e. make sure the packages in that repo are used instead of the stock ones:
    Code:
    sudo zypper dup --from Packman\ Repository --allow-vendor-change
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Can't do dist upgrade

    You appear to have the install CD/DVD image enabled in your repository list. This can cause problems and the contents are obsoleted after the first upgrade.
    I suggest either of the following:
    Code:
     # zypper mr -d 7
    
    # zypper rr 7
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •