Results 1 to 5 of 5

Thread: Cannot not execute gajim

  1. #1

    Default Cannot not execute gajim

    Hi,

    my problem is that I can not execute gajim. The first problem was the missing python cairo library. I have installed and now I get the following error message:

    Code:
    user@localhost:~> gajim
    /usr/lib/python3.6/site-packages/gajim/gtkgui_helpers.py:58: TypeError: Passing arguments to gi.types.Boxed.__init__() is deprecated. All arguments passed will be ignored.
      BLACK = Gdk.RGBA(red=0, green=0, blue=0, alpha=1)
    /usr/lib/python3.6/site-packages/gajim/gtkgui_helpers.py:59: TypeError: Passing arguments to gi.types.Boxed.__init__() is deprecated. All arguments passed will be ignored.
      GREEN = Gdk.RGBA(red=115/255, green=210/255, blue=22/255, alpha=1)
    /usr/lib/python3.6/site-packages/gajim/gtkgui_helpers.py:60: TypeError: Passing arguments to gi.types.Boxed.__init__() is deprecated. All arguments passed will be ignored.
      RED = Gdk.RGBA(red=204/255, green=0, blue=0, alpha=1)
    /usr/lib/python3.6/site-packages/gajim/gtkgui_helpers.py:61: TypeError: Passing arguments to gi.types.Boxed.__init__() is deprecated. All arguments passed will be ignored.
      GREY = Gdk.RGBA(red=195/255, green=195/255, blue=192/255, alpha=1)
    /usr/lib/python3.6/site-packages/gajim/gtkgui_helpers.py:62: TypeError: Passing arguments to gi.types.Boxed.__init__() is deprecated. All arguments passed will be ignored.
      ORANGE = Gdk.RGBA(red=245/255, green=121/255, blue=0/255, alpha=1)
    Traceback (most recent call last):
      File "/usr/lib/python3.6/site-packages/gajim/gajim.py", line 266, in _activate
        self.interface = Interface()
      File "/usr/lib/python3.6/site-packages/gajim/gui_interface.py", line 2928, in __init__
        self.systray = statusicon.StatusIcon()
      File "/usr/lib/python3.6/site-packages/gajim/statusicon.py", line 53, in __init__
        self.xml.connect_signals(self)
    ValueError: Pointer arguments are restricted to integers, capsules, and None. See: https://bugzilla.gnome.org/show_bug.cgi?id=683599
    Have anybody an idea to solve this?

    Thanks in advance
    Björn

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,853
    Blog Entries
    2

    Default Re: Cannot not execute gajim

    Am not having any problems running gajim installed from the OSS.
    Where did you get your gajim package?

    Also,
    The install log did not describe installing python-cairo.
    Are installing a plugin that requires python-cairo?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Cannot not execute gajim

    Now, I have deinstalled python-cairo and I get the first error message again:
    Code:
    Traceback (most recent call last):
      File "/usr/lib/python3.6/site-packages/gajim/gajim.py", line 267, in _activate
        from gajim.gui_interface import Interface
      File "/usr/lib/python3.6/site-packages/gajim/gui_interface.py", line 62, in <module>
        from gajim import gtkgui_helpers
      File "/usr/lib/python3.6/site-packages/gajim/gtkgui_helpers.py", line 37, in <module>
        import cairo
    ModuleNotFoundError: No module named 'cairo'
    Here the output from zypper info gajim:
    Code:
    Informationen zu Paket gajim:
    -----------------------------
    Repository         : Haupt-Repository (OSS)                
    Name               : gajim                                 
    Version            : 1.0.1-1.1                             
    Arch               : noarch                                
    Anbieter           : openSUSE                              
    Installierte Größe : 11,3 MiB                              
    Installiert        : Ja                                    
    Status             : aktuell                               
    Quellpaket         : gajim-1.0.1-1.1.src                   
    Zusammenfassung    : XMPP client written in Python and Gtk3
    It is possible the problem is the installed python version 3.6?

  4. #4

    Default Re: Cannot not execute gajim

    For documentation: I have removed gajim and use pidgin, now. It support OMEMO, too. I have install the follwoing packages to get pidgin with OMEMO support:
    Code:
    sudo zypper install libpurple-plugin-lurch pidgin

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,312
    Blog Entries
    14

    Default Re: Cannot not execute gajim

    Quote Originally Posted by bjawebos View Post
    For documentation: I have removed gajim and use pidgin, now. It support OMEMO, too. I have install the follwoing packages to get pidgin with OMEMO support:
    Code:
    sudo zypper install libpurple-plugin-lurch pidgin
    Re gajim: you may have installed the wrong python package. Tw has both python2 and python3 available, python3 should be the default on Tw now.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •