Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Yast language does not match system language selection in one computer, depends on system-settings!

  1. #1
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Yast language does not match system language selection in one computer, depends on system-settings!

    KDE/Plasma on three desktop computers, all updated today.

    Yast control center is in pt_BR, the system language set in all three, with no secondary language set.

    BUT, in just one of the desktops all Yast modules open in English, not in pt_BR as the other two!

    Now, of the two correct boxes, one has no language set in system-settings>local configurations, and the other has this set to pt_BR.

    The "wrong" box, however, has both pt_BR and English set as preferred languages, *with* pt_BR on top, which I suppose makes English the secondary KDE language.

    If I remove English from system-settings>local config>language, yast modules are shown in pt_BR after restarting the session.

    WTH??? Yast modules language depend on KDE/Plasma settings, but not Yast's control center? And how can user Plasma settings affect Yast that run as root???

    I thought it would be a qtconfig setting, but apparently not.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,670
    Blog Entries
    3

    Default Re: Yast language does not match system language selection in one computer, depends on system-settin

    Quote Originally Posted by brunomcl View Post
    I thought it would be a qtconfig setting, but apparently not.
    Have you tried running "qtconfig" from a root shell?

    Yast is probably running under settings for the root user rather than for you.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Yast language does not match system language selection in one computer, depends on system-settin

    I haven't dissected your post, but interested to know if this guide is consistent with your experience...
    https://doc.opensuse.org/documentati...2.lang.primsec

    Does this report as expected?
    Code:
    localectl
    Remember YaST runs as root.

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: Yast language does not match system language selection in one computer, depends on system-settin

    Quote Originally Posted by nrickert View Post
    Have you tried running "qtconfig" from a root shell?
    No, I didn't get that far. The issue was fixed with local kde settings, that is the puzzling part.

    Quote Originally Posted by nrickert View Post
    Yast is probably running under settings for the root user rather than for you.
    AFAIK that's how it normally runs. Isn't yast's language settings system-wide, while kde system-settings language is user-specific?
    My surprise is in that a local setting could affect a root-owned yast module. It seems like a mix-up.

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: Yast language does not match system language selection in one computer, depends on system-settin

    Quote Originally Posted by deano_ferrari View Post
    I haven't dissected your post, but interested to know if this guide is consistent with your experience...
    https://doc.opensuse.org/documentati...2.lang.primsec
    No, I expected what is described item 4.1:
    Applications not belonging to your desktop framework are not affected by this change and may still appear in the language that was set in YaST.
    Quote Originally Posted by deano_ferrari View Post
    Does this report as expected?
    Code:
    localectl
    Remember YaST runs as root.
    It reports the same in all three boxes, run as root and as the local user:

    Code:
    :~> localectl
       System Locale: LC_CTYPE=pt_BR.UTF-8
           VC Keymap: br
          X11 Layout: br
           X11 Model: microsoftpro
         X11 Options: terminate:ctrl_alt_bksp
    Interestingly, when run for the first time after boot in the "wrong" box, it took many seconds to return the result. Subsequent runs were instantaneous, including after a session restart.

    So, I re-added American English in kde system-settings language, below pt_BR, and after restarting the session, the yast modules reverted to English, but localectl still reports the same.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,670
    Blog Entries
    3

    Default Re: Yast language does not match system language selection in one computer, depends on system-settin

    Quote Originally Posted by brunomcl View Post
    No, I didn't get that far. The issue was fixed with local kde settings, that is the puzzling part.
    I think it depends on how you start Yast.

    If you do "su -" at the command line, and then run "yast2" from that root command line, Yast will see $HOME as "/root" and use the setting for user root. I'm not sure what happens if you use "kdesu" since I don't do that. But it may leave $HOME as your home directory and use your settings. And if you start Yast from menus, it probably use "xdg-su" or similar, and that probably works the same as "kdesu".
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,562

    Cool Re: Yast language does not match system language selection in one computer, depends on system-settin

    Quote Originally Posted by brunomcl View Post
    I thought it would be a qtconfig setting, but apparently not.
    For YaST, it's in '/etc/sysconfig/language' -- at the end of the file: INSTALLED_LANGUAGES="de_DE" -- in my case …

    A "Gotcha" is in '/etc/sysconfig/keyboard' : once again, for YaST, at the end of the file there's YAST_KEYBOARD="german,pc104" -- in my case. If anything other than 'pc104' is used, then the experience is unpleasant -- there's an old post somewhere in this Forum …

  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: Yast language does not match system language selection in one computer, depends on system-settin

    Quote Originally Posted by nrickert View Post
    I think it depends on how you start Yast.
    I always start from the menu, which seems to authenticate with kdesu.

  9. #9
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: Yast language does not match system language selection in one computer, depends on system-settin

    Quote Originally Posted by dcurtisfra View Post
    For YaST, it's in '/etc/sysconfig/language' -- at the end of the file: INSTALLED_LANGUAGES="de_DE" -- in my case …

    A "Gotcha" is in '/etc/sysconfig/keyboard' : once again, for YaST, at the end of the file there's YAST_KEYBOARD="german,pc104" -- in my case. If anything other than 'pc104' is used, then the experience is unpleasant -- there's an old post somewhere in this Forum …
    OK, but what puzzles me is *why* a kde setting changes all yast modules language setting. It shouldn't, and if it should, why don't it also changes the Yast interface (i.e., Yast command center) language?

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,562

    Default Re: Yast language does not match system language selection in one computer, depends on system-settin

    Quote Originally Posted by brunomcl View Post
    OK, but what puzzles me is *why* a kde setting changes all yast modules language setting. It shouldn't, and if it should, why don't it also changes the Yast interface (i.e., Yast command center) language?
    Normally, YaST runs with everything associated with the user "root".
    • On a KDE system, you have to login to a KDE session as the user "root" and then set-up the user "root"; including "~/.profile" (the language EXPORT) and, the KDE preferences …

    Currently, I tend to set-up the KDE Window appearance for the user "root" differently to my "normal" user's window appearance …

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •