Results 1 to 9 of 9

Thread: Google-earth-pro-stable version 7.3.1.4507-0

  1. #1
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,032

    Default Google-earth-pro-stable version 7.3.1.4507-0

    Hello.
    Cannot update to / or install Google-earth-pro-stable version 7.3.1.4507-0 due to mesa-libglu missing.
    Code:
    zypper in ./google-earth-pro-stable-current.x86_64.rpm
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides mesa-libGLU needed by google-earth-pro-stable-7.3.1.4507-0.x86_64
     Solution 1: do not install google-earth-pro-stable-7.3.1.4507-0.x86_64
     Solution 2: break google-earth-pro-stable-7.3.1.4507-0.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    Previous Google-earth-pro-stable version 7.3.0.3832-0 install without problem.

    Code:
    linux-nhv4:~ # uname -a
    Linux linux-nhv4.suse 4.4.120-45-default #1 SMP Wed Mar 14 20:51:49 UTC 2018 (623211f) x86_64 x86_64 x86_64 GNU/Linux
    linux-nhv4:~ #
    Code:
    linux-nhv4:~ # lsmod | grep nvidia
    nvidia_uvm            806912  0 
    nvidia_drm             49152  1 
    nvidia_modeset       1110016  6 nvidia_drm
    nvidia              14356480  591 nvidia_modeset,nvidia_uvm
    drm_kms_helper        155648  1 nvidia_drm
    drm                   397312  4 drm_kms_helper,nvidia_drm
    ipmi_msghandler        53248  1 nvidia
    linux-nhv4:~ #
    Any help is welcome
    Thanks for helping. JCD
    __________
    server leap 15.0 -- ASUS g75vw KDE leap 15.0 -- ASUS g750JZ Optimus KDE leap 15.1 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,794
    Blog Entries
    15

    Default Re: Google-earth-pro-stable version 7.3.1.4507-0

    Hi
    Select option 2, is libGLU1 installed? Works fine here with openSUSE Leap 42.3 and amdgpu driver and libGLU1 installed...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,032

    Default Re: Google-earth-pro-stable version 7.3.1.4507-0

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Select option 2, is libGLU1 installed? Works fine here with openSUSE Leap 42.3 and amdgpu driver and libGLU1 installed...

    linux-nhv4:~ # zypper se -si libglu
    Loading repository data...
    Reading installed packages...

    S | Name | Type | Version | Arch | Repository
    --+--------------+--------+------------+--------+-----------------------
    i+ | libGLU1 | package | 9.0.0-18.4 | x86_64 | openSUSE-Leap-42.3-Oss
    i | libGLU1-32bit | package | 9.0.0-18.4 | x86_64 | openSUSE-Leap-42.3-Oss
    i | libglut3 | package | 2.8.1-8.4 | x86_64 | openSUSE-Leap-42.3-Oss
    Thanks for helping. JCD
    __________
    server leap 15.0 -- ASUS g75vw KDE leap 15.0 -- ASUS g750JZ Optimus KDE leap 15.1 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  4. #4
    Join Date
    Jun 2008
    Location
    South-West France
    Posts
    1,032

    Default Re: Google-earth-pro-stable version 7.3.1.4507-0

    Installing last version (7.3.1) and choosing option 2 seems to work.

    Thank you very much
    Thanks for helping. JCD
    __________
    server leap 15.0 -- ASUS g75vw KDE leap 15.0 -- ASUS g750JZ Optimus KDE leap 15.1 -- acer aspire s13 win 10 home -- HP Omen win 10 home - scan EPSON V500 - Brother HL2250DN - Samsung CLP-325W

  5. #5

    Default Re: Google-earth-pro-stable version 7.3.1.4507-0

    'Solution 2' does not work for me. Zypper yields

    Code:
    S  | Name                | Typ   | Version                                | Arch   | Repository               
    ---+---------------------+-------+----------------------------------------+--------+--------------------------
    i  | libGLU1             | Paket | 9.0.0-18.4                             | x86_64 | openSUSE-Leap-42.3-Oss   
    i  | libGLU1-32bit       | Paket | 9.0.0-18.4                             | x86_64 | openSUSE-Leap-42.3-Oss   
    i+ | libglue-devel       | Paket | 1.0.12+v1.git.1485976882.03d61cd-2.3.1 | x86_64 | openSUSE-Leap-42.3-Update
    i+ | libglue-devel-32bit | Paket | 1.0.12+v1.git.1485976882.03d61cd-2.3.1 | x86_64 | openSUSE-Leap-42.3-Update
    i  | libglue2            | Paket | 1.0.12+v1.git.1485976882.03d61cd-2.3.1 | x86_64 | openSUSE-Leap-42.3-Update
    i  | libglue2-32bit      | Paket | 1.0.12+v1.git.1485976882.03d61cd-2.3.1 | x86_64 | openSUSE-Leap-42.3-Update
    i+ | libglut3            | Paket | 2.8.1-8.4                              | x86_64 | openSUSE-Leap-42.3-Oss
    But google earth still does not work. Acer Laptop. Graphics is
    Code:
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller]) Subsystem: Acer Incorporated [ALI] Device 0504 Flags: bus master, fast devsel, latency 0, IRQ 26 Memory at d1400000 (64-bit, non-prefetchable) [size=4M] Memory at c0000000 (64-bit, prefetchable) [size=256M] I/O ports at 3000 [size=64] Expansion ROM at <unassigned> [disabled] Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit- Capabilities: [d0] Power Management version 2 Capabilities: [a4] PCI Advanced Features Kernel driver in use: i915 Kernel modules: i915


    Any hints appreciated.
    LEAP 15.1.1 64 bit
    KDE 5.12.8 Qt 5.9.7
    Desktop: Nvidia GTX960
    Laptop: acer aspire 5750g / intel graphics

  6. #6

    Default Re: Google-earth-pro-stable version 7.3.1.4507-0

    Quote Originally Posted by tobiasw2 View Post
    Any hints appreciated.
    Istillget these messages:

    # /opt/google/earth/pro/googleearth
    kreadconfig5: ./libQt5Core.so.5: version `Qt_5' not found (required by kreadconfig5)
    kreadconfig5: ./libQt5Core.so.5: version `Qt_5.6' not found (required by kreadconfig5)
    kreadconfig5: ./libQt5Core.so.5: version `Qt_5.6' not found (required by /usr/lib64/libKF5ConfigCore.so.5)
    kreadconfig5: ./libQt5Core.so.5: version `Qt_5' not found (required by /usr/lib64/libKF5ConfigCore.so.5)


    No ideas?

    Thanks
    LEAP 15.1.1 64 bit
    KDE 5.12.8 Qt 5.9.7
    Desktop: Nvidia GTX960
    Laptop: acer aspire 5750g / intel graphics

  7. #7
    Join Date
    Jul 2008
    Location
    Brunoy, France
    Posts
    222

    Default Re: Google-earth-pro-stable version 7.3.1.4507-0

    I confirm
    I have try zypper se -si libglu but yast ask me it doesnt found lib-mesa and so I stop install

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Google-earth-pro-stable version 7.3.1.4507-0

    Quote Originally Posted by tobiasw2 View Post
    Istillget these messages:

    # /opt/google/earth/pro/googleearth
    kreadconfig5: ./libQt5Core.so.5: version `Qt_5' not found (required by kreadconfig5)
    kreadconfig5: ./libQt5Core.so.5: version `Qt_5.6' not found (required by kreadconfig5)
    kreadconfig5: ./libQt5Core.so.5: version `Qt_5.6' not found (required by /usr/lib64/libKF5ConfigCore.so.5)
    kreadconfig5: ./libQt5Core.so.5: version `Qt_5' not found (required by /usr/lib64/libKF5ConfigCore.so.5)


    No ideas?

    Thanks
    your repo list
    Code:
    zypper lr -d

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Google-earth-pro-stable version 7.3.1.4507-0

    Quote Originally Posted by Enthalpie View Post
    I confirm
    I have try zypper se -si libglu but yast ask me it doesnt found lib-mesa and so I stop install
    Code:
    zypper se -si libglu
    means search for installed packages with libglu in their name it does not do anything except give search results
    tell us the output of
    Code:
    zypper in /path/to/google_earth.rpm
    or
    Code:
    sudo rpm --import https://dl.google.com/linux/linux_signing_key.pub
    sudo zypper in https://dl.google.com/dl/linux/direct/google-earth-pro-stable-7.3.1.x86_64.rpm
    mesa libraries are needed for 3d acceleration and they depend on your graphic card and driver
    what gpu do you have
    Code:
    sudo lspci | grep VGA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •