Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

  1. #1
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Hi,

    VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't. My system is already updated from Packman.

    What could cause this? Does these players using different plugins, backend or what?

    I'm using Leap 42.3 with KDE.

    Many thanks
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Video card and driver???

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    kaffeine uses libxine as a backend (unless you've installed the package from kde:extra which uses libvlc)
    I'd recommend checking if you have the vlc-plugin-gstreamer installed in which case vlc uses gstreamer as a backend
    Code:
    zypper se -si vlc-plugin-gstreamer
    if it's there remove it
    Code:
    zypper rm vlc-plugin-gstreamer
    what version of kaffeine do you have?
    Code:
    zypper se -si kaffeine
    another thing to consider is that by default vlc uses hardware acceleration via the vdpau interface and while this works good on nvidia devices with the propitiatory nvidia driver it can cause issues on intel and some amd chips, if you have an nvidia card install the propitiatory driver if you're using intel's buildin gpu use va-api (in vlc options) or disable hardware acceleration, what is your gpu
    Code:
    sudo lspci | grep VGA
    afaik mplayer has been depreciated and replaced with mpv and dragon uses phonon as a media framework which in turn uses gstreamer by default (it can be made to use libvlc) and gstreamer uses hardware acceleration appropriate for your hardware va-api or vdpau or none (unlike vlc which defaults to vdpau)
    there are too many variable's for us to guess why your system is acting the way it is some more info is needed

  4. #4
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Quote Originally Posted by gogalthorp View Post
    Video card and driver???
    I'm using Intel.

    Code:
    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  5. #5
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Quote Originally Posted by I_A View Post
    kaffeine uses libxine as a backend (unless you've installed the package from kde:extra which uses libvlc)
    I'd recommend checking if you have the vlc-plugin-gstreamer installed in which case vlc uses gstreamer as a backend
    Code:
    zypper se -si vlc-plugin-gstreamer
    if it's there remove it
    Code:
    zypper rm vlc-plugin-gstreamer
    what version of kaffeine do you have?
    Code:
    zypper se -si kaffeine
    another thing to consider is that by default vlc uses hardware acceleration via the vdpau interface and while this works good on nvidia devices with the propitiatory nvidia driver it can cause issues on intel and some amd chips, if you have an nvidia card install the propitiatory driver if you're using intel's buildin gpu use va-api (in vlc options) or disable hardware acceleration, what is your gpu
    Code:
    sudo lspci | grep VGA
    afaik mplayer has been depreciated and replaced with mpv and dragon uses phonon as a media framework which in turn uses gstreamer by default (it can be made to use libvlc) and gstreamer uses hardware acceleration appropriate for your hardware va-api or vdpau or none (unlike vlc which defaults to vdpau)
    there are too many variable's for us to guess why your system is acting the way it is some more info is needed
    In fact, I'm using the KDE:Extra repo.

    Code:
    viniciusbr@linux-hwbe:~> sudo zypper se -si vlc-plugin-gstreamer
    [sudo] senha para root: 
    Baixando os metadados do repositório 'KDE:Extra' .......................................[concluído]
    Construindo o cache do repositório 'KDE:Extra' .........................................[concluído]
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome             | Tipo       | Versão | Arquitetura | Repositório              
    ---+------------------+------------+--------+-------------+--------------------------
    i+ | VLC Media player | aplicativo |        | noarch      | openSUSE-Leap-42.3-Oss   
    i+ | VLC Media player | aplicativo |        | noarch      | openSUSE-Leap-42.3-Update
    There is no "vlc-plugin-gstreamer", but "vlc-codec-gstreamer". I removed it as suggested but still flickering.

    Kaffeine version:

    Code:
    viniciusbr@linux-hwbe:~> zypper se -si kaffeine
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome          | Tipo       | Versão      | Arquitetura | Repositório         
    ---+---------------+------------+-------------+-------------+---------------------
    i+ | Kaffeine      | aplicativo |             | noarch      | (Pacotes do sistema)
    i+ | kaffeine      | pacote     | 2.0.14-67.2 | x86_64      | KDE:Extra           
    i+ | kaffeine-lang | pacote     | 2.0.14-67.2 | noarch      | KDE:Extra
    My video:

    Code:
    viniciusbr@linux-hwbe:~> sudo lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Quote Originally Posted by viniciusbrbio View Post
    In fact, I'm using the KDE:Extra repo.

    Code:
    viniciusbr@linux-hwbe:~> sudo zypper se -si vlc-plugin-gstreamer
    [sudo] senha para root: 
    Baixando os metadados do repositório 'KDE:Extra' .......................................[concluído]
    Construindo o cache do repositório 'KDE:Extra' .........................................[concluído]
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome             | Tipo       | Versão | Arquitetura | Repositório              
    ---+------------------+------------+--------+-------------+--------------------------
    i+ | VLC Media player | aplicativo |        | noarch      | openSUSE-Leap-42.3-Oss   
    i+ | VLC Media player | aplicativo |        | noarch      | openSUSE-Leap-42.3-Update
    There is no "vlc-plugin-gstreamer", but "vlc-codec-gstreamer". I removed it as suggested but still flickering.

    Kaffeine version:

    Code:
    viniciusbr@linux-hwbe:~> zypper se -si kaffeine
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome          | Tipo       | Versão      | Arquitetura | Repositório         
    ---+---------------+------------+-------------+-------------+---------------------
    i+ | Kaffeine      | aplicativo |             | noarch      | (Pacotes do sistema)
    i+ | kaffeine      | pacote     | 2.0.14-67.2 | x86_64      | KDE:Extra           
    i+ | kaffeine-lang | pacote     | 2.0.14-67.2 | noarch      | KDE:Extra
    My video:

    Code:
    viniciusbr@linux-hwbe:~> sudo lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    I was working out of memory, there is a known issue with vlc and vdpau on intel chips in vlc you should just select va-api in vlc prefferences

    picture's not mine found it with google search but I get the same options on nvidia

    about kaffeine you are using 2.0 one that uses libvlc as a backend I don't know how to configure that video backend with that version
    as intel does not natively support vdpau you could try uninstalling libvdpau1 that should prevent vlc and kaffeine using vdpau
    Code:
    zypper rm libvdpau1
    just keep an eye on the dependencies
    or play with the libvlc options in kaffeine
    Last edited by I_A; 27-Mar-2018 at 11:47.

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Quote Originally Posted by viniciusbrbio View Post
    In fact, I'm using the KDE:Extra repo.

    Code:
    viniciusbr@linux-hwbe:~> sudo zypper se -si vlc-plugin-gstreamer
    [sudo] senha para root: 
    Baixando os metadados do repositório 'KDE:Extra' .......................................[concluído]
    Construindo o cache do repositório 'KDE:Extra' .........................................[concluído]
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome             | Tipo       | Versão | Arquitetura | Repositório              
    ---+------------------+------------+--------+-------------+--------------------------
    i+ | VLC Media player | aplicativo |        | noarch      | openSUSE-Leap-42.3-Oss   
    i+ | VLC Media player | aplicativo |        | noarch      | openSUSE-Leap-42.3-Update
    
    one more thing you seam to have vlc from the opensuse repo's if patented video's play (h263 h264 h265 etc) I'm assuming you also have the packman repo's but you didn't do a full vendor change and you have mixed packages
    this might cause some issues so
    what is your repo list
    Code:
    zypper lr -d

  8. #8
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Quote Originally Posted by I_A View Post
    I was working out of memory, there is a known issue with vlc and vdpau on intel chips in vlc you should just select va-api in vlc prefferences

    picture's not mine found it with google search but I get the same options on nvidia

    about kaffeine you are using 2.0 one that uses libvlc as a backend I don't know how to configure that video backend with that version
    as intel does not natively support vdpau you could try uninstalling libvdpau1 that should prevent vlc and kaffeine using vdpau
    Code:
    zypper rm libvdpau1
    just keep an eye on the dependencies
    or play with the libvlc options in kaffeine
    I changed to va-api via x11 and worked fine! Many thanks
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  9. #9
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Quote Originally Posted by I_A View Post
    one more thing you seam to have vlc from the opensuse repo's if patented video's play (h263 h264 h265 etc) I'm assuming you also have the packman repo's but you didn't do a full vendor change and you have mixed packages
    this might cause some issues so
    what is your repo list
    Code:
    zypper lr -d
    Code:
    viniciusbr@linux-hwbe:~> zypper lr -d
    As prioridades de repositório não possuem efeito algum. Todos os repositórios habilitados possuem a mesma prioridade.
    
    #  | Apelido                             | Nome                                    | Habilitado | Verificação GPG | Atualizar | Prioridade | Tipo   | URI                                                                             | Serviço
    ---+-------------------------------------+-----------------------------------------+------------+-----------------+-----------+------------+--------+---------------------------------------------------------------------------------+--------
     1 | MEGAsync                            | MEGAsync                                | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | https://mega.nz/linux/MEGAsync/openSUSE_Leap_42.3/                              |        
     2 | http-download.opensuse.org-4533bd1f | KDE:Extra                               | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.3/        |        
     3 | http-download.opensuse.org-a2f2ae0e | LibreOffice:6.0                         | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/6.0/openSUSE_Leap_42.3/  |        
     4 | http-download.opensuse.org-a633788e | home:snwh:paper                         | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/home:/snwh:/paper/openSUSE_Leap_42.2/ |        
     5 | http-download.opensuse.org-c2a91ff2 | Emulators                               | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/Emulators/openSUSE_Leap_42.3/         |        
     6 | http-download.opensuse.org-e34c0d26 | mozilla                                 | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3/           |        
     7 | libdvdcss                           | libdvdcss                               | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                              |        
     8 | openSUSE-Leap-42.3-0                | openSUSE-Leap-42.3-0                    | Não        | ----            | ----      |   99       | yast2  | cd:///?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ8C2_S_HR33_525084          |        
     9 | packman                             | packman                                 | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.3/              |        
    10 | repo-debug                          | openSUSE-Leap-42.3-Debug                | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/             |        
    11 | repo-debug-non-oss                  | openSUSE-Leap-42.3-Debug-Non-Oss        | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/         |        
    12 | repo-debug-update                   | openSUSE-Leap-42.3-Update-Debug         | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                        |        
    13 | repo-debug-update-non-oss           | openSUSE-Leap-42.3-Update-Debug-Non-Oss | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/                    |        
    14 | repo-non-oss                        | openSUSE-Leap-42.3-Non-Oss              | Sim        | (r ) Sim        | Sim       |   99       | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/               |        
    15 | repo-oss                            | openSUSE-Leap-42.3-Oss                  | Sim        | (r ) Sim        | Sim       |   99       | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                   |        
    16 | repo-source                         | openSUSE-Leap-42.3-Source               | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/            |        
    17 | repo-source-non-oss                 | openSUSE-Leap-42.3-Source-Non-Oss       | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/        |        
    18 | repo-update                         | openSUSE-Leap-42.3-Update               | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                              |        
    19 | repo-update-non-oss                 | openSUSE-Leap-42.3-Update-Non-Oss       | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  10. #10
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: VLC and Kaffeine is flickering the videos, while Dragon Player and MPlayer doesn't

    Quote Originally Posted by viniciusbrbio View Post
    Code:
    viniciusbr@linux-hwbe:~> zypper lr -d
    As prioridades de repositório não possuem efeito algum. Todos os repositórios habilitados possuem a mesma prioridade.
    
    #  | Apelido                             | Nome                                    | Habilitado | Verificação GPG | Atualizar | Prioridade | Tipo   | URI                                                                             | Serviço
    ---+-------------------------------------+-----------------------------------------+------------+-----------------+-----------+------------+--------+---------------------------------------------------------------------------------+--------
     1 | MEGAsync                            | MEGAsync                                | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | https://mega.nz/linux/MEGAsync/openSUSE_Leap_42.3/                              |        
     2 | http-download.opensuse.org-4533bd1f | KDE:Extra                               | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.3/        |        
     3 | http-download.opensuse.org-a2f2ae0e | LibreOffice:6.0                         | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/6.0/openSUSE_Leap_42.3/  |        
     4 | http-download.opensuse.org-a633788e | home:snwh:paper                         | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/home:/snwh:/paper/openSUSE_Leap_42.2/ |        
     5 | http-download.opensuse.org-c2a91ff2 | Emulators                               | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/Emulators/openSUSE_Leap_42.3/         |        
     6 | http-download.opensuse.org-e34c0d26 | mozilla                                 | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3/           |        
     7 | libdvdcss                           | libdvdcss                               | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                              |        
     8 | openSUSE-Leap-42.3-0                | openSUSE-Leap-42.3-0                    | Não        | ----            | ----      |   99       | yast2  | cd:///?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ8C2_S_HR33_525084          |        
      9 | packman                             | packman                                 | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.3/              |        
    10 | repo-debug                          | openSUSE-Leap-42.3-Debug                | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/             |        
    11 | repo-debug-non-oss                  | openSUSE-Leap-42.3-Debug-Non-Oss        | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/         |        
    12 | repo-debug-update                   | openSUSE-Leap-42.3-Update-Debug         | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                        |        
    13 | repo-debug-update-non-oss           | openSUSE-Leap-42.3-Update-Debug-Non-Oss | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/                    |        
    14 | repo-non-oss                        | openSUSE-Leap-42.3-Non-Oss              | Sim        | (r ) Sim        | Sim       |   99       | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/               |        
    15 | repo-oss                            | openSUSE-Leap-42.3-Oss                  | Sim        | (r ) Sim        | Sim       |   99       | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                   |        
    16 | repo-source                         | openSUSE-Leap-42.3-Source               | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/            |        
    17 | repo-source-non-oss                 | openSUSE-Leap-42.3-Source-Non-Oss       | Não        | ----            | ----      |   99       | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/        |        
    18 | repo-update                         | openSUSE-Leap-42.3-Update               | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                              |        
    19 | repo-update-non-oss                 | openSUSE-Leap-42.3-Update-Non-Oss       | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/
    you should do
    Code:
    zypper dup --from 9
    to make sure all your multimedia packages are from packman

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •