Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41

Thread: After latest update no graphical Interface

  1. #1

    Default After latest update no graphical Interface

    I am running on my old 32 bit laptop (with intel graphics) Tumbleweed/KDE/LXDE for several years. Yesterday I ran again zypper dup and today I have no GUI. I tried the 4.15.10 kernel, then the previous 4.15.8 Kernel with the same result - when the booting finishes I get a black screen and all I see is the cursor instead of my login screen. Booting in rescue mode didn't go further and then I tried booting with nomodeset with the same result - black screen with cursor. Next attempt was booting into command line and ran a zypper dup. But only newer codecs were there and after this install I still had the same result - no GUI. I tried the startx command as root the computer went into the GUI. I logged out and logged in as normal user and tried systemctl isolate graphical.target. The root password was requested and afterwards again I only had the black screen with the cursor. I have no idea what is going on - any ideas anyone?

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,976

    Default Re: After latest update no graphical Interface

    Quote Originally Posted by fuerstu View Post
    I am running on my old 32 bit laptop (with intel graphics) Tumbleweed/KDE/LXDE for several years. Yesterday I ran again zypper dup and today I have no GUI. I tried the 4.15.10 kernel, then the previous 4.15.8 Kernel with the same result - when the booting finishes I get a black screen and all I see is the cursor instead of my login screen. Booting in rescue mode didn't go further and then I tried booting with nomodeset with the same result - black screen with cursor. Next attempt was booting into command line and ran a zypper dup. But only newer codecs were there and after this install I still had the same result - no GUI. I tried the startx command as root the computer went into the GUI. I logged out and logged in as normal user and tried systemctl isolate graphical.target. The root password was requested and afterwards again I only had the black screen with the cursor. I have no idea what is going on - any ideas anyone?
    You could try
    Code:
    zypper rm drm-kmp-default
    There was an update to it, I believe, and it has been causing problems in the past with some seemingly random groups of intel chips.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  3. #3

    Default Re: After latest update no graphical Interface

    Thank you, Fraser_Bell but I get the response that drm-kmp-default is not installed.Has tumbleweed switched to wayland?

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,976

    Default Re: After latest update no graphical Interface

    Quote Originally Posted by fuerstu View Post
    Thank you, Fraser_Bell but I get the response that drm-kmp-default is not installed.Has tumbleweed switched to wayland?
    Hmmm. That is a factor for those running Gnome, I believe I just recently saw in the mailing lists.

    However, I do not know if LXDE is affected, and I am not using 32 bit, where things can be a bit different.

    I am running TW, 15.0, and 42.3, ran updates earlier today, having no issues. I am using Xfce on all three versions.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  5. #5
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,976

    Default Re: After latest update no graphical Interface

    Ucode also updated, but AFAIK, if that was a problem it would lock at "Loading initial ramdisk"

    But, you could experiment with it, anyway, and see if
    Code:
    dis_ucode_ldr
    at the end of the kernel boot line helps.

    If not, you could instead try one of:
    Code:
    nopti
    or
    Code:
    nospec
    or
    Code:
    noefi
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  6. #6

    Default Re: After latest update no graphical Interface

    I am not running Gnome - is there a way to check whether wayland oc X11 is running? Normally I used the i915 kernel driver and lsmod shows that this is loaded.

  7. #7
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,976

    Default Re: After latest update no graphical Interface

    ... or, you might try:
    Code:
    zypper in drm-kmp-default
    Perhaps you need it with the newer kernel???

    ... Just taking frantic stabs in the dark until someone who knows something better shows up here.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  8. #8

    Default Re: After latest update no graphical Interface

    OK - with running from one computer to try and then to the other to post - our answers have crossed. I presume your other codes there are to be inserted in Grub before booting. Will continue to try tomorrow morning..... Had enough for today with this computer. Hopefully I have a few more ideas by then.

  9. #9
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,976

    Default Re: After latest update no graphical Interface

    Quote Originally Posted by fuerstu View Post
    OK - with running from one computer to try and then to the other to post - our answers have crossed. I presume your other codes there are to be inserted in Grub before booting. Will continue to try tomorrow morning..... Had enough for today with this computer. Hopefully I have a few more ideas by then.
    Yes, and if Wolfi shows up in the meantime, he is usually particularly good at this type of problem.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  10. #10
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,408

    Default Re: After latest update no graphical Interface

    "Old" doesn't have the same meaning in every context or to everyone. Please tell us more by using
    Code:
    lspci -nnk | grep VGA
    and/or
    Code:
    inxi -G -c0
    to report which it is you have. I have multiple installations to "old" Intel gfx systems, and none have required drm-kmp-default as yet. Knowing which you have I might be able to match yours and test it specifically (e.g. 845 or 865).

    Nomodeset with any Intel gfx defeats use of either competent GUI driver (modesetting or intel) intended for Intel gfx. It's useful mainly only for troubleshooting non-GUI issues or performing repairs sans GUI.

    Which DM are you using? SDDM? LightDM? GDM? KDM? XDM?
    Code:
    ps -A | egrep 'X|land'
    should tell which server, if any, is running.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •