Results 1 to 7 of 7

Thread: Viber. Can't install on OpenSUSE 42.3 XFCE

  1. #1

    Default Viber. Can't install on OpenSUSE 42.3 XFCE

    Hi, guys!

    I can't install Viber on OpenSUSE 42.3 (XFCE).

    Package "viber.rpm" from official site.

    Please help me! I am total frustated...

    Logs:
    http://paste.opensuse.org/93653333

    What I did, but it didn't help:

    ***libcrypto***

    ln -s /lib/libcrypto.so.1.0.0 /lib/libcrypto.so.10
    ln -s /lib64/libcrypto.so.1.0.0 /lib64/libcrypto.so.10

    ln -s /usr/lib/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.10
    ln -s /usr/lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.10

    ***libpulse***

    Installed:
    libpulse-mainloop-glib0
    libpulse-mainloop-glib0-32bit
    libpulse0
    libpulse0-32bit
    https://drive.google.com/open?id=10l...28w7aUVos7Gk7B
    I changed (downgrade) versions. But it also didn't help.

    ***gstreamer***

    Installed additionally:
    gstreamer-plugins-libav
    gstreamer-plugins-ugly
    gstreamer-plugins-good

  2. #2
    Join Date
    Apr 2016
    Location
    North America
    Posts
    526

    Default Re: Viber. Can't install on OpenSUSE 42.3 XFCE

    I can't help with that, but in case you are interested in open-source alternatives:

    https://wiki.p2pfoundation.net/P2P_C...ation_Software

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Viber. Can't install on OpenSUSE 42.3 XFCE

    looks like a pulse audio issue
    do you have pulseaudio installed?
    you can try using pavucontrol to setup pulse audio
    you can also use the hardware section in yast to setup (and enable pulse audio)
    to install pavucontrol (which should install pulseaudio too) do
    Code:
    zypper in pavucontrol
    What I did, but it didn't help:

    ***libcrypto***

    Code:
    ln -s /usr/lib/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.10
    ln -s /usr/lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.10
    
    that looks about right

    ***libpulse***

    Installed:
    libpulse-mainloop-glib0
    libpulse-mainloop-glib0-32bit
    libpulse0
    libpulse0-32bit
    https://drive.google.com/open?id=10l...28w7aUVos7Gk7B
    I changed (downgrade) versions. But it also didn't help.
    you really shuldn't have done that tell us your repo list
    Code:
    zypper lr -d
    ***gstreamer***

    Installed additionally:
    gstreamer-plugins-libav
    gstreamer-plugins-ugly
    gstreamer-plugins-good
    that doesn't give us much info we don't know from where gstreamer is (in your case it doesn't matter)

    I have installed (latter removed) viber on LEAP aside from linking the 64bit shared object libcrypto.so.1.0.0 to libcrypto.so.10 there is nothing else to be done
    what I did to get viber working on a clean system
    Code:
    ln -s /usr/lib64/libcrypto.so.1.0.0 /usr/lib64/libcrypto.so.10
    ldconfig
    zypper in /path/to/viber.rpm
    
    that being said I've never used xfce afaik it should use pulseaudio unless you chose an exotic install

  4. #4

    Default Re: Viber. Can't install on OpenSUSE 42.3 XFCE

    That's my "zypper lr -d":
    http://paste.opensuse.org/22937451

    I installed pavucontrol and run PulseAudio, but get the message:
    https://drive.google.com/open?id=11X...HDoLy_wv0xkn5E
    What should I do with that?

    Please tell me what version you tried to install Viber on. I know on 42.2 it's no problem.

    But with 42.3 I tried to install Viber on 3 PCs and I have no success.

  5. #5

    Default Re: Viber. Can't install on OpenSUSE 42.3 XFCE

    Still get the message:

    Code:
    /opt/viber/Viber
    Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
    Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
    Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
    Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
    PulseAudioService: pa_context_connect() failed
    PulseAudioService: pa_context_connect() failed
    Assertion 'pthread_mutex_unlock(&m->mutex) == 0' failed at pulsecore/mutex-posix.c:108, function pa_mutex_unlock(). Aborting.
    Аварийный останов (core dumped)

  6. #6

    Default Re: Viber. Can't install on OpenSUSE 42.3 XFCE

    OMG! Guys! I don't believe in that!

    I launched the Viber!

    It happened after I had installed package "pulseaudio" ("alsa-plugins-pulse").

    Tommorow I test that on others PCs and can give you the 100% right answer!

  7. #7

    Default Re: Viber. Can't install on OpenSUSE 42.3 XFCE

    So, the solution to run Viber on OpenSUSE 42.3 is:

    1. zypper in path/to/viber.rpm (press "2", "y", "i").
    2. Install package "libpulse-mainloop-glib0".
    3. Install package "pulseaudio".
    4. run /opt/viber/Viber.
    5. Have fun!

    P. S. You do not need to do any symlinks!

    Thanks a lot for HELP!)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •