Hi,
This morning when I tried to login to my computer, I got a blank screen with a small window saying "Could not sync environment to dbus". Only the mouse pointer is visible. I did not notice any unusual behavior before I shutdown my computer last night. I am able to login using icewm. I looked at some linux forums and one post suggested to switch to tty2 and login using the command "dbus-launch xinit startkde -- :2 vt2". I did and it worked. However, I am only able to login using the command "dbus-launch xinit startkde -- :2 vt2" in tty2. If I try to login via SDDM, I am getting a blank screen. When I am in tty2 and type in "plasmashell", "startkde" and "startx", I get the following:
Code:
raaj@raaj-Laptop:~>plasmashell
qt.qpa.screen: QXcbConnection: could not connect to display
could not connect to any X display

raaj@raaj-Laptop:~>startkde
Could not start D-Bus. Can you call qdbus-qt5?
$Display is not set or cannot connect to the X server

raaj@raaj-Laptop:~>startx
hostname: Name or service not known
xauth:  file /home/raaj/.serverauth.5317 does not exist

_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
(EE) 
Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE) 
(EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/home/raaj/.local/share/xorg/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1 keyxinit: giving up
xinit: unable to connect to X server: Resource temporarily unavailable
xinit: server error
-------------------------------------------------------------------------------------------
xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
If so either use a display manager (strongly recommended) or adjust /etc/permissions.local and run "chkstat --system --set" afterwards
Xorg.0.log is
Code:
[   941.791] _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
[   941.792] _XSERVTransMakeAllCOTSServerListeners: server already running
[   941.792] (EE) 
Fatal server error:
[   941.792] (EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE) 
[   941.792] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   941.792] (EE) Please also check the log file at "/home/raaj/.local/share/xorg/Xorg.0.log" for additional information.
[   941.792] (EE) 
[   941.792] (EE) Server terminated with error (1). Closing log file.
Your help is very much appreciated.