Results 1 to 7 of 7

Thread: I lost Win 10 in the boot menu on an X220 Thnk Pad

  1. #1
    Join Date
    Jan 2009
    Location
    West of the Mississippi...
    Posts
    37

    Default I lost Win 10 in the boot menu on an X220 Thnk Pad

    I installed Tumbleweed on an X220 Think Pad with Win 10. I first set the bios to boot legacy and secure so that it would boot either Windows or OpenSuse. It worked great for about a week and then after the updates, the daily updates, last Saturday I no longer see Win 10 as a boot option when I start the computer. The partitions are still there but somehow I no longer can see Win 10 as a boot choice and have not been able to access the windows hard drive area. ?? Any thoughts on this? Suggestions? Any help would be much appreciated.

    Cheers...

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: I lost Win 10 in the boot menu on an X220 Thnk Pad

    Quote Originally Posted by zxr250cc View Post
    I installed Tumbleweed on an X220 Think Pad with Win 10. I first set the bios to boot legacy and secure so that it would boot either Windows or OpenSuse. It worked great for about a week and then after the updates, the daily updates, last Saturday I no longer see Win 10 as a boot option when I start the computer. The partitions are still there but somehow I no longer can see Win 10 as a boot choice and have not been able to access the windows hard drive area. ?? Any thoughts on this? Suggestions? Any help would be much appreciated.

    Cheers...
    Yast=>Bootloader

    Make sure Probe Foreign OS is checked.

    Then re-install the bootloader (Grub).
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: I lost Win 10 in the boot menu on an X220 Thnk Pad

    Also be sure that fast boot is off in Windows or grub may not see it. But if this is a legacy boot I'm not sure if fast boot functions in a MBR boot.
    .

  4. #4
    Join Date
    Jan 2009
    Location
    West of the Mississippi...
    Posts
    37

    Default Re: I lost Win 10 in the boot menu on an X220 Thnk Pad

    Hi all,

    I did updates again last evening and now Win 10 is back... Boots fine, works OK, as it should. I was quite surprised.

    Cheers

  5. #5
    Join Date
    Jan 2009
    Location
    West of the Mississippi...
    Posts
    37

    Default Re: I lost Win 10 in the boot menu on an X220 Thnk Pad

    This is getting weird. It (Win 10) now is missing again. ??

    Assume the question marks are harsh language...

    Cheers

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: I lost Win 10 in the boot menu on an X220 Thnk Pad

    How do you shutdown Win10?? Any hibernation including fast boot will make the partition invisible to Linux

    Show us fdisk - l

    Please us code tags to preserve format (# in the tool bar here)
    Last edited by Fraser_Bell; 22-Mar-2018 at 15:17. Reason: fix typos that cause loss of clarity

  7. #7
    Join Date
    Jan 2009
    Location
    West of the Mississippi...
    Posts
    37

    Default Re: I lost Win 10 in the boot menu on an X220 Thnk Pad

    Quote Originally Posted by gogalthorp View Post
    How do you shutdown Win10?? Any hibernation including fast boot will make the partition invisible to Linux

    Show us fdisk - l

    Please us code tags to preserve format (# in the tool bar here)
    [CODE][CODE]

    Hi all,

    I shut off fast boot and it has been OK since then. I never use suspend for any software. Thanks for the idea about killing fast boot.

    Cheers...

    Disk /dev/sda: 698.7 GiB, 750156374016 bytes, 1465149168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: dos
    Disk identifier: 0xa2d1c0f9

    Device Boot Start End Sectors Size Id Type
    /dev/sda1 * 2048 718847 716800 350M 7 HPFS/NTFS/exFAT
    /dev/sda2 718848 859711487 858992640 409.6G 7 HPFS/NTFS/exFAT
    /dev/sda3 1434425344 1465145343 30720000 14.7G 27 Hidden NTFS WinRE
    /dev/sda4 859711488 1434425343 574713856 274G 83 Linux

    Partition table entries are not in disk order.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •