Results 1 to 10 of 10

Thread: Error applications using libpango (gimp, chromium, firefox, etc...)

  1. #1

    Default Error applications using libpango (gimp, chromium, firefox, etc...)

    After last week update I have issues running applications with using libpango.


    Every application related to libpango returns Error:


    Code:
    # chromium
    /usr/lib64/chromium/chromium: symbol lookup error: /usr/lib64/libpango-1.0.so.0: undefined symbol: g_log_structured_standard
    # gimp
    gimp: symbol lookup error: /usr/lib64/libatk-1.0.so.0: undefined symbol: g_log_structured_standard
    # firefox
    XPCOMGlueLoad error for file /usr/lib64/firefox/libmozgtk.so:
    /usr/lib64/libpango-1.0.so.0: undefined symbol: g_log_structured_standard
    Couldn't load XPCOM.

    libpango
    Code:
    Information for package libpango-1_0-0:
    ---------------------------------------
    Repository     : OpenSUSE-Tumbleweed-Oss                  
    Name           : libpango-1_0-0                           
    Version        : 1.42.0-1.1                               
    Arch           : x86_64                                   
    Vendor         : openSUSE                                 
    Installed Size : 605.4 KiB                                
    Installed      : Yes                                      
    Status         : up-to-date                               
    Source package : pango-1.42.0-1.1.src                     
    Summary        : Library for Layout and Rendering of Text

    My system is:
    Code:
    # cat /etc/os-release
    NAME="openSUSE Tumbleweed"
    # VERSION="20180316"
    ID=opensuse
    ID_LIKE="suse"
    VERSION_ID="20180316"
    PRETTY_NAME="openSUSE Tumbleweed"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:opensuse:tumbleweed:20180316"
    BUG_REPORT_URL="https://bugs.opensuse.org"
    HOME_URL="https://www.opensuse.org/"

    KDE:
    Code:
    # kde4-config -v
    Qt: 4.8.7
    KDE: 4.14.38
    kde4-config: 1.0

    Also now I can't login to GNOME shell - after a sec back to login screen...
    Code:
    Information for package gnome-shell:
    ------------------------------------
    Repository     : OpenSUSE-Tumbleweed-Oss    
    Name           : gnome-shell                
    Version        : 3.28.0-1.1                 
    Arch           : x86_64                     
    Vendor         : openSUSE                   
    Installed Size : 8.1 MiB                    
    Installed      : Yes                        
    Status         : up-to-date                 
    Source package : gnome-shell-3.28.0-1.1.src
    Summary        : GNOME Shell

  2. #2
    Join Date
    Mar 2014
    Location
    switzerland
    Posts
    2

    Default Re: Error applications using libpango (gimp, chromium, firefox, etc...)

    same to me!
    any help???
    thanks

  3. #3

    Default Re: Error applications using libpango (gimp, chromium, firefox, etc...)

    Run "sudo zypper dup" (not "zypper up" or anything else), to make sure your system is really fully up-to-date.
    In case of conflicts please post the exact message.

    If that doesn't help, please post your repo list:
    Code:
    zypper lr -d

  4. #4

    Default Re: Error applications using libpango (gimp, chromium, firefox, etc...)

    I'm having the same problem since 2018-03-17 when libpango was updated.

    Code:
    $ sudo zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    10 Problems:
    Problem: problem with installed package libQtWebKit4-4.8.7+2.3.4-4.1.x86_64
    Problem: problem with installed package libQtWebKit-devel-4.8.7+2.3.4-4.1.x86_64
    Problem: problem with installed package qt3-3.3.8c-141.1.x86_64
    Problem: problem with installed package libmjpegutils-2_0-0-2.0.0-26.1.x86_64
    Problem: problem with installed package libmpeg2-0-0.5.1-3.42.x86_64
    Problem: problem with installed package libmpeg2convert0-0.5.1-3.42.x86_64
    Problem: problem with installed package mjpegtools-2.0.0-26.1.x86_64
    Problem: nothing provides typelib-1_0-WebKit-3_0 needed by gufw-16.04.0-1.8.noarch
    Problem: libopenssl-1_0_0-devel-1.0.2n-2.1.x86_64 conflicts with libopenssl-devel > 1.0.2n provided by libopenssl-devel-1.1.0g-2.1.noarch
    Problem: SuSEfirewall2-3.6.378-2.1.noarch conflicts with firewalld provided by firewalld-0.5.1-1.1.noarch
    
    Problem: problem with installed package libQtWebKit4-4.8.7+2.3.4-4.1.x86_64
     Solution 1: install libQtWebKit4-4.8.7+2.3.4-2.48.x86_64 (with vendor change)
      openSUSE  -->  http://packman.links2linux.de
     Solution 2: keep obsolete libQtWebKit4-4.8.7+2.3.4-4.1.x86_64
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c):
    Code:
    $ zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    # | Alias                               | Name                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                    | Service
    --+-------------------------------------+----------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------+--------
    1 | http-download.opensuse.org-aab66fc3 | home:bosim:suse-prime      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/bosim:/suse-prime/openSUSE_Tumbleweed/ |        
    2 | kernel-repo                         | kernel-repo                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Kernel:/HEAD/standard/                       |        
    3 | nvidia-tumbleweed                   | nvidia-tumbleweed          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/tumbleweed                                        |        
    4 | packman                             | packman                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                    |        
    5 | repo-debug                          | openSUSE-Tumbleweed-Debug  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                                |        
    6 | repo-oss                            | openSUSE-Tumbleweed-Oss    | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/tumbleweed/repo/oss/                                      |        
    7 | repo-source                         | openSUSE-Tumbleweed-Source | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                               |        
    8 | repo-update                         | openSUSE-Tumbleweed-Update | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                        |

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,218

    Default AW: Error applications using libpango (gimp, chromium, firefox, etc...)

    Solution 1?

  6. #6

    Default AW: Error applications using libpango (gimp, chromium, firefox, etc...)

    Quote Originally Posted by Sauerland View Post
    Solution 1?
    Exactly this.

    And you should allow the vendor change for the other problematic packages as well to unblock the upgrade.

    Qt3 and libQtWebKit4 have been dropped from openSUSE because they are unmaintained since years (and even considered a security risk), Packman does still provides them for packages (on Packman) that need them.
    OTOH, libmpeg2 and mjpegutils (with MPEG2 support) are not available on Packman anymore because they are part of the distribution now as the patents expired.

    Plus:
    You should remove libopenssl-1_0_0-devel, as it conflicts with libopenssl-1_1 that you seem to have installed as well.
    And SuSEfirewall2 has been replaced with firewalld recently. You currently have to choose one or the other and cannot have both (because there were indications that having both could cause problems), but that should be "fixed" soon by removing that conflict again (although you shouldn't have both running).
    No idea about gufw, but that apparently needs some package that is not available (typelib-1_0-WebKit-3_0), so better uninstall it as well.
    Last edited by wolfi323; 20-Mar-2018 at 09:25.

  7. #7

    Thumbs up Re: Error applications using libpango (gimp, chromium, firefox, etc...)

    And after some digging in other sites
    libglib-2_0-0 was not updated
    We need version 2.56.0-1.1
    On my system was 2.54.2-4.2 because of related package gio-branding-openSUSE-42.1-9.1
    Force update to version 2.56 libglib-2 was successful. Application back.

    Code:
    Information for package libglib-2_0-0:
    ---------------------------------------
    Repository     : OpenSUSE-Tumbleweed-Oss                  
    Name           : libglib-2_0-0                           
    Version        : 2.56.0-1.1                              
    Arch           : x86_64                                   
    Vendor         : openSUSE                                 
    Installed Size : 1,5 MiB 
    Installed      : Yes                                      
    Status         : out-of-date (version 2.54.2-4.2 installed)
    Source package : glib2-2.56.0-1.1.src                     
    Summary        : General-Purpose Utility Library
    Thanks for help.
    Last edited by dissssid; 20-Mar-2018 at 09:44. Reason: forgot about thanks

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,218

    Default AW: Error applications using libpango (gimp, chromium, firefox, etc...)

    On Tumbleweed only
    Code:
    zypper dup
    does Udate the System, all other things like
    Code:
    zypper up
    or the Plasmoid does not work properly.

    But this is only for Tumbleweed, not for Leap.

  9. #9

    Default Re: Error applications using libpango (gimp, chromium, firefox, etc...)

    Quote Originally Posted by dissssid View Post
    On my system was 2.54.2-4.2 because of related package gio-branding-openSUSE-42.1-9.1
    Right, Tumbleweed currently has gio-branding-openSUSE-42.1-3.1 which is *lower* version, but only "zypper dup" downgrades packages so the outdated one was being kept (which also prevented glib2 from being updated because of package dependencies).

    The -9.1 package seems to come from Leap 42.3 though. So it seems you either never properly upgraded to Tumbleweed in the first place (with "zypper dup"), or you still have the 42.3 repo(s) in your repo list (which you shouldn't).
    Please check the latter, or you may run into problems again eventually.

    If in doubt, please post your repo list ("zypper lr -d") so others can check.
    Last edited by wolfi323; 20-Mar-2018 at 10:11.

  10. #10

    Default Re: Error applications using libpango (gimp, chromium, firefox, etc...)

    Thanks @Sauerland and @wolfi323! Solving conflicts in zypper dup did the trick. :-)

    I must say, I didn't expect the problem to go away after that, since there were no conflicts with libpango.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •