Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Prevent Tumbleweed shutdown

  1. #1

    Default Prevent Tumbleweed shutdown

    I can't seem to configure Tumbleweed so it doesn't shutdown after a period of inactivity when no one is logged on. The Yast configuration tool seems to be tied to particular users. The machine is primarily used as a server with no one logged on. Any help would be appreciated.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Prevent Tumbleweed shutdown

    It never shuts down here, unless I shut it down. I thought that was the default, because did not do anything to get this behavior.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Prevent Tumbleweed shutdown

    Do you mean hibernate? Or suspend?

    It does not normally shut down, at least not by default, but power settings might cause the above?
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,822

    Default Re: Prevent Tumbleweed shutdown

    Quote Originally Posted by morrisjm8421 View Post
    The Yast configuration tool seems to be tied to particular users.
    Like the others say, I do not use TW btw, but all openSUSE versions I used never shut down "out of their own" (that is, I have a cron job running every 5 mins after 23:00 that shuts it down when nobody is logged in and it's NFS clients are not running, but that is my own programming).

    But the above quoted part of your post I do not understand, thus I can not decide if it is an important part of your problem description. Can you explain what you mean with it?
    Henk van Velden

  5. #5

    Default Re: Prevent Tumbleweed shutdown

    I should have said that the machine goes to sleep. It behaves like a laptop in the sense that it goes to sleep after 10 minutes or so of inactivity. It reawakens when you press a key. I use this machine as a server and for years it worked as expected. However, the most recent update of Tumbleweed (on Friday, California time) installed some software that configured it to shutdown laptop style. I can't find where the parameter is. I assume it's in the systemd files somewhere, but I haven't yet found it.

    When logged on as a specific user, in the Settings window that's activated from the power icon in the upper right corner of the screen, there's a power submenu in which you can specify that automatic suspend is to be turned off. This doesn't seem to make any difference. The machine suspends anyway.

    Any help would be greatly appreciated.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Prevent Tumbleweed shutdown

    My laptop and my desktop both "go to sleep" after a period of inactivity. But it is only the monitor that goes to sleep. The computer itself is still running. For example, I can login with "ssh" from another computer.

    If there is a power failure, then my laptop will really go to sleep. It won't just be the display, and I won't be able to access with "ssh" until it has woken.

    If it is just the display going to sleep, then that won't affect the server functions that are still running.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: Prevent Tumbleweed shutdown

    I have made some progress. Systemd was updated recently for Tumbleweed. However, the files in /etc/systemd were not updated. I discovered this by deleting /etc/systemd/logind.conf and rebooting. I did this this assuming that the original logind.conf would be restored by the reboot (per comments in the file). However, recent changes to systemd caused some of the files in /etc/systemd to be replaced, among them logind.conf. The new set of files, not surprisingly, work fine.

    Thanks for the comments.

  8. #8

    Default Re: Prevent Tumbleweed shutdown

    I commented too soon. The system works much better, but still suspends after 10 minutes or so. This happens with no one logged on. The system is asleep; it's not the case that the monitor is merely blanked. For example, it doesn't respond to pings.

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Prevent Tumbleweed shutdown

    Have you checked whether there are BIOS settings involved?
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  10. #10

    Default Re: Prevent Tumbleweed shutdown

    I disabled sleep mode in the bios, but the system went to sleep anyway. I am going to try masking the systemd targets sleep, suspend, hibernate, and hybrid-sleep.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •