Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Very slow boot of Windows 10 after using openSUSE

  1. #1

    Default Very slow boot of Windows 10 after using openSUSE

    Hello!
    I just installed openSUSE Leap 42.3 on my Asus next to Windows 10 (dual boot). Everytime when I boot windows after having used openSUSE peviously, boot takes 5+ minutes. When I boot Windows after having used Windows, boot is quick as always. I haven't found anything helpful in a google search so far, only tips on how to speed up boot in Win 10 in general, but those don't help.
    Any idea what could cause this? Let me know if you need more information.
    Thanks in advance!

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: Very slow boot of Windows 10 after using openSUSE

    That's probably due to windows fast boot. See https://www.windowscentral.com/how-d...0-fast-startup

  3. #3

    Default Re: Very slow boot of Windows 10 after using openSUSE

    Quote Originally Posted by brunomcl View Post
    That's probably due to windows fast boot. See https://www.windowscentral.com/how-d...0-fast-startup
    Thanks for the answer, but no, fastboot has been deactivated... I let Windows performance analyser run during boot, but I have no idea how to read the output. Could you have a look at it? Or do you have any other suggestions what to do?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Very slow boot of Windows 10 after using openSUSE

    Hi, welcome

    Let me make one thing very clear: openSUSE does by no means touch your Windows OS, hence not influence it's boot time. Like Brunomci writes, I too suspect fast-boot
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: Very slow boot of Windows 10 after using openSUSE

    Quote Originally Posted by Knurpht View Post
    Hi, welcome

    Let me make one thing very clear: openSUSE does by no means touch your Windows OS, hence not influence it's boot time. Like Brunomci writes, I too suspect fast-boot
    Hi
    Maybe the OP's system is automounting the windows partition with ntfs-3g (and perhaps failing) and perhaps not cleanly removing. Windows then goes through a file system check on boot.

    @OP when shutting down windows, do you just do a shutdown, or a full shutdown, either via shutdown /s /t 5 or hold the shift-key and select shutdown to ensure the disk is not using fast-start.... Also check the BIOS to ensure if there is an option for this to disable.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: Very slow boot of Windows 10 after using openSUSE

    I'll add a point of experience here.

    I have Windows 8.1 installed. I turned off "fast-boot" a long time ago.

    I rarely mount the Windows partition to my openSUSE system. When I tried recently, I got error messages suggesting a "fast-boot" problem.

    I booted to windows and checked. And "fast-boot" was disabled. But, back in openSUSE, I still could not mount.

    Finally, I disabled hibernation in Windows. And that fixed the problem.

    So it looks to me as if Windows is cheating. It tells you that fast-boot is disabled, but it isn't fully disabled until you also disable hibernation.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,325
    Blog Entries
    15

    Default Re: Very slow boot of Windows 10 after using openSUSE

    On Sun 18 Mar 2018 07:46:01 PM CDT, nrickert wrote:

    I'll add a point of experience here.

    I have Windows 8.1 installed. I turned off "fast-boot" a long time ago.

    I rarely mount the Windows partition to my openSUSE system. When I
    tried recently, I got error messages suggesting a "fast-boot" problem.

    I booted to windows and checked. And "fast-boot" was disabled. But,
    back in openSUSE, I still could not mount.

    Finally, I disabled hibernation in Windows. And that fixed the problem.

    So it looks to me as if Windows is cheating. It tells you that
    fast-boot is disabled, but it isn't fully disabled until you also
    disable hibernation.


    Hi
    That's why I always add the shutdown command switches to ensure it
    really does get rid of the hiberfile.sys...

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.3|GNOME 3.20.2|4.4.114-42-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: Very slow boot of Windows 10 after using openSUSE

    Quote Originally Posted by malcolmlewis View Post
    Also check the BIOS to ensure if there is an option for this to disable.
    Yes, IIRC it's not enough to disable it in windows. I had to disable something called "Intel Rapid Start" (or a similar name) in my daughter's laptop UEFI/BIOS, or fast boot would turn back on when running windows 8.

  9. #9
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: Very slow boot of Windows 10 after using openSUSE

    Quote Originally Posted by brunomcl View Post
    Yes, IIRC it's not enough to disable it in windows. I had to disable something called "Intel Rapid Start" (or a similar name) in my daughter's laptop UEFI/BIOS, or fast boot would turn back on when running windows 8.
    Or perhaps it was related to the 32GB SSD the laptop used as a system/hibernation cache, that I re-purposed for /...

  10. #10

    Default Re: Very slow boot of Windows 10 after using openSUSE

    OP with an update here:

    Situation changed: Boot is slow now even when starting after having used Windows....
    - fastboot is off
    - hibernation is off
    - no fastboot option in BIOS setup

    It's really funny: when I open the BIOS setup, don't change anything and go to "save changes and exit", boot takes normal amount of time.
    Also, there are three boot options available, all of them called "Windows Boot Manager". One of them leads to Grub, two of those to Windows boot.

    Another thing: I manually changed the path of the boot manager to \EFI\opensuse\shim.efi because my BIOS does not allow to disable secure boot.

    @brunomcl: How did you repurpose this SSD?? I tried the same on my laptop to no avail...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •