Results 1 to 2 of 2

Thread: KDE Plasmashell Using 100% CPU

  1. #1

    Default KDE Plasmashell Using 100% CPU

    I'm running into a lot of problems with KDE/Plasmashell. I've turned off all of the fancy options I can think and I'm still having problems.

    Pretty much every day, or twice a day, plasmashell starts consuming 100% cpu and I don't understand why. Typically I have may 4 copies of Konsole open with perhaps two dozen tabs total. I run a browser, and a commercial coding tool called SlickEdit. That's it.

    Once plasmashell starts using 100%, I kill it and then re-start it using "kstart plasmashell".

    Is there anything that can be done to stop this from happening?

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: KDE Plasmashell Using 100% CPU

    Quote Originally Posted by gsexton View Post
    I'm running into a lot of problems with KDE/Plasmashell. I've turned off all of the fancy options I can think and I'm still having problems.

    Pretty much every day, or twice a day, plasmashell starts consuming 100% cpu and I don't understand why. Typically I have may 4 copies of Konsole open with perhaps two dozen tabs total. I run a browser, and a commercial coding tool called SlickEdit. That's it.

    Once plasmashell starts using 100%, I kill it and then re-start it using "kstart plasmashell".

    Is there anything that can be done to stop this from happening?
    No expert here, but... apparently there are a number of reasons, some have been outstanding bugs for a long time - search KDE bugzilla and you'll see..

    On one laptop I noticed this when a widget is active, for example showing a copy progress notification. Other possibility is when connecting a second monitor - for example turning on a TV connected to a laptop HDMI out.

    I've seen this on and off since KDE4 on this laptop, and also on desktops although much less than the laptop.

    Sometimes disabling composition (ALT-SHIFT-F12) helps, but usually I have to log off and restart the session.

    There is no clear resolution that I could find.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •