Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

Hybrid View

  1. #1
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,296

    Default Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Very odd...

    Since the 20180312 TW snapshot Dolphin throws an error when attempting to mount media, claiming:

    "An error occurred while accessing 'Wastebin'; the system responded: The device is already mounted: Device /dev/sd(Xn) is already mounted at '/run/media/(user)/(device label)'."


    This happens when attempting to mount any device, external USB, internal (unmounted) drive, no matter what.


    For example:

    Login, Launch Dolphin and insert a USB stick. The USB correctly appears as unmounted in (Dolphin Panel) Devices section, and the Device Notifier plasmoid opens. In Dolphin, click to mount and the following happens:

    http://paste.opensuse.org/view/raw/aa9952d9


    Additionally, and I don't know if this previously worked or is related. If instead of attempting to mount the USB from a running instance of Dolphin I select "Open with file manager" from the Device Notifier, that fails with a "Malformed URL" error message.



    Looking through the change log for that snapshot, no updates occurred for Dolphin, but there was udisks2 (2.6.5 -> 2.7.6), possibly related?
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,296

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Forgot to add... also happens with another existing, and a freshly created test user.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  3. #3

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Quote Originally Posted by tannington View Post
    Looking through the change log for that snapshot, no updates occurred for Dolphin, but there was udisks2 (2.6.5 -> 2.7.6), possibly related?
    Probably.
    Dolphin (or KDE Frameworks actually) use udisks2 for mounting/unmounting.

    I haven't noticed a problem here on Leap 42.3 with the latest Frameworks 5.43 (and an older udisks2 of course)...

    Maybe try to install udisks2 from Leap 42.3 (or 15.0) as a test.
    Should be quite unproblematic to replace that. (there are two packages, udisks2 and libudisks2-0, and maybe udisks2-lang)
    Last edited by wolfi323; 14-Mar-2018 at 09:47.

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,296

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Yes...

    Installed the Leap 15 versions of udisks2 and libudisk2-0 as they are at 2.6.5 which was the version TW had prior to the update.

    Mounting from Dolphin or the Device Notifier now works correctly.

    So... where's the bug then, KDE Frameworks or udisk2.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Quote Originally Posted by tannington View Post
    So... where's the bug then, KDE Frameworks or udisk2.
    Well, it's obviously caused by a change in udisks2 then.

    Whether it's to be considered as bug in udisks2 or KDE Frameworks I cannot tell really.
    Apparently KDE Frameworks would need to be adjusted to the latest udisks2, but personally I'd say udisks2 shouldn't have such incompatible changes in the first place...

  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,296

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Quote Originally Posted by wolfi323 View Post
    Well, it's obviously caused by a change in udisks2 then.
    Yes, something in udisks2 2.6.5 -> 2.7.6 has broken KDE Frameworks mounting.

    Sorry, my "So... where's the bug then, KDE Frameworks or udisk2." was badly phrased, it was intended more as where should a bug report be directed.

    I'll file a bug against KDE Frameworks along the lines of udisks2 2.6.5 -> 2.7.6 has broken KDE Frameworks mounting, and let the KDE/udisks2 Developers take it from there.

    Thanks.


    Edit: Well I would if I knew which Framework component to file it against. Guessing, rather wildly, KIO? (As nothing else seemed to jump out at me).
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  7. #7

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Quote Originally Posted by tannington View Post
    Sorry, my "So... where's the bug then, KDE Frameworks or udisk2." was badly phrased, it was intended more as where should a bug report be directed.
    That's how I understood it anyway...

    Edit: Well I would if I knew which Framework component to file it against. Guessing, rather wildly, KIO? (As nothing else seemed to jump out at me).
    Solid is the responsible KDE Framework for this, component "frameworks-solid" in KDE's bugzilla.

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,296

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Quote Originally Posted by wolfi323 View Post
    Solid is the responsible KDE Framework for this, component "frameworks-solid" in KDE's bugzilla.
    OK. Thanks for that.

    Bug report: https://bugs.kde.org/show_bug.cgi?id=391886
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  9. #9
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,296

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    Just found these, the first looks very similar to the problem I observed.

    https://bugs.kde.org/show_bug.cgi?id=391290

    The second may also be related.

    https://bugs.kde.org/show_bug.cgi?id=391386


    I temporarily reverted back to udisks2 2.7.6 and indeed the media is actually mounted, despite the warning.

    Open Dolphin
    Insert USB stick
    Click to mount - error displayed
    Click elsewhere on a "Places" entry (Home, Downloads, whatever)
    Re-Click on the USB device - now shown as mounted and Dolphin displays the contents.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191109) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  10. #10

    Default Re: Since TW snapshot 20180312 Dolphin throws a wobbly when attempting to mount media.

    There's also https://bugs.kde.org/show_bug.cgi?id=391706 that sounds similar.
    This suggests that it may in fact be a bug or regression in solid, but maybe only the latest udisks triggers it? AFAIK it cannot be reproduced on KDE Neon, which is based on Ubuntu LTS. (and I don't see it here on Leap 42.3 with the latest Frameworks either as mentioned)
    https://marc.info/?l=kde-devel&m=152149245724878&w=2
    Last edited by wolfi323; 20-Mar-2018 at 10:22.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •