hi to all,

i need install php 7.1 for a project

so i have installed php7 with:
zypper install php7

I have installed php 7.2
Code:
php -v
PHP 7.2.2 (cli) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
i can't use php 7.2 instead 7.1 bucause this incompatibilities: http://be2.php.net/manual/en/migrati...compatible.php

i have undestand php7 package have the same name for each version.
https://forums.opensuse.org/showthre...nstall-PHP-7-1


i have this repo installed:

Code:
# | Alias                               | Nome                        | Abilitato | Controllo GPG | Aggiornamento--+-------------------------------------+-----------------------------+-----------+---------------+--------------
1 | Games                               | Games                       | Sì        | (r ) Sì       | No           
2 | Mozilla                             | Mozilla                     | No        | ----          | ----         
3 | code                                | Visual Studio Code          | Sì        | (r ) Sì       | No           
4 | google-chrome                       | google-chrome               | Sì        | (r ) Sì       | Sì           
5 | http-download.opensuse.org-54848f9d | home:opensuseitalia         | Sì        | (r ) Sì       | Sì           
6 | http-download.videolan.org-d7a88967 | SuSE                        | Sì        | (r ) Sì       | Sì           
7 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Sì        | (r ) Sì       | Sì           
8 | repo-oss                            | openSUSE-Tumbleweed-Oss     | Sì        | (r ) Sì       | Sì           
9 | repo-update                         | openSUSE-Tumbleweed-Update  | Sì        | (r ) Sì       | Sì    

If i search different version of php7

Code:
sudo zypper search -s php7


Caricamento dati del repository in corso...
Lettura dei pacchetti installati in corso...


S  | Nome                         | Tipo      | Versione        | Arch.  | Repository             
---+------------------------------+-----------+-----------------+--------+------------------------
i+ | apache2-mod_php7             | pacchetto | 7.2.2-2.1       | x86_64 | openSUSE-Tumbleweed-Oss
v  | apache2-mod_php7             | pacchetto | 7.2.2-2.1       | i586   | openSUSE-Tumbleweed-Oss
i+ | php7                         | pacchetto | 7.2.2-2.1       | x86_64 | openSUSE-Tumbleweed-Oss
v  | php7                         | pacchetto | 7.2.2-2.1       | i586   | openSUSE-Tumbleweed-Oss
   | php7-APCu                    | pacchetto | 5.1.9-1.1       | x86_64 | openSUSE-Tumbleweed-Oss
i have also search on on line packages here https://software.opensuse.org/package/php7 but is the same only version available is 7.2




is possible opensuse thumbleweed don't make avilable previous version of a packages? i think i'm do same mistake but i don't undertand where...

I have search a lot on google but i have find solution only for apt-get based sistem like ubuntu where different version of php are named different.