Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Digikam startet nicht

  1. #1

    Default Digikam startet nicht

    Weder Digikam, als auch Showphoto bringen beim Starten keine Fehlermeldung, starten aber auch nicht

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,737

    Default AW: Digikam startet nicht

    Hier startet digikam.

    Allerdings die Version aus KDE-Extra.

    Code:
    zypper se -si digikam
    Code:
    zypper lr -d

  3. #3

    Default Re: Digikam startet nicht

    Außerdem würd ich digikam bzw. showfoto mal in Konsole oder xterm aufrufen.
    Eventuell gibts dort eine hilfreiche Fehlermeldung...

  4. #4

    Default Re: Digikam startet nicht

    Quote Originally Posted by wolfi323 View Post
    Außerdem würd ich digikam bzw. showfoto mal in Konsole oder xterm aufrufen.
    Eventuell gibts dort eine hilfreiche Fehlermeldung...
    Es kommt die Fehlermeldung:

    digikam: error while loading shared libraries: libgomp.so.1: cannot open shared object file: Permission denied

    Allerdings existiert diese Datei systemweit nicht und der Versuch, libgomp1 zu installieren schlägt leider fehl

  5. #5

    Default Re: Digikam startet nicht

    Quote Originally Posted by speedy75 View Post
    Allerdings existiert diese Datei systemweit nicht und der Versuch, libgomp1 zu installieren schlägt leider fehl
    Und inwiefern schägt es fehl? Wir sind hier auch keine Hellseher.

    Installieren sollte aber sowieso nicht notwendig sein, denn sie sollte automatisch installiert worden sein.
    Außerdem existiert sie scheinbar schon, sonst wäre die Fehlermeldung "Datei nicht gefunden"...

    "Permission denied" heißt aber dass du keine Rechte hast darauf zuzugreifen.
    Was sagt denn:
    Code:
    ls -l /usr/lib64/libgomp*

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,737

    Default AW: Digikam startet nicht

    Quote Originally Posted by Sauerland View Post
    Hier startet digikam.

    Allerdings die Version aus KDE-Extra.

    Code:
    zypper se -si digikam
    Code:
    zypper lr -d
    Das fehlt auch noch.

  7. #7

    Default Re: Digikam startet nicht

    Quote Originally Posted by wolfi323 View Post
    Und inwiefern schägt es fehl? Wir sind hier auch keine Hellseher.

    Installieren sollte aber sowieso nicht notwendig sein, denn sie sollte automatisch installiert worden sein.
    Außerdem existiert sie scheinbar schon, sonst wäre die Fehlermeldung "Datei nicht gefunden"...

    "Permission denied" heißt aber dass du keine Rechte hast darauf zuzugreifen.
    Was sagt denn:
    Code:
    ls -l /usr/lib64/libgomp*
    Zuerst mal SORRY an die Community für meine langen Reaktionszeiten und SORRY an Sauerland, daß ich diese Lösung nicht weiter verfolgt habe (das Problem hätte sich dadurch nicht gelöst). Ich bin leider fast ständig im Ausland (teils ohne Internet) und habe momentan auch wenig Zeit.

    Code:
    ls -l /usr/lib64/libgomp*
    bringt folgende Liste (und das ist auch das eigentliche Problem):

    pc22:/usr/lib64 # ll libgomp*
    lrwxrwxrwx 1 root root 27 18. Mär 19:07 libgomp-plugin-hsa.so.1 -> libgomp-plugin-hsa.so.1.0.0
    -rwxr-xr-x 1 root root 30944 9. Mär 22:57 libgomp-plugin-hsa.so.1.0.0
    lrwxrwxrwx 1 root root 29 18. Mär 19:07 libgomp-plugin-nvptx.so.1 -> libgomp-plugin-nvptx.so.1.0.0
    -rwxr-xr-x 1 root root 30880 9. Mär 22:57 libgomp-plugin-nvptx.so.1.0.0
    lrwxrwxrwx 1 root root 25 19. Mär 09:57 libgomp.so.1 -> libgomp.so.1.0.0;5aaeaaf1
    -rwxr-xr-x 1 root root 65630 -4130033806880825322 libgomp.so.1.0.0
    ---------- 1 root root 195880 18. Mär 19:06 libgomp.so.1.0.0;5aaeaac1
    ---------- 1 root root 195880 18. Mär 19:07 libgomp.so.1.0.0;5aaeaadd
    ---------- 1 root root 195880 18. Mär 19:07 libgomp.so.1.0.0;5aaeaaf1
    pc22:/usr/lib64 #

    Bei dieser Ausgabe ist zu beachten, daß meine momentane "Problemlösung" darin enthalten ist.

    Bei der automatischen Installation von libgomp1 ist offensichtlich etwas schief gelaufen, das sich leider auch nicht durch Deinstallation und Installation beheben läßt:
    Die 3 Dateien libgomp.so.1.0.0;5aae* sind ohne Rechte und lassen sich weder löschen noch umbenennen; mit Rechten versehen geht auch nicht.

    Meine "Problemlösung" sieht so aus, daß ich einen symbolischen Link auf eine dieser Dateien gesetzt habe, da diese zwar keine Rechte und einen falschen Namen hat, aber inhaltlich korrekt ist.
    (Die Mehrfachausgabe der Schrottdatei stammt aus den Installationsversuchen).
    So habe ich jetzt zwar Digikam korrekt am Laufen, aber ein unsauberes Betriebssystem, das sich bestimmt bei Updates rächt.
    Last edited by speedy75; 24-Mar-2018 at 16:49. Reason: Ergänzung durch Antwort an weiteren Post

  8. #8

    Default Re: Digikam startet nicht

    Quote Originally Posted by speedy75 View Post
    Bei der automatischen Installation von libgomp1 ist offensichtlich etwas schief gelaufen, das sich leider auch nicht durch Deinstallation und Installation beheben läßt:
    Die 3 Dateien libgomp.so.1.0.0;5aae* sind ohne Rechte und lassen sich weder löschen noch umbenennen; mit Rechten versehen geht auch nicht.
    Diese Dateien gibt es in der Tat nur wenn beim Installieren/Updaten des Pakets was schief läuft.
    Hintergrundinfo: rpm legt zuerst mal diese Dateien an, erst wenn alles erfolgreich erledigt ist werden sie zu den richtigen Dateien umbenannt.

    Gibts irgendeine Fehlermeldung, wenn du eine Neuinstallation des Pakets forcierst?
    Code:
    sudo zypper in -f libgomp1

  9. #9

    Default Re: Digikam startet nicht

    Kleine Ergänzung vorweg:
    die unnötigen Schrottdateien konnte ich (natürlich ) löschen durch \;
    Was sich nicht löschen läßt, ist die (inhaltlich falsche) libgomp.so.1.0.0 wegen des falschen Zeitstempels.

    Quote Originally Posted by wolfi323 View Post
    Diese Dateien gibt es in der Tat nur wenn beim Installieren/Updaten des Pakets was schief läuft.
    Hintergrundinfo: rpm legt zuerst mal diese Dateien an, erst wenn alles erfolgreich erledigt ist werden sie zu den richtigen Dateien umbenannt.

    Gibts irgendeine Fehlermeldung, wenn du eine Neuinstallation des Pakets forcierst?
    Code:
    sudo zypper in -f libgomp1
    Ja, hab ich gerade probiert:

    Das folgende NEUE Paket wird installiert:
    libgomp1

    1 neues Paket zu installieren.
    Gesamtgröße des Downloads: 0 B. Bereits im Cache gespeichert: 104,7 KiB. Nach der Operation werden
    zusätzlich 251,7 KiB belegt.
    Fortfahren? [j/n/...? zeigt alle Optionen] (j): j
    Im Cache libgomp1-7.3.1+r258313-6.1.x86_64.rpm (1/1), 104,7 KiB (251,7 KiB entpackt)
    Überprüfung auf Dateikonflikte läuft: .........................................................[fertig]
    (1/1) Installieren: libgomp1-7.3.1+r258313-6.1.x86_64 .........................................[Fehler]
    Installation von libgomp1-7.3.1+r258313-6.1.x86_64 fehlgeschlagen:
    Fehler: Subprocess failed. Error: RPM fehlgeschlagen: error: unpacking of archive failed on file /usr/lib64/libgomp.so.1.0.0: cpio: rename failed - Operation not permitted
    error: libgomp1-7.3.1+r258313-6.1.x86_64: install failed

    Abbrechen, wiederholen, ignorieren? [a/w/i] (a):

  10. #10

    Default Re: Digikam startet nicht

    Quote Originally Posted by speedy75 View Post
    Kleine Ergänzung vorweg:
    die unnötigen Schrottdateien konnte ich (natürlich ) löschen durch \;
    Was sich nicht löschen läßt, ist die (inhaltlich falsche) libgomp.so.1.0.0 wegen des falschen Zeitstempels.
    Was heißt das genau ("wegen des falschen Zeitstempels")?

    Installation von libgomp1-7.3.1+r258313-6.1.x86_64 fehlgeschlagen:
    Fehler: Subprocess failed. Error: RPM fehlgeschlagen: error: unpacking of archive failed on file /usr/lib64/libgomp.so.1.0.0: cpio: rename failed - Operation not permitted
    error: libgomp1-7.3.1+r258313-6.1.x86_64: install failed
    Hm, möglicherweise ein Filesystem Fehler?
    Die gepostete Ausgabe vom ls lässt eigentlich auch schon darauf schliessen:
    Code:
    -rwxr-xr-x 1 root root 65630 -4130033806880825322 libgomp.so.1.0.0
    Was sagt denn "dmesg|tail" nach Aufruf dieses zypper Befehls?

    Evtl. hilft ein fsck?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •