Results 1 to 2 of 2

Thread: Google Earth problem in Lenovo P51

  1. #1
    Join Date
    Apr 2009
    Location
    Helsinki
    Posts
    3

    Default Google Earth problem in Lenovo P51

    Hello,

    I installed Leap 42.3 and then newest Google Earth.
    Everything else works fine, but view-window shrinks image inch by inch sized it top left corner of view window. Rest of the area is an image of my Desktop.

    There was a same problem with ATI Radeon graphics card and they managed to fixi it by ATI specific way.
    https://forums.opensuse.org/showthre...t=Google+Earth

    I first installed Google Earth by "rpm -ihv <package_name>.rpm". Package was downloaded from Google. Later I've uninstalled and re-installed it with Yast.
    According to previous thread here are some information:
    Lenovo P51, 16 GB RAM, nVidia Quadro M1200 with 512 MB, i7 CPU.

    HantteP51:~ # glxinfo |grep -E "OpenGL"
    No protocol specified
    OpenGL vendor string: nouveau
    OpenGL renderer string: Gallium 0.4 on NV117
    OpenGL core profile version string: 4.3 (Core Profile) Mesa 17.0.5
    OpenGL core profile shading language version string: 4.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 17.0.5
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:

    GlxGears works. System installation is brand new and up to date. Home directory was copied from old OpenSUSE 13.2 as it was.

    Does anyone know solution to this problem with nVidia Quadro?

    --
    Br,
    Hantte

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,862
    Blog Entries
    14

    Default Re: Google Earth problem in Lenovo P51

    Quote Originally Posted by hantte View Post
    Hello,

    I installed Leap 42.3 and then newest Google Earth.
    Everything else works fine, but view-window shrinks image inch by inch sized it top left corner of view window. Rest of the area is an image of my Desktop.

    There was a same problem with ATI Radeon graphics card and they managed to fixi it by ATI specific way.
    https://forums.opensuse.org/showthre...t=Google+Earth

    I first installed Google Earth by "rpm -ihv <package_name>.rpm". Package was downloaded from Google. Later I've uninstalled and re-installed it with Yast.
    According to previous thread here are some information:
    Lenovo P51, 16 GB RAM, nVidia Quadro M1200 with 512 MB, i7 CPU.

    HantteP51:~ # glxinfo |grep -E "OpenGL"
    No protocol specified
    OpenGL vendor string: nouveau
    OpenGL renderer string: Gallium 0.4 on NV117
    OpenGL core profile version string: 4.3 (Core Profile) Mesa 17.0.5
    OpenGL core profile shading language version string: 4.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 17.0.5
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:

    GlxGears works. System installation is brand new and up to date. Home directory was copied from old OpenSUSE 13.2 as it was.

    Does anyone know solution to this problem with nVidia Quadro?

    --
    Br,
    Hantte
    IIRC Earth doesn't play nicely with nouveau. If Earth is a requirement for your daily desktop usage, install and use the NVIDIA proprietary drivers.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •