Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Zoom Conferencing - Blank GUI

  1. #1
    Join Date
    Jan 2010
    Location
    Olympia, WA
    Posts
    66

    Default Zoom Conferencing - Blank GUI

    I use the Zoom Video Conferencing client (zoom.us) for business and recently it stopped working. It happened after I wiped my system and did a fresh openSUSE Tumbleweed (64-bit) installation. Everything on my system is working great, but now Zoom is having problems. It installs normally, but when I launch the client, I get the following window:


    It's just a blank box with no visible options. I can click in the areas where the options would have been and things seem to work, but I can't see anything. This persists with any subsequent windows that open within Zoom. Even if I click a direct link to a meeting, the client launches as it should, but I get the same blank windows.

    I've been running openSUSE Tumbleweed with Gnome for a long time and Zoom has worked great. Something changed when I did this recent wipe/reinstall. I've been working with Zoom support to see if they can solve it, but when they try to reproduce the issue on an openSUSE VM, everything works fine for them. They sent me a screenshot of it running normally on a current Gnome desktop in Tumbleweed. I've followed all of their recommendations, but nothing fixes the problem. I think the Zoom client is fine. Something is wrong with my openSUSE system. My OS is fully upgraded, running the latest packages from the standard repositories. How can I track down this issue?
    Last edited by Grassman20; 10-Mar-2018 at 12:02. Reason: Added some supporting information
    Malo periculosam, libertatem quam quietam servitutem.

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Zoom Conferencing - Blank GUI

    as it is a video conferencing app maybe it's missing some patented codecs did you add and do a full vendor change to the packman repo, what's your repo list
    Code:
    zypper lr -d
    maybe it's a video card issue, what card and driver do you have?
    Code:
    sudo lspci | grep VGA
    does that app come packaged as an rpm file is it a web app or a precompiled linux binary if it was a properly packaged rpm then zypper would have installed all the needed dependencies if it's a binary blob try running it in a terminal and see the messages that pop up.

  3. #3
    Join Date
    Jan 2010
    Location
    Olympia, WA
    Posts
    66

    Default Re: Zoom Conferencing - Blank GUI

    Here's my repo list:
    Repository priorities are without effect. All enabled repositories share the same priority.
    Code:
    # | Alias .............. | Name  ....................... | Enabled | GPG Check | Refresh |  Priority | Type ....| URI
    1 | openSUSE-20180222-0. | openSUSE-20180222-0 ......... | No .... | --------- | ------- | 99 ...... | yast2 .. | hd:///?device=/dev/disk/by-id/usb-Lexar_JumpDrive_3633097036-0:0-part2
    2 | packman ............ | packman  .................... | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/
    3 | repo-debug ......... | openSUSE-Tumbleweed-Debug ... | No  ... | --------- | ------- | 99 ...... | NONE ... | http://download.opensuse.org/debug/tumbleweed/repo/oss/
    4 | repo-non-oss ....... | openSUSE-Tumbleweed-Non-Oss . | Yes ... | (r ) Yes .| Yes ... | 99 ...... | yast2 .. | http://download.opensuse.org/tumbleweed/repo/non-oss/
    5 | repo-oss  .......... | openSUSE-Tumbleweed-Oss ..... | Yes ... | (r ) Yes .| Yes ... | 99 ...... | yast2 .. | http://download.opensuse.org/tumbleweed/repo/oss/
    6 | repo-source  ....... | openSUSE-Tumbleweed-Source .. | No .... |  -------- | ------- | 99 ...... | NONE ... | http://download.opensuse.org/source/tumbleweed/repo/oss/
    7 | repo-update ........ | openSUSE-Tumbleweed-Update .. | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | http://download.opensuse.org/update/tumbleweed/
    8 | skype-stable  ...... | skype (stable) .............. | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | https://repo.skype.com/rpm/stable/
    Here's my video card and driver:
    Code:
    00:02.0 VGA compatible controller: Intel Corporation Iris Graphics 6100 (rev 09)
    The software comes packaged as an openSUSE RPM from the Zoom website. It makes sense that perhaps some codecs were missing since my previous Tumbleweed installation was pretty mature. I hadn't done a fresh wipe in a few years. However, if the default openSUSE installation doesn't have the necessary codecs, then the Zoom support guy wouldn't have been able to get it running in his test VM. Right? The app ran fine for him.
    Malo periculosam, libertatem quam quietam servitutem.

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Zoom Conferencing - Blank GUI

    Quote Originally Posted by Grassman20 View Post
    Here's my repo list:
    Repository priorities are without effect. All enabled repositories share the same priority.
    Code:
    # | Alias .............. | Name  ....................... | Enabled | GPG Check | Refresh |  Priority | Type ....| URI
    1 | openSUSE-20180222-0. | openSUSE-20180222-0 ......... | No .... | --------- | ------- | 99 ...... | yast2 .. | hd:///?device=/dev/disk/by-id/usb-Lexar_JumpDrive_3633097036-0:0-part2
    2 | packman ............ | packman  .................... | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/
    3 | repo-debug ......... | openSUSE-Tumbleweed-Debug ... | No  ... | --------- | ------- | 99 ...... | NONE ... | http://download.opensuse.org/debug/tumbleweed/repo/oss/
    4 | repo-non-oss ....... | openSUSE-Tumbleweed-Non-Oss . | Yes ... | (r ) Yes .| Yes ... | 99 ...... | yast2 .. | http://download.opensuse.org/tumbleweed/repo/non-oss/
    5 | repo-oss  .......... | openSUSE-Tumbleweed-Oss ..... | Yes ... | (r ) Yes .| Yes ... | 99 ...... | yast2 .. | http://download.opensuse.org/tumbleweed/repo/oss/
    6 | repo-source  ....... | openSUSE-Tumbleweed-Source .. | No .... |  -------- | ------- | 99 ...... | NONE ... | http://download.opensuse.org/source/tumbleweed/repo/oss/
    7 | repo-update ........ | openSUSE-Tumbleweed-Update .. | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | http://download.opensuse.org/update/tumbleweed/
    8 | skype-stable  ...... | skype (stable) .............. | Yes ... | (r ) Yes .| Yes ... | 99 ...... | rpm-md . | https://repo.skype.com/rpm/stable/
    Here's my video card and driver:
    Code:
    00:02.0 VGA compatible controller: Intel Corporation Iris Graphics 6100 (rev 09)
    The software comes packaged as an openSUSE RPM from the Zoom website. It makes sense that perhaps some codecs were missing since my previous Tumbleweed installation was pretty mature. I hadn't done a fresh wipe in a few years. However, if the default openSUSE installation doesn't have the necessary codecs, then the Zoom support guy wouldn't have been able to get it running in his test VM. Right? The app ran fine for him.
    afaik most if not all video conferencing software use patented codecs you should do a full vendor change to packman
    Code:
    zypper dup --from 2

  5. #5
    Join Date
    Jan 2010
    Location
    Olympia, WA
    Posts
    66

    Default Re: Zoom Conferencing - Blank GUI

    Ok, that won't cause any major issues or anything? I'm always hesitant to move away from the manufacturer's recommended settings. I figure the defaults are defaults for a reason.
    Malo periculosam, libertatem quam quietam servitutem.

  6. #6
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    472

    Default Re: Zoom Conferencing - Blank GUI

    Quote Originally Posted by Grassman20 View Post
    I figure the defaults are defaults for a reason.
    In the linux world, defaults are simply a means for which anyone can start. In other words, they're a starting point only. It's why linux is renowned for its customization.
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  7. #7
    Join Date
    May 2015
    Location
    Italy
    Posts
    385

    Default Re: Zoom Conferencing - Blank GUI

    Hi Grassman20!

    Quote Originally Posted by Grassman20 View Post
    Ok, that won't cause any major issues or anything?
    No, but somehow I don't think it will solve your issue, otherwise those assisting you would have had the same issue (or would have told you about this necessary step).

    Did you try to run the video conferencing app under a fresh new account?

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Zoom Conferencing - Blank GUI

    Quote Originally Posted by Cris70 View Post
    Hi Grassman20!



    No, but somehow I don't think it will solve your issue, otherwise those assisting you would have had the same issue (or would have told you about this necessary step).

    Did you try to run the video conferencing app under a fresh new account?

    Cris
    assumption is the cause of most fails
    if their app uses h264 for video encoding (as a lot if not most do) it would need the packman multimedia packages
    as a doing a full vendor change to packman is a must for all opensuse users who want an unrestricted system the zoom devs might have also assumed the OP did a full vendor change as he does have the packman repo
    if that doesn't work I'd suggest checking the hardware in yast, that app might need v4l packages but the OP didn't say how he installed the rpm if he used zypper and the devs did a propper jop packaging their app all dependencies should be met (zypper might install restricted multimedia packages if they weren't already installed as both packman and OSS have the same priority)
    after doing the full vendor change to packman the issue persists the OP should start that app in a terminal and tell up the output

  9. #9

    Default Re: Zoom Conferencing - Blank GUI

    Quote Originally Posted by Grassman20 View Post
    I'm always hesitant to move away from the manufacturer's recommended settings. I figure the defaults are defaults for a reason.
    Sure there is:
    openSUSE cannot include proprietary/restricted codecs for legal reasons.
    See also https://en.opensuse.org/Restricted_formats

    Packman can (and does) offer them though.
    If you want (or need) to use them, you need to switch (preferably all) packages to Packman's versions.
    Last edited by wolfi323; 13-Mar-2018 at 03:48.

  10. #10
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Zoom Conferencing - Blank GUI

    I just installed zoom conferencing on leap 42.3 and it's working fine for me

    on their download page they say their opensuse build is for 13.2+
    I'm speculating that TW is just too new for that build you should recontact the zoom developers and ask for a newer build
    TW uses a much newer version of gcc depending how they linked their app it might need a recompile (a static build should work on TW also)

    edit
    they said they used TW in an virtual machine but what version of TW did they use and what version of TW do you have
    Code:
    cat /etc/os-release
    make sure you both have the same TW build before comparing
    Last edited by I_A; 14-Mar-2018 at 04:02.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •