Results 1 to 7 of 7

Thread: Scanner scannt nicht (mehr)

  1. #1

    Default Scanner scannt nicht (mehr)

    Hallo,

    hat jemand eine Idee, wo ich schauen muss, warum es der Scanner meines Multifunktionsgeräts (MFC-7420) nicht (mehr) tut?
    Bisher, d. h. bis LEAP 42.2, hat das immer wunderbar geklappt, aber dieses Mal, d. h. mit LEAP 42.3, scheint der Wurm beim Scannen drin zu sein; Drucken klappt.

    • Fehlermeldung von Scanlite: "Das Öffnen des Scanners ist fehlgeschlagen".
    • Xsane meldet: "Fehler beim Öffnen des Geräts "brother2:bus4;dev2" Ungültiges Argument."
    • Scanner (YaST) meldet für Treiber "dev2,Brother,MFC-7420": "Test mit 'scanimage -d dev2 -v' ist fehlgeschlagen. ... scanimage: open of device dev2 failed: Invalid argument"
    • Scanner (YaST) meldet für Treiber "brother2": "Test mit 'scanimage -d -v' ist fehlgeschlagen. Ergebnis: ... Usage: test_scanner_backend SANE_device"



    Gruß


    PS: http://support.brother.com/g/b/downl...od=mfc7420_all

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,738

    Default AW: Scanner scannt nicht (mehr)

    Und wie ist der Treiber installiert?

  3. #3
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    188

    Default Re: Scanner scannt nicht (mehr)

    Das hier beachtet, ist zwar für opensuse 11.2, gilt aber immer noch:

    http://support.brother.com/g/s/id/li...ct=on#suse11_2

    Code:
    1. Open "/etc/udev/rules.d/55-libsane.rules"2. Add the following 2 lines at the last of the device entry. (just before "# The following rule...")   
    # Brother
    ATTR{idVendor}=="04f9", MODE="0664", GROUP="lp", ENV{libsane_matched}="yes"
    3. Restart the OS.

  4. #4

    Default AW: Scanner scannt nicht (mehr)

    @Sauerland
    Installiert habe ich das so wie von Brother empfohlen:
    File runterladen, extrahieren und dann:
    Code:
    # bash linux-brprinter-installer-2.1.1-1 "MFC-7420"
    Wobei folgende Files verwendet werden:
    • brmfc7420lpr-2.0.1-1.i386.rpm
    • brscan2-0.2.5-1.x86_64.rpm
    • brscan-skey-0.2.4-1.x86_64.rpm
    • cupswrapperMFC7420-2.0.1-1.i386.rpm


    @swannema
    Ich habe das mal in den File eingefügt. Das hat aber nichts gebracht.
    Ich habe es nun wieder deaktiviert.

    Beim Editieren kamen ein paar Fehlermeldungen, vielleicht können die ein Einhaltspunkt sein:
    Code:
    # gedit /etc/udev/rules.d/55-libsane.rules
    
    (gedit:2925): dconf-WARNING **: failed to commit changes to dconf: Verbindung ist geschlossen
    
    (gedit:2925): dconf-WARNING **: failed to commit changes to dconf: Verbindung ist geschlossen
    Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
    Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
    Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
    Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
    Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)
    --------------------------------------------------------------------------------------------------------------------------------------------
    (gedit:2925): dconf-WARNING **: failed to commit changes to dconf: Verbindung ist geschlossen
    
    (gedit:2925): dconf-WARNING **: failed to commit changes to dconf: Verbindung ist geschlossen
    
    (gedit:2925): dconf-WARNING **: failed to commit changes to dconf: Verbindung ist geschlossen
    Wie gesagt, bisher hat das mit jeder openSUSE-Version auf Anhieb geklappt mit dem Scanner.

    Noch 2 Hardcopies:
    https://abload.de/img/screenshot_20180310_19bk6c.png
    https://abload.de/img/screenshot_20180310_1hrjfe.png

  5. #5
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    188

    Default Re: Scanner scannt nicht (mehr)

    Nutzt Du Gnome?

  6. #6

    Default AW: Scanner scannt nicht (mehr)

    KDE-Desktop

  7. #7

    Default AW: Scanner scannt nicht (mehr)

    Oh Mann, ich habe den "Fehler" gefunden.

    Ich habe seit einiger Zeit ein neues Notebook, ein "HP 255 G5 Notebook PC", und da scheinen die USB-Ports nicht alle gleich zu sein. Da bin ich jetzt schon wieder drauf reingefallen.

    Mit dem USB-Port links, an der Drucker bis eben hing, kann ich drucken, aber nicht scannen, dafür muss ich den rechten USB-Port nehmen.

    Ein Canon-Farbdrucker druckt auch nur über den rechten USB-Port.

    Es gibt zwei USB-Ports links und einen rechts.

    Danke euch trotzdem für die Hilfe.


    PS: Oder ist das eine Einstellungssache mit den USB-Ports?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •