Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Static IP assigned to network card, but DHCP process initiated

  1. #1

    Default Static IP assigned to network card, but DHCP process initiated

    I've set-up a static IP address for my system. But upon boot my system gets assigned a DHCP IP address from the router. I get assigned 2 IP addresses:

    Code:
    $ ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host  
           valid_lft forever preferred_lft forever
    2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 1c:87:2c:74:63:7d brd ff:ff:ff:ff:ff:ff
        inet 201.7.5.121/24 brd 201.7.5.255 scope global dynamic noprefixroute enp4s0
           valid_lft 6922sec preferred_lft 6922sec
        inet 201.7.5.100/24 brd 201.7.5.255 scope global secondary enp4s0
           valid_lft forever preferred_lft forever
        inet6 fe80::d48d:a025:f189:555f/64 scope link noprefixroute  
           valid_lft forever preferred_lft forever
    
    In my router the MAC address is bound to the corresponding IP address. This config / set-up worked correctly with 42.3. With my server (42.3) I have no issue with the static IP address as that works correct and that configuration is the same (except for the IP) as I use on my desktop.

    I'm expecting only a single IP address and not 2. Where can I see what config is triggering the request for the DHCP (.121) provided IP address?
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

  2. #2
    Join Date
    Sep 2012
    Posts
    7,090

    Default Re: Static IP assigned to network card, but DHCP process initiated

    Are you using wicked or NetworkManager?

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Static IP assigned to network card, but DHCP process initiated

    Also,
    That's really odd that "noprefixroute" is an attribute of your IPv4 DHCP address.
    AFAIK that should only be associated with and make sense for IPv6 addressing.

    Was this immediately after a manual configuration?
    Besides the Wicked vs NM question, are you configuring your static address in YaST or NM, editing your interface files directly or implementing some other configuration alternative like /etc/sysctl?
    And, did you restart your network service or reboot immediately after making your changes and only then run "ip addr"?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4

    Default Re: Static IP assigned to network card, but DHCP process initiated

    I make use of Yast2 to configure the network settings. I'm making use of Wicked.

    I rebooted the system multiple times and the result is the same.
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

  5. #5
    Join Date
    Sep 2012
    Posts
    7,090

    Default Re: Static IP assigned to network card, but DHCP process initiated

    Do you have systemd-networkd.service active by any chance? "systemctl status systemd-networkd"?

  6. #6

    Default Re: Static IP assigned to network card, but DHCP process initiated

    That appears to be dead:
    Code:
    systemd-networkd.service - Network Service
       Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: disabled)
       Active: inactive (dead)
         Docs: man:systemd-networkd.service(8)
    
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

  7. #7
    Join Date
    Sep 2012
    Posts
    7,090

    Default Re: Static IP assigned to network card, but DHCP process initiated

    Quote Originally Posted by t_neo View Post
    Code:
    systemd-networkd.service - Network Service
       Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: disabled)
    
    "enabled" is confusing here but I checked - it is the same on my TW and it is not started. Could you show your /etc/sysconfig/network/ifcfg-enp4s0?

  8. #8

    Default Re: Static IP assigned to network card, but DHCP process initiated

    That file seems to be correct:
    Code:
    BOOTPROTO='static'
    STARTMODE='auto'
    BROADCAST=''
    ETHTOOL_OPTIONS=''
    IPADDR='201.7.5.100/24'
    MTU=''
    NAME=''
    NETWORK=''
    REMOTE_IPADDR=''
    ZONE=public
    
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Static IP assigned to network card, but DHCP process initiated

    A speculative try,

    Recycle your networking using the classic "ifup/ifdown" commands, ie.
    Code:
    ifdown enp4s0
    Then
    Code:
    ifup enp4s0
    Followed by the following to see if there is any diff
    Code:
    ip addr
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  10. #10

    Default Re: Static IP assigned to network card, but DHCP process initiated

    Executed the commands, and the output is the same.

    Code:
    # ifdown enp4s0
    enp4s0          device-ready
    # ifup enp4s0   
    enp4s0          up
    $ ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host  
           valid_lft forever preferred_lft forever
    2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 1c:87:2c:74:63:7d brd ff:ff:ff:ff:ff:ff
        inet 201.7.5.121/24 brd 201.7.5.255 scope global dynamic noprefixroute enp4s0
           valid_lft 7187sec preferred_lft 7187sec
        inet 201.7.5.100/24 brd 201.7.5.255 scope global secondary enp4s0
           valid_lft forever preferred_lft forever
        inet6 fe80::d48d:a025:f189:555f/64 scope link noprefixroute  
           valid_lft forever preferred_lft forever
    
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •