Results 1 to 3 of 3

Thread: opensuse 42.3 error radeon kernel, instead kubutu works as fine.. why?

  1. #1

    Default opensuse 42.3 error radeon kernel, instead kubutu works as fine.. why?

    hi
    i love Opensuse!
    i isntalled opensuse 42.3 with kde plasma 5 64bit, computer is old hardware.
    in installation: i set "no KMS mode". because hardware video is old: H3200 (AMD/ATI) but is bult in not card video, (on board)
    installation is perfect nothing problem.
    reboot there is:
    grub2 (works)
    booting (works)
    systemd (works)
    kde plasma (works)
    opensuse is perfect working.

    one problem is bad resolution: small solution (640x480 pixel)..
    i go to see dmesg i find error:

    [drm] VGACON disable radeon kernel modesetting.
    [drm:radeon_init] *ERROR* No UMS support in radeon module!

    i try see xorg.conf (/etc/X11/) there is not file but there is xorg.config.install..

    so i try kubuntu CD-live 17.10
    result:
    booting (works)
    systemd (works)
    kde plasma 5 (works)
    kubuntu (works)
    but resolution is correct..
    so i check /etc/X11/ there is not file xorg.config ..
    then i want to ask you :
    i want opensuse 43.2 on old computer, but kubuntu how..?
    how resolve this problem..?

  2. #2

    Default Re: opensuse 42.3 error radeon kernel, instead kubutu works as fine.. why?

    Quote Originally Posted by manuel_songokuh View Post
    in installation: i set "no KMS mode". because hardware video is old: H3200 (AMD/ATI) but is bult in not card video, (on board)
    There's no need to use "no KMS mode" just because the hardware is old.
    My Radeon card is much older (9600) and KMS works fine.

    one problem is bad resolution: small solution (640x480 pixel)..
    That's because you disabled KMS (Kernel Mode Setting).
    The radeon driver requires KMS though, so you are using some generic fallback now (fbdev).
    That's what the error message you posted tells you.

    Go into YaST->System->Boot Loader and remove the "nomodeset" in "Optional Kernel Parameter".

    If in doubt, please post the whole line you have, either by taking it from YaST or running "cat /proc/cmdline".

    i try see xorg.conf (/etc/X11/) there is not file but there is xorg.config.install..
    xorg.conf is not used since years.
    Although it is still respected if it exists, but you should normally have no need to create it.
    Last edited by wolfi323; 09-Mar-2018 at 04:48.

  3. #3

    Thumbs up Re: opensuse 42.3 error radeon kernel, instead kubutu works as fine.. why?

    Quote Originally Posted by wolfi323 View Post
    There's no need to use "no KMS mode" just because the hardware is old.
    My Radeon card is much older (9600) and KMS works fine.


    That's because you disabled KMS (Kernel Mode Setting).
    The radeon driver requires KMS though, so you are using some generic fallback now (fbdev).
    That's what the error message you posted tells you.

    Go into YaST->System->Boot Loader and remove the "nomodeset" in "Optional Kernel Parameter".

    If in doubt, please post the whole line you have, either by taking it from YaST or running "cat /proc/cmdline".


    xorg.conf is not used since years.
    Although it is still respected if it exists, but you should normally have no need to create it.

    OHH MY GOD WORKS!!! THANK YOU SO MUCH!!!
    i learn this solution THANK YOU!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •