Results 1 to 2 of 2

Thread: Hilfe mit pgpPgAdmin & Apache Zugriffsrechten

  1. #1
    Join Date
    Jun 2014
    Location
    Bonn, Germany
    Posts
    67

    Unhappy Hilfe mit pgpPgAdmin & Apache Zugriffsrechten

    Hallo zusammen.

    Ich wollte mir selbst mal ein wenig PostgreSQL beibringen. Zu diesem Zweck habe ich eine VM mit Leap 15 aufgesetzt und dann brav die Schritte von hier (bzw. hier) befolgt. Wenn ich am Ende allerdings im Firefox auf localhost:80/phpPgAdmin oder 192.168.1.101/phpPgAdmin/ gehe, bekomme ich ein "Access forbidden!" von Apache. Ich habe keine Ahnung von Apache, ich bin mir auch nicht sicher, dass das ein Apache-Problem ist, aber ich verstehe auch nicht, was da schiefgeht. Falls mich jemand erhellen kann, bin ich sehr dankbar!

    VG,
    pbiel

    P.S.: Ich hab noch mit systemctl stop firewalld die Firewall ausgeschaltet, das war's nicht ...

  2. #2

    Default AW: Hilfe mit pgpPgAdmin & Apache Zugriffsrechten

    Wie hast Du den phpPgAdmin installiert? Solltest Du über das rpm (via Yast2) installiert haben, dann sieh mal in /etc/apache2/conf.d/phpPgAdmin.conf . Hier findet eine Versionsprüfung des httpd statt:
    Bei mir:

    Code:
    <Directory /srv/www/htdocs/phpPgAdmin/libraries>
      <IfVersion >= 2.4>
        Require all denied
      </IfVersion>
      <IfVersion < 2.4>
        Order allow,deny
        Deny from all
      </IfVersion>
    </Directory>
    
    Bedeutet, dass phpPgAdmin nur für Apache2 ab Version 2.4 funktioniert.

    Was sagt denn:
    Code:
    httpd -v

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •