Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Nvidia Drivers not configured properly

  1. #21
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,798

    Default AW: Nvidia Drivers not configured properly

    If you can disable the Intel Graphics in Bios, you can do that and use only the Nvidia Card.
    If you can not disable the Intel, you have an Optimus System and use bumblebee or not.

  2. #22

    Unhappy Re: Nvidia Drivers not configured properly

    I am a new user. I too see the behavior described earlier. (running nvidia-xconfig and reboot results in console flashing at a high rate; it seems to drop characters typed on the keyboard, making it impossible to enter the password)
    I am running the latest NVIDIA drivers (04) and latest Tumbleweed build. (Brand new installation; never used OpenSUSE before.)

    My laptop, like many other modern laptops, has TWO potential GPU systems, the Intel embedded graphics, and the Nvidia GPU.

    Under WindowsOS, the system prefers the Intel GPU to minimize power usage. There is an adjustment in the Nvidia Control Panel (3D, Global Settings, Preferred Graphics Processor) that allows one to turn-off the auto-switching mode, and request that Nvidia be used all the time.

    If there is a similar control in the OpenSUSE system, I cannot locate it. I cannot access nvidia-settings, as it requires me to execute nvidia-config first (and this makes the system unusable).

    The OpenSUSE literature stresses that Tumbleweed is intended to be installed and used widely (not just by Linux kernel hackers and device-driver gurus). Getting all the basic laptop HW to activate shouldn't be this difficult, right? (I didn't even see nvidia-settings or other Nvidia control panel included in any of the system administration UI; I had to scrounge around using Google to find the name of the Nvidia control panel. Not newbie friendly...)

    Notably, if "nvidia-xconfig" is required, then perhaps it should be executed in the installation scripts. (This would have raised visibility of the issue, as more folks would encounter the unusable flashing screen condition. As it is, only folks who note that they're STILL running on the Intel GPU, and attempt to activate the Nvidia GPU, are kicked in the ass by the bug.)

    I noted the request above for output of hwinfo command. I collected it and will include it below. (I think I have to paste it in, as I am not allowed to add attachments in the forum?)
    I hope this issue can be identified and repaired. (Hope I am not doing something wrong and wasting your time with this report. If so, I apologize!)
    Bob

    linux-h4lx:/home/enger # hwinfo --gfxcard
    17: PCI 100.0: 0302 3D controller
    [Created at pci.378]
    Unique ID: VCu0.C4vYvkQe035
    Parent ID: vSkL.ssGVCrpcUlF
    SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
    SysFS BusID: 0000:01:00.0
    Hardware Class: graphics card
    Device Name: "NVIDIA N16E-GR"
    Model: "nVidia GM206M [GeForce GTX 965M]"
    Vendor: pci 0x10de "nVidia Corporation"
    Device: pci 0x1427 "GM206M [GeForce GTX 965M]"
    SubVendor: pci 0x103c "Hewlett-Packard Company"
    SubDevice: pci 0x825b
    Revision: 0xa1
    Driver: "nvidia"
    Driver Modules: "nvidia"
    Memory Range: 0xa3000000-0xa3ffffff (rw,non-prefetchable)
    Memory Range: 0x90000000-0x9fffffff (ro,non-prefetchable)
    Memory Range: 0xa0000000-0xa1ffffff (ro,non-prefetchable)
    I/O Ports: 0x5000-0x5fff (rw)
    Memory Range: 0xa4000000-0xa407ffff (ro,non-prefetchable,disabled)
    IRQ: 16 (1 event)
    Module Alias: "pci:v000010DEd00001427sv0000103Csd0000825Bbc03sc02i00"
    Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
    Driver Info #1:
    Driver Status: nvidia_drm is active
    Driver Activation Cmd: "modprobe nvidia_drm"
    Driver Info #2:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
    Config Status: cfg=new, avail=yes, need=no, active=unknown
    Attached to: #12 (PCI bridge)


    26: PCI 02.0: 0300 VGA compatible controller (VGA)
    [Created at pci.378]
    Unique ID: _Znp.eW0JZl5DxA3
    SysFS ID: /devices/pci0000:00/0000:00:02.0
    SysFS BusID: 0000:00:02.0
    Hardware Class: graphics card
    Device Name: "Intel Skylake HD Graphics ULT GT2"
    Model: "Intel HD Graphics 530"
    Vendor: pci 0x8086 "Intel Corporation"
    Device: pci 0x191b "HD Graphics 530"
    SubVendor: pci 0x103c "Hewlett-Packard Company"
    SubDevice: pci 0x825b
    Revision: 0x06
    Driver: "i915"
    Driver Modules: "i915"
    Memory Range: 0xa2000000-0xa2ffffff (rw,non-prefetchable)
    Memory Range: 0xb0000000-0xbfffffff (ro,non-prefetchable)
    I/O Ports: 0x6000-0x603f (rw)
    Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
    IRQ: 141 (17494 events)
    Module Alias: "pci:v00008086d0000191Bsv0000103Csd0000825Bbc03sc00i00"
    Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
    Config Status: cfg=new, avail=yes, need=no, active=unknown


    Primary display adapter: #26
    linux-h4lx:/home/enger #

  3. #23
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,798

    Default AW: Nvidia Drivers not configured properly

    My laptop, like many other modern laptops, has TWO potential GPU systems, the Intel embedded graphics, and the Nvidia GPU.
    You have a system on which the normal nvidia driver from the repo is not working.
    It is working only, if you can disable the Intel graphics in bios.

  4. #24

    Default Re: Nvidia Drivers not configured properly

    Thank you for the info.
    No control appears in the BIOS for disabling the Intel embedded graphics. Unless I relegate the laptop to being an expensive server, I'm stuck with gatesware. (And given the increasing importance of GPU co-processing, it seems a real shame to squander a GPU, even on a server.)

    Bob

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •