Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Packages not available anymore in Packman?

  1. #1

    Default Packages not available anymore in Packman?

    Hi,

    after running a zyper dup I get the following notification:

    Code:
    Problem: problem with installed package libmjpegutils-2_0-0-2.0.0-25.1.x86_64
    Problem: problem with installed package mjpegtools-2.0.0-25.1.x86_64
    
    Problem: problem with installed package libmjpegutils-2_0-0-2.0.0-25.1.x86_64
     Solution 1: install libmjpegutils-2_0-0-2.0.0-24.1.x86_64 (with vendor change)
      http://packman.links2linux.de  -->  openSUSE
     Solution 2: keep obsolete libmjpegutils-2_0-0-2.0.0-25.1.x86_64
    It wants me to switch to OS repo.
    Should I switch? How come these packages are no longe available in Packman?

    Here are my repos:

    Code:
     | packman.inode.at-openSUSE_Tumbleweed_1 | Packman Repository          | Yes     | (r ) Yes  | Yes     |   80    
    1 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository        | Yes     | (r ) Yes  | Yes     |   85    
    3 | repo-non-oss                           | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99    
    4 | repo-oss                               | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99    
    5 | repo-update                            | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99    
    6 | skype-stable                           | skype (stable)              | Yes     | (r ) Yes  | Yes     |   99    
    7 | skypeforlinux                          | skypeforlinux               | Yes     | (r ) Yes  | Yes     |   99

    Thanks.
    David

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    17,882
    Blog Entries
    1

    Default Re: Packages not available anymore in Packman?

    I don't have a definitive answer (and I'm not a TW user), but what is returned by the following command?
    Code:
    zypper se -s mjpegtools libmjpegutils

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,310

    Default Re: Packages not available anymore in Packman?

    I just rebooted out of Leap to TW, currently running zypper dup at the time of this message. I see no sign of a package switch away from packman. When finished, I will look again at these items.

    In the meantime, you might try to reapply the Packman switch, see if that helps.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    24,091
    Blog Entries
    15

    Default Re: Packages not available anymore in Packman?

    On Wed 28 Feb 2018 01:06:01 AM CST, SF6 wrote:

    Hi,

    after running a zyper dup I get the following notification:


    Code:
    --------------------
    Problem: problem with installed package
    libmjpegutils-2_0-0-2.0.0-25.1.x86_64 Problem: problem with installed
    package mjpegtools-2.0.0-25.1.x86_64
    Problem: problem with installed package
    libmjpegutils-2_0-0-2.0.0-25.1.x86_64 Solution 1: install
    libmjpegutils-2_0-0-2.0.0-24.1.x86_64 (with vendor change)
    http://packman.links2linux.de --> openSUSE Solution 2: keep obsolete
    libmjpegutils-2_0-0-2.0.0-25.1.x86_64 --------------------


    It wants me to switch to OS repo.
    Should I switch? How come these packages are no longe available in
    Packman?

    Here are my repos:


    Code:
    --------------------
    | packman.inode.at-openSUSE_Tumbleweed_1 | Packman
    Repository | Yes | (r ) Yes | Yes | 80 1 |
    opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository |
    Yes | (r ) Yes | Yes | 85 3 |
    repo-non-oss | openSUSE-Tumbleweed-Non-Oss |
    Yes | (r ) Yes | Yes | 99 4 |
    repo-oss | openSUSE-Tumbleweed-Oss |
    Yes | (r ) Yes | Yes | 99 5 |
    repo-update | openSUSE-Tumbleweed-Update |
    Yes | (r ) Yes | Yes | 99 6 |
    skype-stable | skype (stable) |
    Yes | (r ) Yes | Yes | 99 7 |
    skypeforlinux | skypeforlinux |
    Yes | (r ) Yes | Yes | 99 --------------------



    Thanks.
    David


    Hi
    Set your repo priorities all the same (99), the libdvdcss2 changes once
    in a bluemoon... install and disable?

    Once packman is at 99 do a zypper dup from packman to ensure a clean
    switch.


    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.3|GNOME 3.20.2|4.4.114-42-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  5. #5
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,310

    Default Re: Packages not available anymore in Packman?

    The answer is:

    It has to do with the expired patents.

    Tue 20 Feb 2018 04:00:00 AM PST

    bjorn.lie@gmail.com

    - No longer use patched tarball for build, mpeg2 is now available
    in openSUSE:
    + Drop pre_checkin.sh, mjpegtools-codecpatch.sh and
    mjpegtools-codecpatch.patch, no longer needed.
    + Drop BUILD_ORIG and obsolete versions conditionals.
    + Drop previously conditional mjpegtools-orig-addon and
    libmpeg2encpp-2_0-0 subpackages.
    + Update baselibs.conf for the new build structure.
    + Add mjpegtools-orig-addon and libmpeg2encpp-2_0-0 Obsoletes:
    Ensure a smooth upgrade for our users.
    I did not see the switch from Packman to openSUSE because I installed Tumbleweed after 02/20/2018.

    I am guessing this is your first zypper dup since then?
    Last edited by Fraser_Bell; 27-Feb-2018 at 19:57.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    17,882
    Blog Entries
    1

    Default Re: Packages not available anymore in Packman?

    Quote Originally Posted by Fraser_Bell View Post
    The answer is:

    It has to do with the expired patents.
    I suspected that might be the case. FWIW the Leap packman package version numbering is still ahead of the OSS repo...
    Code:
    i+ | libmjpegutils-2_0-0                 | package    | 2.0.0-19.7 | x86_64 | packman               
    v  | libmjpegutils-2_0-0                 | package    | 2.0.0-18.3 | x86_64 | openSUSE-Leap-42.3-oss
    Code:
    i+ | mjpegtools                          | package    | 2.0.0-19.7 | x86_64 | packman               
    v  | mjpegtools                          | package    | 2.0.0-18.3 | x86_64 | openSUSE-Leap-42.3-oss

  7. #7

    Default Re: Packages not available anymore in Packman?

    Quote Originally Posted by deano_ferrari View Post
    I suspected that might be the case. FWIW the Leap packman package version numbering is still ahead of the OSS repo...
    42.3 doesn't have MPEG2 support (i.e. libmpeg2) yet anyway...

    And the last change in mjpegtools in the 42.3 package:
    Code:
    Thu Jan  8 15:15:11 UTC 2015 - olaf@aepfle.de
    - BuildRequire at least libpng 1.14 due to usage of
       PNG_TRANSFORM_GRAY_TO_RGB 
    IOW, on Leap 42.3, you should stick to the Packman versions (if you want/need MPEG2 support at least) currently.

    No idea what the plans for 42.3 are regarding libmpeg2, libmad and lame have been released as official update half a year ago.

    Tumbleweed OTOH has libmpeg2 in the official repos now (which also allows to have an "uncrippled" mjpegtools), so it's (both libmpeg2 and mjpegtools) no longer provided by Packman.
    That also means that the standard ffmpeg/libav*, vlc, and gstreamer packages (and possibly others) have MPEG2 support enabled now.
    Last edited by wolfi323; 28-Feb-2018 at 00:12.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    17,882
    Blog Entries
    1

    Default Re: Packages not available anymore in Packman?

    Quote Originally Posted by wolfi323 View Post
    No idea what the plans for 42.3 are regarding libmpeg2, libmad and lame have been released as official update half a year ago.
    Yes, I recall that.

  9. #9
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    371

    Default Re: Packages not available anymore in Packman?

    Quote Originally Posted by wolfi323 View Post
    Tumbleweed OTOH has libmpeg2 in the official repos now (which also allows to have an "uncrippled" mjpegtools), so it's (both libmpeg2 and mjpegtools) no longer provided by Packman.
    That also means that the standard ffmpeg/libav*, vlc, and gstreamer packages (and possibly others) have MPEG2 support enabled now.
    If I get it right, for multimedia packages (vlc, gstreamer-plugins, lame, ffmpeg etc.) we no longer need packman.
    For me there are good news. I think it is better (safe) to stay only with opensuse repositories.

  10. #10

    Default Re: Packages not available anymore in Packman?

    Quote Originally Posted by another_roadrunner View Post
    If I get it right, for multimedia packages (vlc, gstreamer-plugins, lame, ffmpeg etc.) we no longer need packman.
    That depends.

    Yes, lame is in the standard repos now (since nearly a year), and also other MP3 related packages like libmad and mpg123, i.e. MP3 is meanwhile supported out of the box, and the same is true for A/52 (liba52). And MPEG2 (via libmpeg2) since recently too.

    But there are still non-free codecs that cannot be included in openSUSE, e.g. MPEG4/H264/AAC, and will be for a long time.
    Not all multimedia-related patents have expired yet...
    Last edited by wolfi323; 28-Feb-2018 at 01:40.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •