Results 1 to 5 of 5

Thread: No audio on t100taf

  1. #1

    Default No audio on t100taf

    Audio is not working on my T100TAF, but "works" out of the box on fedora.
    T100TAF audio support is partial and rather hacky even when correctly setted up. It requires an alsa UCM file to have more then just headphones working, and despite any effort speaker audio is mono.

    I've recently installed tumbleweed, but despite all my efforts I can't get audio working on it, the card is listed by `aplay -l` but it doesn't work and pulseaudio fails to load it. Whenever the card is probed by pulseaudio a list of `Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port` is printed in dmesg.
    All required kernel patches looks in place (they're all merged upstream afaik), I even compiled 4.16-rc2 but had no luck.
    I can't figure out why tumbleweed fails despite fedora is partly working out of the box (it requires the ucm file to work "optimally"), it might be some kernel configuration issue but I can't figure it out.
    Code:
    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: bytcrrt5640 [bytcr-rt5640], device 0: Baytrail Audio (*) []
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: bytcrrt5640 [bytcr-rt5640], device 1: Deep-Buffer Audio (*) []
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Code:
    [    9.409472] bytcr_rt5640 bytcr_rt5640: BIOS Routing: AIF2 connected
    [    9.409479] bytcr_rt5640 bytcr_rt5640: quirk IN1_MAP enabled
    [    9.409482] bytcr_rt5640 bytcr_rt5640: quirk MONO_SPEAKER enabled
    [    9.409485] bytcr_rt5640 bytcr_rt5640: quirk DIFF_MIC enabled
    [    9.409488] bytcr_rt5640 bytcr_rt5640: quirk SSP0_AIF2 enabled
    [    9.409490] bytcr_rt5640 bytcr_rt5640: quirk MCLK_EN enabled
    [    9.416113] bytcr_rt5640 bytcr_rt5640: snd-soc-dummy-dai <-> media-cpu-dai mapping ok
    [    9.416192] bytcr_rt5640 bytcr_rt5640: snd-soc-dummy-dai <-> deepbuffer-cpu-dai mapping ok
    [    9.416872] bytcr_rt5640 bytcr_rt5640: rt5640-aif2 <-> ssp0-port mapping ok
    ...
    [   38.342318]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
    [   38.342747]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
    [   38.343065]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
    [   38.344187]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
    [   38.344607]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
    [   38.344932]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
    [   38.346729]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
    ...
    Everything else works like as expected (touchpad/backlight/standby and all other recently added kernel patches)

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No audio on t100taf

    Quote Originally Posted by raffarti View Post
    Audio is not working on my T100TAF, but "works" out of the box on fedora.
    T100TAF audio support is partial and rather hacky even when correctly setted up. It requires an alsa UCM file to have more then just headphones working, and despite any effort speaker audio is mono.

    I've recently installed tumbleweed, but despite all my efforts I can't get audio working on it, the card is listed by `aplay -l` but it doesn't work and pulseaudio fails to load it. Whenever the card is probed by pulseaudio a list of `Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port` is printed in dmesg.
    This is highly technical, and my recommendation would be not to waste time, but rather to immediately file a bug report on openSUSE tumbleweed kernel (that the audio does not work). This will likely get the attention of an openSUSE sound packager, who is also an alsa sound driver developer. If anyone can sort this problem, he can. Further anything he does for openSUSE is typically then passed upstream so that all GNU/Linux versions benefit.

    There is guidance for raising bug reports here: https://en.opensuse.org/openSUSE:Submitting_bug_reports You can use your openSUSE forum user name and password when loggin on to Bugzilla. Attach to the bug report the file you get by running as a regular user in a konsole/xterm;
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    Also add to the bug report any other information you believe salient ... (such as you did in this thread). Don't bother referencing this forum thread, as the openSUSE packager will not read a forum thread. Every couple or days ago check the status of the bug report. You may be asked a question (to provide more info) in which provide that as best you can, and then as appropriate remove on the bug report entry any "NEED INFO" flag (if there still is such a flag)

    You can try waiting longer for a response on this thread, but my assessment is given the nature of your problem, your quickest approach is what I note above.

    Good luck.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No audio on t100taf

    One dumb question (further to the above) - have you installed "kernel-firmware" in case it provides what is missing ? https://software.opensuse.org/package/kernel-firmware and alsa-firmware ? I scrolled through kernel-firmware and also through an old version of alsa-firmware, and I myself did not see anything relevant, but I could have missed such.

    I still think a bug report is your best approach.

  4. #4

    Default Re: No audio on t100taf

    Quote Originally Posted by oldcpu View Post
    One dumb question (further to the above) - have you installed "kernel-firmware" in case it provides what is missing ? https://software.opensuse.org/package/kernel-firmware and alsa-firmware ? I scrolled through kernel-firmware and also through an old version of alsa-firmware, and I myself did not see anything relevant, but I could have missed such.

    I still think a bug report is your best approach.
    I've forgot to mention I've also checked for the firmware to be present, whilst I'm not sure whether it's the correct version. I've accidentally cut a line in the dmesg.

    Code:
    [   38.341821] intel_sst_acpi 80860F28:00: FW Version 01.0c.00.01
    [   38.342318]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
    Quote Originally Posted by oldcpu View Post
    This is highly technical, and my recommendation would be not to waste time, but rather to immediately file a bug report on openSUSE tumbleweed kernel (that the audio does not work). This will likely get the attention of an openSUSE sound packager, who is also an alsa sound driver developer. If anyone can sort this problem, he can. Further anything he does for openSUSE is typically then passed upstream so that all GNU/Linux versions benefit.
    I tried here first as I'm not entirely sure where the issue lays. If I recall correctly, a vanilla git kernel was enough on fedora to have audio working.
    This line in particular is a T100TAF specific quirk
    Code:
    [    9.409482] bytcr_rt5640 bytcr_rt5640: quirk MONO_SPEAKER enabled
    Yet reporting it there might turn out to be the only way . It could still be a kernel configuration issue though.

  5. #5

    Default Re: No audio on t100taf

    Mystery solved, it was the UCM. I had a working UCM but when I tested it snd_hdmi_lpe_audio wasn't blacklisted yet, breaking pulseaudio. After blacklisting it I was using a broken UCM that was somehow working on my previous installation (most likely because part of the state of a previous UCM was stored in alsa) but not on tumbleweed nor on fedora live. The broken UCM works if loaded after the working one, additionally headset mic will work that way. It would be nice to have the working UCM fixed so that headset mic would work. Maybe I'll open an issue on https://github.com/plbossart/UCM.git later.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •