Results 1 to 7 of 7

Thread: Kernel panic - not syncing: VFS

  1. #1

    Default Kernel panic - not syncing: VFS

    Tumbleweed update went wrong and now my boot is broken. When I boot the default kernel through Grub I end up with:

    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,1)


    I can get into the system by going into advanced options and select the second kernel entry there. When I select the first entry it throws the same error. To the eye the kernel entries are identical.


    When I booted the system I created a snapshot and rebooted. Selecting the snapshot (or any other in read-only) is unable to boot the system and I end in maintenance mode.

    I searched online and found the suse help page (https://www.suse.com/support/kb/doc/?id=3864925) that suggested to run mkinitrd but that did not have a resolving effect.

    By going through the 2nd option in my advanced options I was able to eventually boot my system, but it is very unresponsive and slow.

    My questions are:
    1. I haven seen anything odd in /etc/fstab. What can I do to fix the kernel panic error?
    2. Where can I find the advanced options details, to see what the difference is?
    3. Under my current boot, yast is not opening boot-loader details, how to check?
    Last edited by t_neo; 26-Feb-2018 at 08:10. Reason: add text for google indexing
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,562

    Cool Re: Kernel panic - not syncing: VFS

    In the openSUSE Wiki, there's the following Support Database article:

    There's also this SDB article for recovering root's password but, it also works for other instances where a Rescue system is booted to repair the system disk to be booted:

  3. #3

    Default Re: Kernel panic - not syncing: VFS

    Thanks for the suggested pages. However I don't have issues with the root password. And the rescue system page states "Obviously, this isn't any good for when the hard disk or the boot loader needs to be repaired..." I don't really see how that will resolve the kernel panic and the oddity that I do can boot, but not following the default option.
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,562

    Default Re: Kernel panic - not syncing: VFS

    The "Rescue Disk" article is meant to describe how to produce a rescue disk if an installation DVD or installation USB (with an ISO image) is not at hand.
    If you have an installation DVD or installation USB, you can boot it and select the Rescue System. Then, proceed as for "recovering the root password": in other words mount the defective system disk and proceed to recover the boot loader or whatever else needs to be done.

  5. #5

    Default Re: Kernel panic - not syncing: VFS

    Making progress.

    I have booted the rescue system and followed the "Forgot root password" process to mount the disk and through Yast2 to install the boot-loader again. The output of the boot-loader installation threw an error, but it showed something interesting. As I now understand the difference in entries in the advanced options in GRUB. The second entry in my advanced options is now changed into kernel 4.15.4 instead of only 4.15.5. Booting that kernel all works as expected.

    Upon reboot GRUB boots the kernel 4.15.5 but now I end in emergency mode.
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,562

    Default Re: Kernel panic - not syncing: VFS

    Quote Originally Posted by t_neo View Post
    Upon reboot GRUB boots the kernel 4.15.5 but now I end in emergency mode.
    Given that, something seems to have gone very wrong at the last Tumbleweed upgrade: using the 4.15.4 kernel, try to re-upgrade to the 4.15.5 kernel.
    If that doesn't help, a Bug Report is needed.

  7. #7

    Default Re: Kernel panic - not syncing: VFS

    Re-Installing the new kernel 4.14.5 brought me further from home as it removed the 4.14.4 kernel and thus the advanced fallback option. Upon reboot I was presented again with the kernel panic screen. After fiddling for several hours with the issue I ended up re-installing TW which was faster than the fiddling. Too bad the rescue system process did not work, but I learned something new there.
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 32GB | Xonar Essence STX
    Laptop: openSUSE Leap 15.3 | KDE | Intel i5-2520M | 8GB | Intel HD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •