Results 1 to 8 of 8

Thread: Waarom ouder versie FF in Leap 42.3?

  1. #1
    Join Date
    Oct 2014
    Location
    Amsterdam, Netherlands
    Posts
    60

    Default Waarom ouder versie FF in Leap 42.3?

    Gewoon even een vraagje in de marge.

    Enkele weken terug lanceerde Mozilla zijn jongste (snelle) browser FF Quantum.
    Mozilla beweerde de snelste browser tot nu toe te hebben gelanceerd die zelfs Chromium en aanverwante browsers doet verbleken.
    https://www.mozilla.org/nl/firefox/

    Quantum is FF versie 58.0.2 terwijl Leap standaard 52.6.0 meelevert.

    Waarom loopt Suse zo achter met Firefox? Je zou verwachten dat ze juist als één van de eerste de jongste versie van FF zouden leveren?
    Ik vind de huidige meegeleverde versie zo traag als wat (ook na opfrissen) en zou graag die Quantumversie willen hebben. Alleen als ik die via hun site wil downloaden, dan krijg ik een TAR bestand waar ik geen raad mee weet. Zekere, ik kan hem uitpakken met ARK, maar verder kom ik dan ook niet.

    Nogmaals, waarom levert Suse niet de laatste repositories mee?
    openSUSE leap 42.2
    64 bit

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,035

    Default Re: Waarom ouder versie FF in Leap 42.3?

    Quote Originally Posted by Gardian_Angel View Post

    Waarom loopt Suse zo achter met Firefox? Je zou verwachten dat ze juist als één van de eerste de jongste versie van FF zouden leveren?
    Even afgezien van de rest van je vraag (waar vast wel een antwoord op komt), waarom verwacht je dat?

    Leap is de stabiele versie van openSUSE. Dat betekent dat er geen nieuwere versie van een product wordt geïntroduceerd nadat de versie is vastgelegd. Stabiliteit wil in dit verband vooral zeggen: geen wijzigingen voor de gebruiker. Niet ineens van vandaag op morgen een gewijzigde gebruikersinterface (knoppen ergens anders omdat nieuwe features ook knoppen moeten hebben) zodat je onverwacht je werkwijze in je normale van dag tot dag werkzaamheden moet wijzigen. Het is voor velen al erg genoeg om steeds aan een nieuwe versie te moeten wennen.

    Voor degenen die wel steeds de nieuwere versie (maar wel getest) van producten willen hebben is er Tumbleweed. Je kunt dus kiezen. Maar niet klagen als je keuze precies levert wat je hebt gekozen.

    Overigens loopt het met FF iets afwijkend, vandaar dat ik verwacht dat je nog wel meer antwoorden krijgt.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,089
    Blog Entries
    14

    Default Re: Waarom ouder versie FF in Leap 42.3?

    Als je echt om één of andere reden de laatste Firefox wilt, voeg dan deze repo toe
    Code:
    sudo zypper ar -f -n Mozilla http://repos.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3/ Mozilla
    sudo zypper ref
    (vertrouw de sleutel)
    sudo zypper dup --from Mozilla
    n

    Maar, daarmee omzeil je wel de openQA tests. Ben het verder met Henk eens: Leap is niet voor 't nieuwste van 't nieuwste. Tumbleweed wel. En als je geen Broadcom wifi kaart hebt of NVIDIA of AMD videokaart, even eenvoudig en stabiel.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Waarom ouder versie FF in Leap 42.3?

    Vind zelf ook de nieuwe FF veel stabieler en sneller dan de vorige versie.
    (Ben zelf een poos overgestapt naar Chrome)
    Vraag mij dan wel af, als een stuk software stabieler is dan de vorige versie (of sneller/beter) dat het misschien, een stabiele versie als Leap, ten goede komt soms software up te daten.
    Je zou inderdaad kunnen overstappen naar Tumbleweed.
    Alleen werkt het dan een beetje andersom.
    Tumbleweed wordt continue geüpdatet, maar het kan wel zijn dat sommige software pakketten problemen veroorzaken.
    Ik heb nooit problemen gehad met Tumbleweed, maar wel heel vaak (na een update van Tumbleweed) met een programma zoals Steam. (als voorbeeld)

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,089
    Blog Entries
    14

    Default Re: Waarom ouder versie FF in Leap 42.3?

    Quote Originally Posted by jansteen View Post
    Tumbleweed wordt continue geüpdatet, maar het kan wel zijn dat sommige software pakketten problemen veroorzaken.
    Ik heb nooit problemen gehad met Tumbleweed, maar wel heel vaak (na een update van Tumbleweed) met een programma zoals Steam. (als voorbeeld)
    Dan hebben we 't inderdaad over 3rd party software. TW en Leap verschillen qua tests niet veel.
    De meeste problemen met TW onstaan door 'zypper up' of applets die hetzelfde doen, of updaten via YaST softwarebeheer. En uiteraard door repos met nóg nieuwere, nóg betere software te gebruiken en de inhoud daarvan te mixen met TW .
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,035

    Default Re: Waarom ouder versie FF in Leap 42.3?

    Quote Originally Posted by Knurpht View Post
    nóg nieuwere, nóg betere software t.
    Contradictio in termini.
    Henk van Velden

  7. #7
    Join Date
    Oct 2014
    Location
    Amsterdam, Netherlands
    Posts
    60

    Default Re: Waarom ouder versie FF in Leap 42.3?

    Dank voor de (interessante)reacties.

    Dus ik begrijp dat de jongste versie nog niet voldoende is doorgetest voor Leap?
    openSUSE leap 42.2
    64 bit

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,089
    Blog Entries
    14

    Default Re: Waarom ouder versie FF in Leap 42.3?

    Quote Originally Posted by Gardian_Angel View Post
    Dank voor de (interessante)reacties.

    Dus ik begrijp dat de jongste versie nog niet voldoende is doorgetest voor Leap?
    Nee, zo zit het niet helemaal. Leap is bedoeld om een min of meer LTS ( Long Term Support ) versie te kunnen distribueren. Daarbij worden (net als bij andere distro's LTS versies ) software versies niet naar een hogere 'major version' geupdate, wel worden bug- en security fixes verwerkt. Dat is dé manier om de distro incl. updates stabiel te houden. Maar, sinds jaar en dag zijn er buiten de home:/ en devel:/ repos er ook een aantal repos die je als semi-officieel zou kunnen beschouwen. ( toevoegbaar via YaST - Software - Softwarebronnen - Toevoegen - Bronnen onderhouden door de gemeenschap ). Daar zaten vroeger o.a. de LibreOffice en Mozilla repo in.

    Dat het principe werkt, blijkt uit o.a. afname in aantal bugreports. terwijl er een flinke toename van openSUSE gebruikers is.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •