Results 1 to 10 of 10

Thread: DKMS Problem

  1. #1

    Default DKMS Problem

    Hey,

    I have a DKMS problem. I use the wifi driver rtl8192CU and the following repository on github.

    Code:
    https://github.com/pvaret/rtl8192cu-fixes
    I executed the following commands:
    Code:
    cd /home/user/programs/wifi-driver
    git clone https://github.com/pvaret/rtl8192cu-fixes.git
    sudo dkms add ./rtl8192cu-fixes
    sudo dkms install 8192cu/1.11
    sudo depmod -a
    ...
    But after a kernel update the module was not rebuild. I have to rebuild manually. After that it works, but it is really painful.

    What can I do to resolve this problem?

    Thanks in advance
    Björn

  2. #2
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    392

    Default Re: DKMS Problem

    You have to make sure dkms is running. You can do it in Yast2>System>Services Manager - dkms enable and start. Or you should be able to do it in terminal with
    Code:
    sudo systemctl enable dkms
    <password>
    sudo systemctl start dkms
    Pete

  3. #3

    Default Re: DKMS Problem

    Hi Pete,

    yes the dkms service was not enabled and started. I have did that and executed dkms install again. After a kernel update the module was not available and I had to build manually again. The problem is not solved.

    Is the location of the source code important?

    Greetings Björn

  4. #4
    Join Date
    Sep 2012
    Posts
    7,101

    Default Re: DKMS Problem

    It will only autoinstall modules that explicitly request it (man dkms, search for AUTOINSTALL).

  5. #5
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    392

    Default Re: DKMS Problem

    Check the dkms.conf file which should be in /usr/src/8192cu-1.11/.
    And check
    Code:
    dkms status
    .
    Pete

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,725

    Default AW: DKMS Problem

    Why not the rtlwifi driver and the rtl8192cu-firmware from my Repo?
    https://download.opensuse.org/reposi...SE_Tumbleweed/

    That is build automatically if a new kernel is published in the Tumbleweed Repo.
    So you can get it automatoically by updating your System if you enabled my Repo.

    It is build from Larry Fingers git Repo:
    https://github.com/lwfinger/rtlwifi_new/

  7. #7

    Default Re: DKMS Problem

    @Sauerland Your repo is my second solution for this problem. I would like to try the build with dkms.

    Here my console output:
    Code:
    localhost:/usr/src/8192cu-1.11 # ls
    8192cu-disable-power-management.conf  README.md                      clean  dkms.conf  include  runwpa
    Makefile                              blacklist-native-rtl8192.conf  core   hal        os_dep
    localhost:/usr/src/8192cu-1.11 # dkms status
    8192cu, 1.10, 4.14.12-1-default, x86_64: installed
    8192cu, 1.10, 4.14.13-1-default, x86_64: installed
    8192cu, 1.10, 4.14.14-1-default, x86_64: installed
    8192cu, 1.10, 4.14.15-1-default, x86_64: installed
    8192cu, 1.11, 4.15.1-1-default, x86_64: installed
    8192cu, 1.11, 4.15.3-1-default, x86_64: installed
    8192cu, 1.11, 4.15.5-1-default, x86_64: installed
    8192cu, 1.11, 4.15.6-1-default, x86_64: installed
    8192cu, 4.0.29: added
    8192cu, 1.11, 4.15.5-1-default, x86_64: installed-weak from 4.15.6-1-default
    localhost:/usr/src # dkms uninstall 8192cu/1.10
    Error! The module 8192cu 1.10 is not currently installed.
    This module is not currently ACTIVE for kernel 4.15.6-1-default (x86_64).
    localhost:/usr/src # dkms uninstall 8192cu/4.0.29
    Error! The module 8192cu 4.0.29 is not currently installed.
    This module is not currently ACTIVE for kernel 4.15.6-1-default (x86_64).
    localhost:/usr/src # dkms remove 8192cu/1.10 --all
    ...
    localhost:/usr/src # dkms remove 8192cu/4.0.29 --all
    
    ------------------------------
    Deleting module version: 4.0.29
    completely from the DKMS tree.
    ------------------------------
    Done.
    localhost:/usr/src # dkms status
    8192cu, 1.11, 4.15.1-1-default, x86_64: installed
    8192cu, 1.11, 4.15.3-1-default, x86_64: installed
    8192cu, 1.11, 4.15.5-1-default, x86_64: installed
    8192cu, 1.11, 4.15.6-1-default, x86_64: installed
    8192cu, 1.11, 4.15.5-1-default, x86_64: installed-weak from 4.15.6-1-default
    localhost:/usr/src # cat 8192cu-1.11/dkms.conf 
    PACKAGE_NAME="8192cu"
    PACKAGE_VERSION="1.11"
    BUILT_MODULE_NAME="8192cu"
    DEST_MODULE_LOCATION="/kernel/drivers/net/wireless/"
    REMAKE_INITRD="yes"
    AUTOINSTALL="yes"

  8. #8
    Join Date
    Sep 2012
    Posts
    7,101

    Default Re: DKMS Problem

    It looks like module should have been autoinstalled. At this point you really need to troubleshoot it using logs (systemd logs - was service started at all, was it completed or faulted? dkms logs - what happened when dkms run?).

  9. #9
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    392

    Default Re: DKMS Problem

    Try a newer version from github (there are more than pvaret's). Or patch the one you have for kernel-4.15. There is a patch for the newer kernels if you google it ("nvidia kernel.4.15"). But there ought to be an updated attempt if you search 8192cu in github.
    I've just reread your latest post properly! Forget about this. Sorry.
    Last edited by peteh100; 04-Mar-2018 at 11:01. Reason: add amendment
    Pete

  10. #10

    Default Re: DKMS Problem

    Why are you trying to run a depricated driver?

    "The new rtl8xxxu driver initially introduced in kernel 4.4 works mostly well these days, and you should give it a try before trying this repository."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •