Results 1 to 2 of 2

Thread: gscan2pdf dependency issues

  1. #1

    Default gscan2pdf dependency issues

    I had some trouble getting gscan2pdf to run.

    First, I had to activate
    Code:
     http://download.opensuse.org/repositories/Publishing/openSUSE_Leap_42.3/
    for gscan2pdf and then to add
    Code:
    http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_42.3/
    to resolve dependency issues.

    Unfortunately, the program still does not start:

    Code:
    Can't locate Exception/Class.pm in @INC (you may need to install the Exception::Class module) (@INC contains: /usr/lib/perl5/site_perl/5.18.2/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.18.2 /usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.18.2 /usr/lib/perl5/5.18.2/x86_64-linux-thread-multi /usr/lib/perl5/5.18.2 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/Image/Sane/Device.pm line 7.
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/Image/Sane/Device.pm line 7.
    Compilation failed in require at /usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/Image/Sane.pm line 6.
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/Image/Sane.pm line 6.
    Compilation failed in require at /usr/lib/perl5/vendor_perl/5.18.2/Gscan2pdf/Scanner/Options.pm line 8.
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.18.2/Gscan2pdf/Scanner/Options.pm line 8.
    Compilation failed in require at /usr/lib/perl5/vendor_perl/5.18.2/Gscan2pdf/Document.pm line 12.
    BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.18.2/Gscan2pdf/Document.pm line 12.
    Compilation failed in require at /usr/bin/gscan2pdf line 50.
    BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 50.
    It worked only after installing
    Code:
    perl-Exception-Class
    from the PERL repo. Thanks to Jeffrey Ratcliffe for the solution.

    It would be great if this dependency issue could be resolved in the next version of gscan2pdf rpm.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,824
    Blog Entries
    15

    Default Re: gscan2pdf dependency issues

    Hi
    Interesting, added to the requires and updated to version 1.8.11;
    https://build.opensuse.org/request/show/579220
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •