Results 1 to 2 of 2

Thread: SDDM does not start on boot with NVIDIA prop driver

  1. #1

    Default SDDM does not start on boot with NVIDIA prop driver

    Hi All,

    I recently upgraded to Leap 42.3. The machine has a GeForce GTX 750i Nvidia graphics card. I am using the factory opensuse build, so the sddm version is 0.14. The machine had been running tumbleweed, but after a disk crash I wanted to play it safe and use a slower release version.

    The opensuse works really, except that at boot I am staring at a console login prompt. If I issue
    Code:
     sudo systemctl enable sddm.service 
                sudo systemctl start sddm.service
    The display manager starts up and runs. The graphics are crisp, and the nvidia tools all confirm a smoothly operating video card. I don't think this is an obvious driver issue.

    I have checked that sddm is the default display manager. Looking in /etc/systemd/system/display-manager.service I see:

    Code:
    [Unit]
    Description=Simple Desktop Display Manager
    Documentation=man:sddm(1) man:sddm.conf(5)
    Conflicts=getty@tty7.service
    After=systemd-user-sessions.service getty@tty7.service plymouth-quit.service
    
    [Service]
    ExecStart=/usr/bin/sddm
    ExecStartPre=-/usr/bin/plymouth quit --retain-splash
    Restart=always
    
    [Install]
    Alias=display-manager.service
    I execute who -r and see the following:

    Code:
     run-level 3 Feb 19 11:18

    I am not sure if something is missing from an init script? I thought run levels were no longer important? I have also done the standard voodoo: 1. zypper in -f sddm 2. mkinitrd still the same!

    Thank you!

    -Greg

  2. #2
    Join Date
    Sep 2012
    Posts
    7,101

    Default Re: SDDM does not start on boot with NVIDIA prop driver

    What "systemctl get-default" says?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •