Results 1 to 7 of 7

Thread: libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586

  1. #1
    Join Date
    Feb 2018
    Posts
    3

    Default libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586

    Hallo,
    nach
    sudo zypper dup # in tumbleweed
    erhalte ich:
    libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586 wird nirgends zur Verfügung gestellt
    mit möglichen Optionen (veraltetes vlc-noX-2.2.8-2.3.x86_64 beibehalten etc.).

    Wir löse ich dieses konkrete Problem?
    Wo gibt es eine vernünftige Doku (de/en), die den Hintergrund und mögliche Folgen erläutert?
    Gibt es ein Verfahren / eine Website, um solche Probleme den tumbleweed - Maintainern zu melden?

    Danke vorab!

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,734

    Default AW: libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586

    mit möglichen Optionen (veraltetes vlc-noX-2.2.8-2.3.x86_64 beibehalten etc.).
    Bitte immer die komplette Eingabezeile incl. der kompletten Ausgabe hier in Code-Tags posten.

    Ist sonst Rate mal mit Rosenthal.

    Gibt es ein Verfahren / eine Website, um solche Probleme den tumbleweed - Maintainern zu melden?
    Eigentlich bugzilla, aber in diesem Fall ist es kein Fehler, sondern nur eine Meldung, das der User eingreifen muss.
    https://bugzilla.opensuse.org/index.cgi

  3. #3
    Join Date
    Feb 2018
    Posts
    3

    Default Re: libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586

    juergen@linux-74mm:~> sudo zypper dup --no-allow-vendor-change
    [sudo] Passwort für root:
    Warnung: Sie sind im Begriff, eine Distributionsaktualisierung mit allen aktivierten Repositorys durchzuführen. Vergewissern Sie sich, dass diese Repositorys kompatibel sind, bevor Sie fortfahren. Weitere Informationen zu diesem Kommando finden Sie unter 'man zypper'.
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Distributions-Aktualisierungen werden verarbeitet...

    Problem: libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586 wird nirgends zur Verfügung gestellt
    Lösung 1: Folgende Aktionen werden ausgeführt:
    veraltetes vlc-noX-2.2.8-2.3.x86_64 beibehalten
    veraltetes libvlc5-2.2.8-2.3.x86_64 beibehalten
    Lösung 2: Deinstallation von phonon4qt5-backend-vlc-0.9.0-3.2.x86_64
    Lösung 3: phonon4qt5-backend-vlc-0.9.0-3.2.i586 durch Ignorieren einiger Abhängigkeiten brechen

    Wählen Sie aus den obigen Lösungen mittels Nummer oder brechen Sie (a)b [1/2/3/a] (a):

  4. #4

    Default Re: libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586

    Das Problem ist dass phonon4qt5-backend-vlc 0.9.0 nicht gegen vlc 3.0 gebaut werden konnte (Kompilierfehler), das bestehende Paket benötigt daher immer noch vlc 2.2.8.
    Sollte im nächsten Snapshot behoben sein (mit Update auf 0.9.1). Vorläufige "Lösung" ist halt bei vlc 2.2.8 zu bleiben...

    Du kannst du aber auch einfach phonon4qt5-backend-vlc deinstallieren und stattdessen das gstreamer Backend verwenden (das per default installiert wird)
    Last edited by wolfi323; 19-Feb-2018 at 09:50.

  5. #5
    Join Date
    Feb 2018
    Posts
    3

    Default Re: libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586

    Quote Originally Posted by wolfi323 View Post
    Sollte im nächsten Snapshot behoben sein (mit Update auf 0.9.1).
    Danke für die Hilfe, ich werde abwarten!
    Vergleichbare Probleme hatte ich schon gelegentlich mit anderen Komponenten, die sich dann durch Abwarten gelöst haben, aber mich würde doch interessieren, ob es irgendwo ein didaktisch brauchbares Dokument (auch gern auf EN) gibt, das den ganzen Prozess erklärt und erläutert, auf welcher Grundlage man die passende Antwort zu den Auswahlfragen (dies deinstallieren, jene Abhängigkeit brechen...) findet. Im Einzelfall im Forum nachzufragen ist ja letztlich keine grundsätzliche Problembehebung.
    Auch würde mich interessieren, ob das automatische Testverfahren für Tumbleweed solche Probleme im Vorfeld greifen könnte oder ob so etwas wie ein Feedback - Geschäftsprozess eingerichtet werden sollte, der aus einem Incident ein lösbares Problem macht.

    Scenario: Ich starte zypper dup, dann findet zypper dup ein issue und fragt mich nicht nur, was ich jetzt machen will, sondern auch "Stimmst Du zu, dass dieser Sachverhalt automatisiert gemeldet wird?" und bei positiver Antwort bekommen die Maintainer den Hinweis, was im Argen liegt. Das würde doch auf Dauer zur Verbesserung auf einer breiten Basis führen können.
    Ich könnte es leider nicht programmieren, aber mir erschiene solche eine Feedback - Schleife sinnvoll.

  6. #6

    Default Re: libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586

    Tja, wenn der Bau von Distributionspaketen fehlschlägt, wird das automatisch an die zuständigen Personen gemeldet.
    Leider ist das aber nicht immer im Vorhinein abzusehen...

    Neue Tumbleweed Snapshots werden aber nur veröffentlicht wenn alle Kernpakete in Ordnung sind.
    phonon4qt5-backend-vlc ist aber optional, und wird nicht mal per default (automatisch) installiert.
    Last edited by wolfi323; 20-Feb-2018 at 08:45.

  7. #7

    Default Re: libvlccore.so.8 benötigt von phonon4qt5-backend-vlc-0.9.0-3.2.i586

    Falls noch nicht bemerkt, das neue Paket (0.9.1) sollte mittlerweile in den Repos sein, der Konflikt sollte also nicht mehr auftreten.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •