Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: cryfs: Wrong version installed. The required version is 0.9.6

  1. #1

    Default cryfs: Wrong version installed. The required version is 0.9.6

    Hi

    I'm using OpenSuse Tumbleweed with KDE. I installed KDE vault which is available as part of the new update. When I try to select the cryfs it is give me error message "cryfs: Wrong version installed. The required version is 0.9.6 fusermount: Correct version found" . But i don't have any issue while selecting encfs type.

    Please let me know what might be the issue in this.

    I'm using

    KDE Plasma version 5.12
    KDE Framework version 5.42
    openSUSE Tumbleweed 20180213-0


    Vipin

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,448
    Blog Entries
    2

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    As a starting point,
    You'll have to post information about your cryfs, where you got it from and its version.
    A search at https://software.opensuse.com/search returns the fact that various versions of cryfx for TW has been built, but they're all private repos.
    I see that the latest version available (cryfs 0.9.9) is available in a malcolm lewis repo (likely recommended over others).

    https://software.opensuse.org/packag...rch_term=cryfs

    It also looks like building from source can be easy.
    The instructions to build from source are available at the following page, and based on a superficial inspection the package list for Fedora look like the package names for dependencies you would use for openSUSE, just use "zypper" in place of dnf. Building from source will have the downside of no automatic package management including auto updates, but would ensure latest code from the Project. Instructions on the page describe how to create your own RPM if you wish for integration with your Package Management.

    https://github.com/cryfs/cryfs

    So,
    I'm doing a bit of personal speculation that there is an error in the code that specifies and checks the exact version of fuse compiled into your version of cryfs instead of specifying only a minimal version. That would mean that on a system like TW that rushes updates and changes to the User, cryfs will break often. Short of fixing the code, this may mean that once you are able to get a working cryfs, you'll want to lock the fuse package on your system.

    In any case, you should submit a bug report...
    Although you might do so to https://bugzilla.opensuse.org, I suspect this likely affects all development distros and not jut TW so recommend you should instead submit to the github Project instead if you are able to do so (would require a Github account but that's a very good thing for you to have if you don't already have one).

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,197
    Blog Entries
    15

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    Hi
    From the spec file;
    Code:
    # plasma-vault supports cryfs and encfs, but we only have encfs here (for now)
    Requires:       encfs
    Ref: https://build.opensuse.org/package/v....spec?expand=1

    Needs to be built with cryfs support. There are plans underway by another user to push cryfs to Factory/Tumbleweed. Once that happens, I'm guessing cryfs support can be added....
    Last edited by hcvv; 23-Feb-2018 at 02:43. Reason: repaired CODE tags
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,448
    Blog Entries
    2

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    [QUOTE=malcolmlewis;2856008]Hi
    From the spec file;
    # plasma-vault supports cryfs and encfs, but we only have encfs here (for now)
    Requires: encfs
    [/CODE]
    Ref: https://build.opensuse.org/package/v....spec?expand=1

    Needs to be built with cryfs support. There are plans underway by another user to push cryfs to Factory/Tumbleweed. Once that happens, I'm guessing cryfs support can be added....
    Unclear to me,
    Are you suggesting that existing packages won't work with KDE/Plasma but would work with another Desktop?

    And, if this is the issue then it seems to me that doing your own build should address the problem.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,197
    Blog Entries
    15

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    [QUOTE=tsu2;2856016]
    Quote Originally Posted by malcolmlewis View Post
    Hi
    From the spec file;


    Unclear to me,
    Are you suggesting that existing packages won't work with KDE/Plasma but would work with another Desktop?

    And, if this is the issue then it seems to me that doing your own build should address the problem.

    TSU
    Hi
    I imagine so, but unsupported, that's up to the Plasma folks to enable if and when it's ready...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,448
    Blog Entries
    2

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    [QUOTE=malcolmlewis;2856017]
    Quote Originally Posted by tsu2 View Post
    Hi
    I imagine so, but unsupported, that's up to the Plasma folks to enable if and when it's ready...

    Apparently, Plasma issues with cryfs aren't being reported in cryfs, but here are a couple recent Plasma/KDE comments
    https://cukic.co/2018/02/02/plasma-v...date-on-cryfs/
    https://cukic.co/2018/01/28/plasma-v...ryfs-versions/

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    Hi

    Please find the steps to reproduce my issue. I have attached a word document in this link. This is explaining the complete issue with screenshot.

    http://goo.gl/W3HtkE

    Thank you,

    Vipin

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,448
    Blog Entries
    2

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    Quote Originally Posted by vipinbalakrishnan View Post
    Hi

    Please find the steps to reproduce my issue. I have attached a word document in this link. This is explaining the complete issue with screenshot.

    http://goo.gl/W3HtkE

    Thank you,

    Vipin
    I'm pretty sure that the people working on this have as much info as you posted but if you think you are able to contribute something significant, you should probably open or append to a bug in the kde bugzilla.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  9. #9

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    As has been pointed out already, cryfs is not supported in Tumbleweed currently (actually it is not included at all).
    A bug report won't help with this either.

    Upstream KDE even changed the default to encfs in plasma-vault 5.12, because "CryFS is still not considered stable, and it has issues when using
    it from an automated UI"...
    https://cgit.kde.org/plasma-vault.gi...bf00ab6f3e764c

  10. #10

    Default Re: cryfs: Wrong version installed. The required version is 0.9.6

    PS:
    Quote Originally Posted by malcolmlewis View Post
    Needs to be built with cryfs support.
    AFAICS, there is no special need to build plasma-vault with cryfs support.
    It should find it on runtime if installed (in a suitable version).

    It hasn't been patched out in the openSUSE package or something...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •