Results 1 to 8 of 8

Thread: LibreOffice 6.0 on Leap 42.3

  1. #1

    Default LibreOffice 6.0 on Leap 42.3

    Is there a repository for upgrading Leap 42.3 to LibreOffice 6.0? Or should we download the source rpm from LibreOffice?

    Thanks.

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: LibreOffice 6.0 on Leap 42.3

    Quote Originally Posted by matchpointok View Post
    Is there a repository for upgrading Leap 42.3 to LibreOffice 6.0? Or should we download the source rpm from LibreOffice?

    Thanks.
    There is a version 6.0 for Tumbleweed in the repos.

    For 42.3, you should probably go to here to get it, as there is an RPM available. Therefore, you do not need to download the source:
    https://www.libreoffice.org/download...0.1&lang=en-GB

    I cannot vouch for its suitability for 42.3, but I do not see why not, IMHO.

    Good luck, come back and let us know.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: LibreOffice 6.0 on Leap 42.3

    there is a LO 6.0 repo in the works for 42.3
    https://download.opensuse.org/reposi...USE_Leap_42.3/
    unfortunately it isn't complete
    it's been build for the upcoming LEAP 15
    https://download.opensuse.org/reposi...USE_Leap_15.0/
    so I'd wait a few days to see if the maintainers update packages for 42.3
    while the LEAP 15 and the TW repo might work but it is more probobly it will break your system as TW (and leap 15) is way ahead of LEAP it uses newer QT and GTK packages
    if you'd really want to use LO 6 and don't want to wait for the repo to come online get the rpm's from the document foundation
    edit
    apparently the build for LEAP 42.3 (and 15) have failed
    https://build.opensuse.org/package/s....0/libreoffice
    I'd wait for the maintainers to fix the build rather then using 3rd party repo's

  4. #4

    Default Re: LibreOffice 6.0 on Leap 42.3

    Quote Originally Posted by I_A View Post
    there is a LO 6.0 repo in the works for 42.3
    https://download.opensuse.org/reposi...USE_Leap_42.3/
    unfortunately it isn't complete
    it's been build for the upcoming LEAP 15
    https://download.opensuse.org/reposi...USE_Leap_15.0/
    so I'd wait a few days to see if the maintainers update packages for 42.3
    while the LEAP 15 and the TW repo might work but it is more probobly it will break your system as TW (and leap 15) is way ahead of LEAP it uses newer QT and GTK packages
    if you'd really want to use LO 6 and don't want to wait for the repo to come online get the rpm's from the document foundation
    edit
    apparently the build for LEAP 42.3 (and 15) have failed
    https://build.opensuse.org/package/s....0/libreoffice
    I'd wait for the maintainers to fix the build rather then using 3rd party repo's
    Thanks to all who tried to help. Guess I need to work on my patience again.

  5. #5

    Default Re: LibreOffice 6.0 on Leap 42.3

    Or, you could install the flatpak version of LO6:

    See:
    https://www.libreoffice.org/download/flatpak/
    And:
    https://flathub.org/

    Install flatpak, add flathub repo, search for libreoffice pacakge and install via flatpak command. That's it

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,759

    Question Re: LibreOffice 6.0 on Leap 42.3

    Quote Originally Posted by SF6 View Post
    Or, you could install the flatpak version of LO6:

    See:
    https://www.libreoffice.org/download/flatpak/
    And:
    https://flathub.org/

    Install flatpak, add flathub repo, search for libreoffice pacakge and install via flatpak command. That's it
    Does the sandboxed version of LibreOffice really run happily within the flatpak environment without any dependency issues arising?

  7. #7

    Default Re: LibreOffice 6.0 on Leap 42.3

    I had briefly tested it on TW, it worked fine there.

    LO6 flatpak depends on the GNOME runtime, which is why you need to install this flatpak first, before installing LO flatpak. It still worked fine in KDE as far as I can tell. As far as I remember it will auomatically ask you to install the runtime when you install LO6 flatpak.

    There is also KDE runtime available, but since LO needs Gnome they won't do much in this case.

  8. #8

    Default Re: LibreOffice 6.0 on Leap 42.3

    Quote Originally Posted by I_A View Post
    there is a LO 6.0 repo in the works for 42.3
    https://download.opensuse.org/reposi...USE_Leap_42.3/
    unfortunately it isn't complete
    I installed from this repository yesterday. 6.0.1.1 is up and working fine here.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •