Results 1 to 10 of 10

Thread: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

  1. #1

    Default opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    Laptops Fujitsu-Siemens S7110 and E8110 Does not boot on Opensuse 4.14.14.1-vanilla kernel.

    these laptops work fine on opensuse 13.1 on kernel 3.12.67.

    photo of screen here https://bugs.freedesktop.org/attachment.cgi?id=137020

    i try to boot with a drm.debug=14, but cant find dmesg or dont know how get it.

    But i found interesting in Xorg.0.log (i attached this file)

    Code:
    [    52.376] (II) Loading sub module "fb"
    [    52.376] (II) LoadModule: "fb"
    [    52.376] (II) Loading /usr/lib/xorg/modules/libfb.so
    [    52.377] (II) Module fb: vendor="X.Org Foundation"
    [    52.377]     compiled for 1.19.6, module version = 1.0.0
    [    52.377]     ABI class: X.Org ANSI C Emulation, version 0.4
    [    52.377] (II) UnloadModule: "fbdev"
    [    52.377] (II) Unloading fbdev
    [    52.377] (II) UnloadSubModule: "fbdevhw"
    [    52.377] (II) Unloading fbdevhw
    [    52.377] (II) UnloadModule: "vesa"
    [    52.377] (II) Unloading vesa
    [    52.377] (==) Depth 24 pixmap format is 32 bpp
    [    52.377] Require OpenGL version 2.1 or later.
    [    52.377] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.
    [    52.377] (EE) 
    Fatal server error:
    [    52.377] (EE) AddScreen/ScreenInit failed for driver 0
    [    52.377] (EE) 
    [    52.377] (EE) 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [    52.377] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    52.377] (EE) 
    [    52.408] (EE) Server terminated with error (1). Closing log file.

    i made a video how it is booting and after that blinking the screen https://youtu.be/BJplHiuHDCw

    I uploaded all /var/log/* with a folders into a clowd disk.yandex.ru:

    https://yadi.sk/d/oHq35uZF3S3stD

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,445
    Blog Entries
    14

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    Why the vanilla kernel instead of TW's stock one ( currently 4.15 ) ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    Quote Originally Posted by Knurpht View Post
    Why the vanilla kernel instead of TW's stock one ( currently 4.15 ) ?
    On stock we have the same problem. So i installed vanilla for testing.

  4. #4

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    Can anyone help me with this problem? Tumbleweed did not want to work on fujitsu laptops

  5. #5
    Join Date
    Sep 2012
    Posts
    5,379

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    Do you have Mesa-dri installed?

  6. #6

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    Quote Originally Posted by arvidjaar View Post
    Do you have Mesa-dri installed?
    yes. I checked. Where are:

    Mesa
    Mesa-dri
    Mesa-gallium
    Mesa-libEGL1
    Mesa-libGL1
    Mesa-libglapi0

    is installed.

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,080

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    How much RAM is installed on these two laptops? Both share RAM between system and video, and shipped with 512MB, while minimum in published system requirements (for both 13.1 and TW) is 1GB.

  8. #8

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    trying to boot fresh tumbleweed live. dmesg and other logs are here
    https://yadi.sk/d/ahfNZaod3SU7Ly

  9. #9
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    169

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    I can not download the files from https://yadi.sk/d/ahfNZaod3SU7Ly and I do not like all kind of view scripts etc. too much. Anyhow I had a look at dmesg.txt using the viewer and see these warnings:
    Code:
    [    8.968053] WARNING: CPU: 0 PID: 456 at ../kernel/irq/chip.c:244 __irq_startup+0x5c/0x70
    ...
    [   25.648755] ACPI Warning: SystemIO range  0x0000000000001028-0x000000000000102F conflicts with OpRegion  0x0000000000001000-0x0000000000001066 (\_SB.PCI0.LPCB.OPIO)  (20170831/utaddress-247)
    [   25.648766] ACPI Warning:  SystemIO range 0x0000000000001028-0x000000000000102F conflicts with  OpRegion 0x0000000000001000-0x000000000000107F (\_SB.PCI0.LPCB.PMIO)  (20170831/utaddress-247)
    [   25.648772] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
    [    25.648776] ACPI Warning: SystemIO range  0x00000000000011B0-0x00000000000011BF conflicts with OpRegion  0x0000000000001180-0x00000000000011BB (\_SB.PCI0.LPCB.OGIO)  (20170831/utaddress-247)
    [   25.648781] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
    [    25.648782] ACPI Warning: SystemIO range  0x0000000000001180-0x00000000000011AF conflicts with OpRegion  0x0000000000001180-0x00000000000011BB (\_SB.PCI0.LPCB.OGIO)  (20170831/utaddress-247)
    Not sure what is the CPU warning about but for the ACPI warnings you could try to disable ACPI in the BIOS.

  10. #10

    Default Re: opensuse tumbleweed does not boot on fujitsu-siemens platform on cpu t2400-t7200

    Quote Originally Posted by marel View Post
    I can not download the files from https://yadi.sk/d/ahfNZaod3SU7Ly and I do not like all kind of view scripts etc. too much. Anyhow I had a look at dmesg.txt using the viewer and see these warnings:
    Code:
    [    8.968053] WARNING: CPU: 0 PID: 456 at ../kernel/irq/chip.c:244 __irq_startup+0x5c/0x70
    ...
    [   25.648755] ACPI Warning: SystemIO range  0x0000000000001028-0x000000000000102F conflicts with OpRegion  0x0000000000001000-0x0000000000001066 (\_SB.PCI0.LPCB.OPIO)  (20170831/utaddress-247)
    Not sure what is the CPU warning about but for the ACPI warnings you could try to disable ACPI in the BIOS.
    The bios of fujitsu laptop (lifebook S7110) did not can disable acpi (did not have this settings).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •