Results 1 to 6 of 6

Thread: Why xdg-open reacts so slowly?

  1. #1

    Question Why xdg-open reacts so slowly?

    Recently I found that the first 3-4 times I click a link in programs like newsbeuter or claws-mail everything works fine - the link opens in the default browser instantly.

    However next clicks open more and more slowly (after 20-30 sec, then more than a minute etc). Even typing 'xdg-open https://opensuse.org' in console is terribly slow.

    I have opened a bug report for that but still I would be interested to know if anyone could give more info (and possibly a solution).

  2. #2

    Default Re: Why xdg-open reacts so slowly?

    Anyone please?

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Why xdg-open reacts so slowly?

    Quote Originally Posted by heyjoe View Post
    Anyone please?
    Not happening to me in Xfce with FFX ES.

    ...so, no can help at this time.

    But, probably a good idea to tell others what Desktop is in use.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  4. #4
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: Why xdg-open reacts so slowly?

    What does the CPU usage look like when it's opening slowly?

  5. #5

    Default Re: Why xdg-open reacts so slowly?

    Quote Originally Posted by Fraser_Bell View Post
    But, probably a good idea to tell others what Desktop is in use.
    KDE Plasma 5.8.7. (I believe it is also in the linked bug report)

    Quote Originally Posted by ravas View Post
    What does the CPU usage look like when it's opening slowly?
    Nothing extraordinary. There is no any high load and there is plenty of free RAM. During the waiting there is also a "1" in a rotating circle next to the clock (tray area) which when clicked shows:

    "Notifications

    Source https://opensuse.org/
    230 B of 0 B

    [bar with a blue short line moving left and right]"

  6. #6

    Default Re: Why xdg-open reacts so slowly?

    I think I may have found the culprit.

    I noticed that the first time xdg-open tries to open a URL a notification in the tray area appears



    So I went to "Proxy - System Settings Module" in Plasma and I saw it was set to "Detect proxy configuration automatically" which I changed to "No Proxy". Now clicking links seems to work fine.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •