Results 1 to 10 of 10

Thread: vlc conflict on latest dup

  1. #1
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default vlc conflict on latest dup

    i am confused over latest conflict

    Code:
    2 Problems:
    Problem: nothing provides libvlccore.so.8 needed by phonon4qt5-backend-vlc-0.9.0-3.2.i586
    Problem: vlc-3.0.0-4.4.x86_64 requires vlc-noX = 3.0.0-4.4, but this requirement cannot be provided
    
    
    Problem: nothing provides libvlccore.so.8 needed by phonon4qt5-backend-vlc-0.9.0-3.2.i586
     Solution 1: Following actions will be done:
      keep obsolete vlc-noX-2.2.8-5.10.x86_64
      keep obsolete libvlc5-2.2.8-5.10.x86_64
     Solution 2: deinstallation of phonon4qt5-backend-vlc-0.9.0-3.2.x86_64
     Solution 3: keep obsolete vlc-noX-2.2.8-5.10.x86_64
     Solution 4: break phonon4qt5-backend-vlc-0.9.0-3.2.i586 by ignoring some of its dependencies
    can anyone provide guidance?

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,277

    Default Re: vlc conflict on latest dup

    Probably “Solution 2” and go for the vlc-3 packages from Packman.
    Unless you want to stick with vlc-2.2.8 for some specific reason.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  3. #3
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: vlc conflict on latest dup

    is phonon4qt5-backend-vlc not required? (i have no idea what it does)
    have just check and yes this is from oss, but everything else from packman?
    could this just cruft from say an old version, and perhaps i have since done a switch to packman?

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,277

    Default Re: vlc conflict on latest dup

    Quote Originally Posted by ndc33 View Post
    is phonon4qt5-backend-vlc not required? (i have no idea what it does)
    No, not with the vlc-3 packages.

    have just check and yes this is from oss, but everything else from packman?
    could this just cruft from say an old version, and perhaps i have since done a switch to packman?

    Yes.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,333

    Default Re: vlc conflict on latest dup

    Quote Originally Posted by ndc33 View Post
    i am confused over latest conflict

    Code:
    2 Problems:
    Problem: nothing provides libvlccore.so.8 needed by phonon4qt5-backend-vlc-0.9.0-3.2.i586
    Problem: vlc-3.0.0-4.4.x86_64 requires vlc-noX = 3.0.0-4.4, but this requirement cannot be provided
    
    
    Problem: nothing provides libvlccore.so.8 needed by phonon4qt5-backend-vlc-0.9.0-3.2.i586
     Solution 1: Following actions will be done:
      keep obsolete vlc-noX-2.2.8-5.10.x86_64
      keep obsolete libvlc5-2.2.8-5.10.x86_64
     Solution 2: deinstallation of phonon4qt5-backend-vlc-0.9.0-3.2.x86_64
     Solution 3: keep obsolete vlc-noX-2.2.8-5.10.x86_64
     Solution 4: break phonon4qt5-backend-vlc-0.9.0-3.2.i586 by ignoring some of its dependencies
    can anyone provide guidance?
    Try removing phonon4qt5-backend-vlc-0.9.0-3.2.i586 and retry zypper dup.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  6. #6
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: vlc conflict on latest dup

    the dup conflict dialogue gave me an endless runaround. So I did:
    Code:
    sudo zypper rm -u vlc-noX  phonon4qt5-backend-vlc
    sudo zypper dup
    sudo zypper in vlc
    everything OK now, thanks for help.

  7. #7

    Default Re: vlc conflict on latest dup

    I also have some issues after upgrading to vlc 3.0.0 (which is implied in zypper dup). It cannot play back any mpeg/h264 anymore, from file or from dvb.

    $ vlc /home/michael/somevideo.mpg
    VLC media player 3.0.0 Vetinari (revision 3.0.0-30-gef4c265336)
    [000056360860eb60] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
    [00007f5cb4005800] main video output error: video output creation failed
    [00007f5cc0c064a0] main decoder error: failed to create video output
    [00007f5cb4005800] main video output error: video output creation failed
    [00007f5cc0c064a0] main decoder error: failed to create video output
    [00007f5cb4032a00] main video output error: video output creation failed
    [00007f5cc0c064a0] main decoder error: failed to create video output
    [mpeg2video @ 0x7f5cb40008c0] get_buffer() failed
    [mpeg2video @ 0x7f5cb40008c0] thread_get_buffer() failed
    [mpeg2video @ 0x7f5cb40008c0] get_buffer() failed (-1 (nil))
    [00007f5cb40ad800] main video output error: video output creation failed
    [00007f5cc0c064a0] main decoder error: failed to create video output
    [mpeg2video @ 0x7f5cb40008c0] get_buffer() failed

    No issues with the pre-3.0.0 release.

    I tried a zypper dup, which reported problems with libvlccore8, but after deleting it, libvlccore9 was autoselected. Still, zypper dup leaves me at this point.

  8. #8

    Default Re: vlc conflict on latest dup

    Addition: I have to explicitly select VDPAU; then I'm getting a video output again. This is the only working option for me. The current behavior on "Automatic" seems to be the one from the Wayland option.

    [000056163c136490] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
    [000056163c135350] main playlist: playlist is empty
    [00007f20080070a0] main video output error: video output creation failed
    [00007f200cc359b0] main decoder error: failed to create video output
    [00007f200cc359b0] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding

    However, I don't get audio output for h264 streams (DVB-C, HD channel) now. When I select ALSA, I get a "device busy", but audio is hearable.

    Using amdgpu.

  9. #9

    Default Re: vlc conflict on latest dup

    I tried on my second PC and found that selecting "openGL" for video output is working. This was the setting I had before, but then the log output showed that it tried to find a plugin "xcb_glx" which seems to be gone now. Or renamed?

    (Will retry on my other PC again in some days and report.)

  10. #10
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    3,333

    Default Re: vlc conflict on latest dup

    Quote Originally Posted by mizapf View Post
    I also have some issues after upgrading to vlc 3.0.0 (which is implied in zypper dup). It cannot play back any mpeg/h264 anymore, from file or from dvb.

    $ vlc /home/michael/somevideo.mpg
    VLC media player 3.0.0 Vetinari (revision 3.0.0-30-gef4c265336)
    [000056360860eb60] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
    [00007f5cb4005800] main video output error: video output creation failed
    [00007f5cc0c064a0] main decoder error: failed to create video output
    [00007f5cb4005800] main video output error: video output creation failed
    [00007f5cc0c064a0] main decoder error: failed to create video output
    [00007f5cb4032a00] main video output error: video output creation failed
    [00007f5cc0c064a0] main decoder error: failed to create video output
    [mpeg2video @ 0x7f5cb40008c0] get_buffer() failed
    [mpeg2video @ 0x7f5cb40008c0] thread_get_buffer() failed
    [mpeg2video @ 0x7f5cb40008c0] get_buffer() failed (-1 (nil))
    [00007f5cb40ad800] main video output error: video output creation failed
    [00007f5cc0c064a0] main decoder error: failed to create video output
    [mpeg2video @ 0x7f5cb40008c0] get_buffer() failed

    No issues with the pre-3.0.0 release.

    I tried a zypper dup, which reported problems with libvlccore8, but after deleting it, libvlccore9 was autoselected. Still, zypper dup leaves me at this point.
    Just upgraded to 20180224 and never experienced a problem related to vlc:

    Code:
    karl@erlangen:~> vlc /home/Albums/testjAlbum/2014-06_Arromanches_Commémorations_débarquement_581_\(1\).mp4 
    VLC media player 3.0.0 Vetinari (revision 3.0.0-30-gef4c265336)
    [0000558665814b60] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
    libva info: VA-API version 1.0.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
    libva info: Found init function __vaDriverInit_1_0
    libva info: va_openDriver() returns 0
    [00007f645cc39640] avcodec decoder: Using Intel i965 driver for Intel(R) Skylake - 2.0.0 for hardware decoding
    QObject::~QObject: Timers cannot be stopped from another thread
    karl@erlangen:~>
    Try running zypper ref --force as well as zypper dup and zypper dup --from http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/.

    Delete outdated configration files:

    Code:
    karl@erlangen:~> find . -name '*vlc*'
    ./.local/share/applications/vlc-2.desktop
    ./.local/share/vlc
    ./.local/share/RecentDocuments/529733-vlc-conflict-on-latest-dup.desktop
    ./.config/vlcrc
    ./.config/vlc
    ./.config/vlc/vlcrc
    ./.config/vlc/vlc-qt-interface.conf
    karl@erlangen:~>
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •