Page 1 of 5 123 ... LastLast
Results 1 to 10 of 47

Thread: Grub and I am starting to become agressive

  1. #1

    Default Grub and I am starting to become agressive

    [rant]Lets start by the aggressive part, I have been reading multiple websites for days about grub, and still don't have a clue on how to fix my problem.

    I also start to get a feeling I want to kill the people who wrote grub.

    Who ever thought it was a good idea, to have files in multiple , and I mean multiple places?

    This mostly annoys me, when I read the old grub had one bloody file. [/rant]



    Whats the situation, I have 3 hard disk

    sda NTFS WIN 7
    sdb Ext4 Leap 42.3
    sdc Ext4 Leap 42.1

    After an failed update I managed to get 42.3 booting by first booting 42.1.

    The grub screen now gives 5 options, which is good.


    Leap 42.1 is first, and I want of course 42.3 at the first spot.
    I am however getting an headache, because in yast under boot options in 42.3, 42.3 is listed as the os that should start first.

    When I start the pc , grub greets me with 42.1 listed first.


    Then an question about yast and the mbr under bootloader options.

    Does linux ( opensuse ) have an mbr?

    Or does this only apply to a pc like mine, were there is also a windows disk.

    Is there a simple way to find out how grub is set up now ? Why it does what it does ?
    Should I look in the grub file yast generates ?

    Can I use grub for this? I noticed if I type ls in the Grub console
    Code:
     ls
    it lists all hard disk.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,239

    Default Re: Grub and I am starting to become agressive

    MBR references both an area at the start of the disk (Master Boot Record) and a boot method. Assuming you have a newer PC ( less then 6 or 7 years old) it has a thing called the UEFI which does the functions of the old BIOS and uses the EFI boot method. So today you have two different boot methods EFI and MBR (legacy). With multiple OS you should not mix the two. All OS should use the same method. First addressing only Linux OS's each one will have it's own grub which are totally independent. Now it all boils down to how they are set to boot MBR/EFI. So how do you have the boot setup???

    It may help to show us the drive layouts ie copy/paste the output of fdisk -l. Please use code tags to preserve the formatting. (# in the editor tool bar)

    In Yast you can set which entry is the default. Most setting can be done from Yast - boot loader. But remember each Linux has its own grub setup and the one you see at boot, the controlling one, is the one set to boot in the UEFI boot menu or the BIOS depending on how old the hardware is. You can't change the listing order in Yast you have to edit the grub files for that just set the default.

  3. #3

    Default Re: Grub and I am starting to become agressive

    No UEFI here, thats one small part I do get.

    You remark about mbr referring to two things, already makes things a bit more clear.

    The output of Fdisk -l

    wissel geheugen = swap


    Code:
    Schijf /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectoren
    Eenheid: sectoren van 1 * 512 = 512 bytes
    Sectorgrootte (logisch/fysiek): 512 bytes / 512 bytes
    In-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
    Schijflabeltype: dos
    Schijf-ID: 0x2b6d04f2
    
    Apparaat   Op.  Begin     Einde  Sectoren Grootte ID Type
    /dev/sda1  *     2048    206847    204800    100M  7 HPFS/NTFS/exFAT
    /dev/sda2      206848 976771071 976564224  465,7G  7 HPFS/NTFS/exFAT
    
    
    Schijf /dev/sdb: 931,5 GiB, 1000204886016 bytes, 1953525168 sectoren
    Eenheid: sectoren van 1 * 512 = 512 bytes
    Sectorgrootte (logisch/fysiek): 512 bytes / 4096 bytes
    In-/uitvoergrootte (minimaal/optimaal): 4096 bytes / 4096 bytes
    Schijflabeltype: dos
    Schijf-ID: 0x00083323
    
    Apparaat   Op.      Begin      Einde   Sectoren Grootte ID Type
    /dev/sdb1  *         2048 1881843711 1881841664  897,3G 83 Linux
    /dev/sdb2      1881843712 1945331711   63488000   30,3G 83 Linux
    /dev/sdb3      1945331712 1953523711    8192000    3,9G 82 Linux wisselgeheugen
    
    
    Schijf /dev/sdc: 465,8 GiB, 500107862016 bytes, 976773168 sectoren
    Eenheid: sectoren van 1 * 512 = 512 bytes
    Sectorgrootte (logisch/fysiek): 512 bytes / 512 bytes
    In-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
    Schijflabeltype: dos
    Schijf-ID: 0x48e3d6ef
    
    Apparaat   Op.    Begin     Einde  Sectoren Grootte ID Type
    /dev/sdc1          2048   4208639   4206592      2G 82 Linux wisselgeheugen
    /dev/sdc2  *    4208640  46153727  41945088     20G 83 Linux
    /dev/sdc3      46153728 976773119 930619392  443,8G 83 Linux

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,120

    Default Re: Grub and I am starting to become agressive

    Quote Originally Posted by Gps2010 View Post
    [ ... in yast under boot options in 42.3, 42.3 is listed as the os that should start first.

    When I start the pc , grub greets me with 42.1 listed first. ...
    There is only one effective boot chain. This is primarily determined by motherboard BIOS settings and firmware.
    Legacy boot (MBR-DOS partitioning) or UEFI (with or without secure boot)
    Device boot order.
    Partition boot flag
    Grub2 or Grub2-EFI
    Use of "device name" "label" or "UUID" to identify partitions.

    You have evidently chosen not to use the default recommendations during the openSUSE installs. My guess is that:
    You are using UUID, so once the boot gets as bar as Grub the deviice name (e.g. sdb1) is irrelevant.
    Either MBR or EFI Boot are pointing to the Leap-42.1 Grub.
    Try using YaST in 42.1 to set the default operating system boot order.

    Otherwise more detailed information about your system is required.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    23,774

    Default Re: Grub and I am starting to become agressive

    Quote Originally Posted by Gps2010 View Post
    .......

    The output of Fdisk -l

    wissel geheugen = swap

    ..............
    First: do not write things like "The output of Fdisk -l ". To begin with it is fdisk, not Fdisk, then you better include one more line at the top (the one that has the prompt and the fdisk -l command) to your copy/paste. Then we see what you saw and you do not have to write what you did (with or without typos).

    Then: to avoid having dutch words in your output, you can do
    Code:
    LANG=C fdisk -l
    (and that works also for other commands).

    As example an part of such a listing from one of my systems:
    Code:
    boven:~ # fdisk -l
    
    Schijf /dev/sda: 320.1 GB, 320072933376 bytes, 625142448 sectoren
    Eenheid = sectoren van 1 * 512 = 512 bytes
    
    Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
    in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
    Schijflabeltype: dos
    Schijf-ID: 0x1549f232
    
     Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
    /dev/sda1              63     4209029     2104483+  82  Linux swap / Solaris
    /dev/sda2   *     4209030    46154744    20972857+  83  Linux
    Code:
    boven:~ # LANG=C fdisk -l
    
    Disk /dev/sda: 320.1 GB, 320072933376 bytes, 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0x1549f232
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1              63     4209029     2104483+  82  Linux swap / Solaris
    /dev/sda2   *     4209030    46154744    20972857+  83  Linux
    Henk van Velden

  6. #6
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,120

    Default Re: Grub and I am starting to become agressive

    Quote Originally Posted by Gps2010 View Post
    Code:
    Apparaat   Op.      Begin      Einde   Sectoren Grootte ID Type
    /dev/sdb1  *         2048 1881843711 1881841664  897,3G 83 Linux
    /dev/sdb2      1881843712 1945331711   63488000   30,3G 83 Linux
    /dev/sdb3      1945331712 1953523711    8192000    3,9G 82 Linux wisselgeheugen
    You have a Boot Flag set on the largest partition on sdb. Another guess: sdb1(897GB) is a data partition (e.g. “/home”), and sdb2 (30GB) hols the operating system (“/”).
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    526

    Default Re: Grub and I am starting to become agressive

    Quote Originally Posted by Gps2010 View Post

    Whats the situation, I have 3 hard disk

    sda NTFS WIN 7
    sdb Ext4 Leap 42.3
    sdc Ext4 Leap 42.1

    After an failed update I managed to get 42.3 booting by first booting 42.1.
    Given that you may want to
    • boot Leap 42.3 and install grub without further tinkering using YAST2
    • enter UEFI and select sdb as boot device
    • save changes and exit

    This solved similar problems on my machine with multiple disks and partitions.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  8. #8

    Default Re: Grub and I am starting to become agressive

    Code:
    Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x2b6d04f2
    
    Device     Boot  Start       End   Sectors   Size Id Type
    /dev/sda1  *      2048    206847    204800   100M  7 HPFS/NTFS/exFAT
    /dev/sda2       206848 976771071 976564224 465.7G  7 HPFS/NTFS/exFAT
    
    
    Disk /dev/sdb: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: dos
    Disk identifier: 0x00083323
    
    Device     Boot      Start        End    Sectors   Size Id Type
    /dev/sdb1  *          2048 1881843711 1881841664 897.3G 83 Linux
    /dev/sdb2       1881843712 1945331711   63488000  30.3G 83 Linux
    /dev/sdb3       1945331712 1953523711    8192000   3.9G 82 Linux swap / Solaris
    
    
    Disk /dev/sdc: 465.8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x48e3d6ef
    
    Device     Boot    Start       End   Sectors   Size Id Type
    /dev/sdc1           2048   4208639   4206592     2G 82 Linux swap / Solaris
    /dev/sdc2  *     4208640  46153727  41945088    20G 83 Linux
    /dev/sdc3       46153728 976773119 930619392 443.8G 83 Linux
    sda = Win7
    sdb = leap 43.3
    sdc = leap 42.1

    All three OS have their own harddisk.

    leap 42.3 yast





  9. #9

    Default Re: Grub and I am starting to become agressive

    leap 42.1 yast.







    I have no idea what the default setting is or should be.
    I do know, I have allot of history, and I would like to do some cleaning up (grub).

    leap 42.3 is an updated leap 42.2, I used the zypper command for that. That update ended with a grub error.
    I am 99.9 % sure that the cause of that grub error was the history of previous installs, maybe even back to opensuse 11.3.

  10. #10
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    526

    Default Re: Grub and I am starting to become agressive

    Quote Originally Posted by Gps2010 View Post
    leap 42.1 yast.
    I have no idea what the default setting is or should be.
    I do know, I have allot of history, and I would like to do some cleaning up (grub).

    leap 42.3 is an updated leap 42.2, I used the zypper command for that. That update ended with a grub error.
    I am 99.9 % sure that the cause of that grub error was the history of previous installs, maybe even back to opensuse 11.3.
    Checked against my working configuration and found different settings of boot loader location:

    - Boot from master boot record: unchecked
    - Boot from root partition: checked
    - Custom boot partion: unchecked

    Try the above, quit Yast2 by clicking ok and reboot.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •