Results 1 to 6 of 6

Thread: Yast firewall module missing

  1. #1
    Join Date
    Feb 2018
    Posts
    1

    Default Yast firewall module missing

    I had to upgrade from Leap to Tumbleweed so I could install the latest version of Docker. When I try to use yast to open up the firewall I get an error popup saying that

    YaST currently does not have a module for configuring firewall.

    Looking at software modules, I do see there is yast firewall module installed, so not sure why I'm getting this error.

    It recommends that I used firewall-config or firewall-cmd. This is a server and firewall-config is graphical. I can't find any online documentation for firewall-cmd. Since -h lists almost two screen fulls of options, I don't want to slog through the man pages on a non-graphical interface.

    This is a a throwaway test box so I just might disable or remove the firewall but that may not be the case for my next build.

    This is the i586 build

  2. #2

    Default Re: Yast firewall module missing

    Quote Originally Posted by gam View Post
    When I try to use yast to open up the firewall I get an error popup saying that

    YaST currently does not have a module for configuring firewall.

    Looking at software modules, I do see there is yast firewall module installed, so not sure why I'm getting this error.
    The reason is as the message says. YaST currently does not have a module for configuring the firewall.

    Tumbleweed switched to using firewalld instead of SuSEfirewall2, and a new YaST module to configure that hasn't been written yet.

    I cannot really help you with firewall-cmd.
    But there were threads about this already.
    See e.g. https://forums.opensuse.org/showthre...e-to-firewalld

  3. #3

    Default Re: Yast firewall module missing


  4. #4
    Join Date
    Jan 2018
    Location
    Canada
    Posts
    193

    Default Re: Yast firewall module missing

    Quote Originally Posted by wolfi323 View Post
    The reason is as the message says. YaST currently does not have a module for configuring the firewall.

    Tumbleweed switched to using firewalld instead of SuSEfirewall2, and a new YaST module to configure that hasn't been written yet.

    I cannot really help you with firewall-cmd.
    But there were threads about this already.
    See e.g. https://forums.opensuse.org/showthre...e-to-firewalld
    It’s actually the opposite, Yast now edits firewalld, but TW hasn’t switched to using it.

    See https://forums.opensuse.org/showthre...-not-configure

  5. #5

    Default Re: Yast firewall module missing

    Quote Originally Posted by doscott View Post
    It’s actually the opposite, Yast now edits firewalld, but TW hasn’t switched to using it.
    Nonsense.
    YaST does not have a firewall module, period.
    It just runs firewall-config currently (which only works in a graphical session, and not in text mode).

    And Tumbleweed does use firewalld by default since some weeks.
    But existing installations are not switched automatically when installing updates.
    Last edited by wolfi323; 14-Feb-2018 at 12:32.

  6. #6
    Join Date
    Jan 2018
    Location
    Canada
    Posts
    193

    Default Re: Yast firewall module missing

    Sorry for double post, not sure what happened.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •